summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-05-25 13:26:14 +0000
committerMark Wright <gienah@gentoo.org>2013-05-25 13:26:14 +0000
commite0a503a0788616410ad7c7f815f6ccc645669a90 (patch)
tree6f7a8de508c7fba84a7a3700ce95b17947ad8131 /dev-haskell
parentFix broken patch, thanks oblikoamorale (diff)
downloadgentoo-2-e0a503a0788616410ad7c7f815f6ccc645669a90.tar.gz
gentoo-2-e0a503a0788616410ad7c7f815f6ccc645669a90.tar.bz2
gentoo-2-e0a503a0788616410ad7c7f815f6ccc645669a90.zip
Bump text to 0.11.3.1
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/text/ChangeLog8
-rw-r--r--dev-haskell/text/metadata.xml29
-rw-r--r--dev-haskell/text/text-0.11.3.1.ebuild37
3 files changed, 72 insertions, 2 deletions
diff --git a/dev-haskell/text/ChangeLog b/dev-haskell/text/ChangeLog
index cc91be15c09f..89414bad7fe6 100644
--- a/dev-haskell/text/ChangeLog
+++ b/dev-haskell/text/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/text
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.28 2013/04/03 09:28:19 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.29 2013/05/25 13:26:14 gienah Exp $
+
+*text-0.11.3.1 (25 May 2013)
+
+ 25 May 2013; Mark Wright <gienah@gentoo.org> +text-0.11.3.1.ebuild,
+ metadata.xml:
+ Bump text to 0.11.3.1
03 Apr 2013; Mark Wright <gienah@gentoo.org> text-0.11.2.2.ebuild:
Fix Bug 462310 - dev-haskell/text-0.11.2.2 - setup: At least the following
diff --git a/dev-haskell/text/metadata.xml b/dev-haskell/text/metadata.xml
index cf71ecfc5565..875ecd3dd9e5 100644
--- a/dev-haskell/text/metadata.xml
+++ b/dev-haskell/text/metadata.xml
@@ -6,9 +6,36 @@
<email>haskell@gentoo.org</email>
</maintainer>
<longdescription>
- The 'Text' type represents Unicode character strings, in a time and
+
+ An efficient packed, immutable Unicode text type (both strict and
+ lazy), with a powerful loop fusion optimization framework.
+
+ The &#39;Text&#39; type represents Unicode character strings, in a time and
space-efficient manner. This package provides text processing
capabilities that are optimized for performance critical use, both
in terms of large data quantities and high speed.
+
+ The &#39;Text&#39; type provides character-encoding, type-safe case
+ conversion via whole-string case conversion functions. It also
+ provides a range of functions for converting &#39;Text&#39; values to and from
+ &#39;ByteStrings&#39;, using several standard encodings.
+
+ Efficient locale-sensitive support for text IO is also supported.
+
+ These modules are intended to be imported qualified, to avoid name
+ clashes with Prelude functions, e.g.
+
+ &gt; import qualified Data.Text as T
+
+ To use an extended and very rich family of functions for working
+ with Unicode text (including normalization, regular expressions,
+ non-standard encodings, text breaking, and locales), see
+ the @text-icu@ package:
+ &lt;http://hackage.haskell.org/package/text-icu&gt;
+
</longdescription>
+ <use>
+ <flag name='developer'>operate in developer mode</flag>
+ <flag name='integer-simple'>Use the simple integer library instead of GMP</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-haskell/text/text-0.11.3.1.ebuild b/dev-haskell/text/text-0.11.3.1.ebuild
new file mode 100644
index 000000000000..ef00c88c4ca5
--- /dev/null
+++ b/dev-haskell/text/text-0.11.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-0.11.3.1.ebuild,v 1.1 2013/05/25 13:26:14 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type."
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="developer integer-simple"
+
+RDEPEND=">=dev-haskell/deepseq-1.1.0.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.4
+ dev-haskell/random
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-hunit-0.2
+ >=dev-haskell/test-framework-quickcheck2-0.2
+ )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag developer developer) \
+ $(cabal_flag integer-simple integer-simple)
+}