summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-05-20 13:51:57 +0000
committerMark Wright <gienah@gentoo.org>2014-05-20 13:51:57 +0000
commiteb8d97f115f9d6a464c70de89fbf1fb5fc3d21be (patch)
treec475b84e786026bee03e9f520360cad86ea8042f /dev-haskell
parentBump pango to 0.12.5.3 (diff)
downloadgentoo-2-eb8d97f115f9d6a464c70de89fbf1fb5fc3d21be.tar.gz
gentoo-2-eb8d97f115f9d6a464c70de89fbf1fb5fc3d21be.tar.bz2
gentoo-2-eb8d97f115f9d6a464c70de89fbf1fb5fc3d21be.zip
Bump gtk to 0.12.5.7.2
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/gtk/ChangeLog8
-rw-r--r--dev-haskell/gtk/gtk-0.12.5.7.2.ebuild63
-rw-r--r--dev-haskell/gtk/metadata.xml15
3 files changed, 82 insertions, 4 deletions
diff --git a/dev-haskell/gtk/ChangeLog b/dev-haskell/gtk/ChangeLog
index 7f33d25f8ae1..43f1a86e61d2 100644
--- a/dev-haskell/gtk/ChangeLog
+++ b/dev-haskell/gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/gtk
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.19 2014/02/02 11:13:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/ChangeLog,v 1.20 2014/05/20 13:51:57 gienah Exp $
+
+*gtk-0.12.5.7.2 (20 May 2014)
+
+ 20 May 2014; Mark Wright <gienah@gentoo.org> +gtk-0.12.5.7.2.ebuild,
+ metadata.xml:
+ Bump gtk to 0.12.5.7.2
02 Feb 2014; Agostino Sarubbo <ago@gentoo.org> gtk-0.12.4-r1.ebuild:
Stable for sparc, wrt bug #488808
diff --git a/dev-haskell/gtk/gtk-0.12.5.7.2.ebuild b/dev-haskell/gtk/gtk-0.12.5.7.2.ebuild
new file mode 100644
index 000000000000..b6b8c0eff39c
--- /dev/null
+++ b/dev-haskell/gtk/gtk-0.12.5.7.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk/gtk-0.12.5.7.2.ebuild,v 1.1 2014/05/20 13:51:57 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+GTK_MAJ_VER="2"
+
+MY_PV="${PV%.*}"
+MY_P="${PN}-${MY_PV}"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library."
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${MY_PV}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="${GTK_MAJ_VER}/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+fmode-binary +gio"
+
+RDEPEND="fmode-binary? ( >=dev-haskell/glib-0.12.5.4:0=[profile?] <dev-haskell/glib-0.13:0=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.12.5.3:0=[profile?] <dev-haskell/pango-0.13:0=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:2 )
+ gio? ( >=dev-haskell/cairo-0.12.5.3:0=[profile?] <dev-haskell/cairo-0.13:0=[profile?]
+ >=dev-haskell/gio-0.12.5:0=[profile?] <dev-haskell/gio-0.13:0=[profile?]
+ >=dev-haskell/glib-0.12.5.4:0=[profile?] <dev-haskell/glib-0.13:0=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.12.5.3:0=[profile?] <dev-haskell/pango-0.13:0=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:2 )
+ !gio? ( fmode-binary? ( >=dev-haskell/cairo-0.12.5.3:0=[profile?] <dev-haskell/cairo-0.13:0=[profile?] )
+ !fmode-binary? ( >=dev-haskell/cairo-0.12.5.3:0=[profile?] <dev-haskell/cairo-0.13:0=[profile?]
+ >=dev-haskell/glib-0.12.5.4:0=[profile?] <dev-haskell/glib-0.13:0=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.12.5.3:0=[profile?] <dev-haskell/pango-0.13:0=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:2 ) )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ >=dev-haskell/gtk2hs-buildtools-0.12.5.1-r1:0=
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Upstream has this enabled, so we might as well force it enabled to be sure.
+ cabal_src_configure \
+ --flags=deprecated \
+ $(cabal_flag fmode-binary fmode-binary) \
+ $(cabal_flag gio have-giob)
+}
diff --git a/dev-haskell/gtk/metadata.xml b/dev-haskell/gtk/metadata.xml
index f48c536c1f81..4efa3eee1ddd 100644
--- a/dev-haskell/gtk/metadata.xml
+++ b/dev-haskell/gtk/metadata.xml
@@ -5,7 +5,16 @@
<maintainer>
<email>haskell@gentoo.org</email>
</maintainer>
- <use>
- <flag name="gio">Add glib's GIO bindings.</flag>
- </use>
+ <longdescription>
+ This is the core library of the Gtk2Hs suite of libraries for Haskell
+ based on Gtk+. Gtk+ is an extensive and mature multi-platform toolkit
+ for creating graphical user interfaces.
+ </longdescription>
+ <use>
+ <flag name='gio'>Depend on GIO package, thereby enabling certain features.</flag>
+ <flag name='fmode-binary'>Set the default file translation mode for
+ file I/O operations to _O_BINARY. Some GTK libraries open image
+ files without specifing binary mode. If you have trouble loading
+ gtk in ghci, then it may help to turn this option off.</flag>
+ </use>
</pkgmetadata>