summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-03-18 23:34:54 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-03-18 23:34:54 +0000
commitf78befd2a963c4a6facdb238122f42a6f48bd94d (patch)
treee7c91ba1d495030e48ebafee9437f94c033b73e0 /dev-haskell
parentFixed double .patch in epatch line. (diff)
downloadgentoo-2-f78befd2a963c4a6facdb238122f42a6f48bd94d.tar.gz
gentoo-2-f78befd2a963c4a6facdb238122f42a6f48bd94d.tar.bz2
gentoo-2-f78befd2a963c4a6facdb238122f42a6f48bd94d.zip
Cabal works with ghc-6.4 now.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/cabal/ChangeLog5
-rw-r--r--dev-haskell/cabal/cabal-0.5.ebuild18
2 files changed, 17 insertions, 6 deletions
diff --git a/dev-haskell/cabal/ChangeLog b/dev-haskell/cabal/ChangeLog
index bfcfd61c9482..3b964305a650 100644
--- a/dev-haskell/cabal/ChangeLog
+++ b/dev-haskell/cabal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-haskell/cabal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.1 2005/02/26 15:26:01 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.2 2005/03/18 23:34:54 kosmikus Exp $
+
+ 19 Mar 2005; Andres Loeh <kosmikus@gentoo.org> cabal-0.5.ebuild:
+ Cabal works with ghc-6.4 now.
*cabal-0.5 (26 Feb 2005)
diff --git a/dev-haskell/cabal/cabal-0.5.ebuild b/dev-haskell/cabal/cabal-0.5.ebuild
index 8fd2fcae014d..7ac94c15ec19 100644
--- a/dev-haskell/cabal/cabal-0.5.ebuild
+++ b/dev-haskell/cabal/cabal-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-0.5.ebuild,v 1.1 2005/02/26 15:26:01 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-0.5.ebuild,v 1.2 2005/03/18 23:34:54 kosmikus Exp $
inherit ghc-package
@@ -12,7 +12,7 @@ SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+IUSE="doc"
DEPEND="${DEPEND}
>=virtual/ghc-6.2"
@@ -45,9 +45,17 @@ cabal-pkg() {
./setup register \
--gen-script \
|| die "setup register failed"
- # sed on ghc-pkg when it isn't always called ghc-pkg
- # therefore, sed on a flag (we assume a lot about register.sh here)
- sed -i "s|--auto-ghci-libs\(.*\)$|--force \1 --config-file=\\\\|" register.sh
+ if ghc-cabal; then
+ # ghc supports Cabal; however, ghc-6.4 ships a slightly
+ # broken version, which we fix here
+ sed -i "s|update *$|update .installed-pkg-config|" register.sh
+ fi
+ # we want to manually build ghci-libs, so we remove the flag;
+ # instead, we force the issue and write to the local config file
+ # rather than the global one (which would cause an access violation
+ # at this point anyway)
+ sed -i "s|--auto-ghci-libs\(.*\)$|--force \1 -f\\\\|" \
+ register.sh
echo "${S}/$(ghc-localpkgconf)" >> register.sh
ghc-setup-pkg
./register.sh