summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-05-18 11:49:37 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-05-18 11:49:37 +0000
commit80d4a772079658704157a76de218115f621b19af (patch)
tree1fecbcebd41708402b264afef6c9631ef1a08d82 /dev-java/ant-contrib/ant-contrib-1.0_beta2.ebuild
parentput the distfile into my toucan dir for a few hours (diff)
downloadgentoo-2-80d4a772079658704157a76de218115f621b19af.tar.gz
gentoo-2-80d4a772079658704157a76de218115f621b19af.tar.bz2
gentoo-2-80d4a772079658704157a76de218115f621b19af.zip
version bump
Diffstat (limited to 'dev-java/ant-contrib/ant-contrib-1.0_beta2.ebuild')
-rw-r--r--dev-java/ant-contrib/ant-contrib-1.0_beta2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/ant-contrib/ant-contrib-1.0_beta2.ebuild b/dev-java/ant-contrib/ant-contrib-1.0_beta2.ebuild
new file mode 100644
index 000000000000..0ed28ff3f1a1
--- /dev/null
+++ b/dev-java/ant-contrib/ant-contrib-1.0_beta2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-contrib/ant-contrib-1.0_beta2.ebuild,v 1.1 2005/05/18 11:49:37 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="The Ant-Contrib project is a collection of tasks (and at one point maybe types and other tools) for Apache Ant."
+HOMEPAGE="http://ant-contrib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ant-contrib/${PN}-${PV/_beta/b}-src.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="jikes doc"
+DEPEND=">=dev-java/ant-1.6.2
+ >=virtual/jdk-1.4
+ >=dev-java/bcel-5.1
+ jikes? ( dev-java/jikes )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/lib
+ java-pkg_jarfrom bcel bcel.jar bcel-5.1.jar
+}
+
+src_compile() {
+ local antflags="jar -Dversion=${PV}"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} docs"
+ ant ${antflags} || die "failed to compile"
+}
+
+src_install() {
+ java-pkg_dojar build/lib/${PN}.jar
+
+ dodir /usr/share/ant-core/lib
+ dosym /usr/share/${PN}/lib/${PN}.jar /usr/share/ant-core/lib/
+
+ dodoc README.txt
+ use doc && java-pkg_dohtml -r build/docs
+ java-pkg_dohtml -r manual
+}