summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2006-01-23 06:07:40 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2006-01-23 06:07:40 +0000
commitb0c12e33a9cee209e0ded2d8ae405548b5b66983 (patch)
tree921f60ae9d13f0ca18ec8d636e610998ea501749 /dev-java/batik/batik-1.5.ebuild
parentRemoved old versions and revisions. (diff)
downloadgentoo-2-b0c12e33a9cee209e0ded2d8ae405548b5b66983.tar.gz
gentoo-2-b0c12e33a9cee209e0ded2d8ae405548b5b66983.tar.bz2
gentoo-2-b0c12e33a9cee209e0ded2d8ae405548b5b66983.zip
Removed old revision.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-java/batik/batik-1.5.ebuild')
-rw-r--r--dev-java/batik/batik-1.5.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-java/batik/batik-1.5.ebuild b/dev-java/batik/batik-1.5.ebuild
deleted file mode 100644
index 25f77277a03e..000000000000
--- a/dev-java/batik/batik-1.5.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/batik-1.5.ebuild,v 1.16 2006/01/08 18:21:16 nichoj Exp $
-
-inherit java-pkg
-
-DESCRIPTION="Batik is a Java(tm) technology based toolkit for applications or applets that want to use images in the Scalable Vector Graphics (SVG) format for various purposes, such as viewing, generation or manipulation."
-SRC_URI="mirror://apache/xml/batik/${PN}-src-${PV}.zip"
-HOMEPAGE="http://xml.apache.org/batik/"
-IUSE="doc"
-LICENSE="Apache-1.1"
-SLOT="1.5"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-
-RDEPEND=">=virtual/jre-1.3
- =dev-java/rhino-1.5*
- >=dev-java/xerces-2.6
- dev-java/xml-commons"
-DEPEND=">=virtual/jdk-1.3
- ${RDEPEND}
- app-arch/unzip
- dev-java/ant-core"
-
-S=${WORKDIR}/xml-batik
-
-src_unpack() {
- jar xf ${DISTDIR}/${PN}-src-${PV}.zip
- cd ${S}/lib
- rm -f *.jar
- java-pkg_jar-from xerces-2
- java-pkg_jar-from rhino-1.5
-}
-
-src_compile() {
- export ANT_OPTS=-Xmx256m
- local antflags="jars all-jar"
- ant ${antflags} || die "compile problem"
-}
-
-src_install() {
- java-pkg_dojar ${P}/batik*.jar
-
- cd ${P}/lib
- rm {js,x*}.jar
-
- # needed because batik expects this layout:
- # batik.jar lib/*.jar
- # there are hardcoded classpathes in the manifest :(
- for jar in *.jar
- do
- java-pkg_dojar ${jar}
- rm -f ${jar}
- ln -s ${DESTTREE}/share/${PN}-${SLOT}/lib/${jar} ${jar}
- done
-
- cd ${S}
- cp -ra ${P}/lib ${D}${DESTTREE}/share/${PN}-${SLOT}/lib/
-
- dodoc README LICENSE
- use doc && java-pkg_dohtml -r ${P}/docs/
-
- echo "#!/bin/sh" > ${PN}${SLOT}
- echo '${JAVA_HOME}/bin/java -classpath $(java-config -p batik-1.5,xerces-2,rhino-1.5) org.apache.batik.apps.svgbrowser.Main $*' >> ${PN}${SLOT}
- dobin ${PN}${SLOT}
-
-}