summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-02-06 13:59:13 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-02-06 13:59:13 +0000
commit64ab5ba07324010837d3fd1625b7d760360665c6 (patch)
treed95765e676f169e16533b5e4e256171d72e3dac3 /dev-java/bcpg
parentVersion bump to 1.50. (diff)
downloadgentoo-2-64ab5ba07324010837d3fd1625b7d760360665c6.tar.gz
gentoo-2-64ab5ba07324010837d3fd1625b7d760360665c6.tar.bz2
gentoo-2-64ab5ba07324010837d3fd1625b7d760360665c6.zip
Version bump to 1.50.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/bcpg')
-rw-r--r--dev-java/bcpg/ChangeLog11
-rw-r--r--dev-java/bcpg/bcpg-1.49-r1.ebuild (renamed from dev-java/bcpg/bcpg-1.49.ebuild)8
-rw-r--r--dev-java/bcpg/bcpg-1.50.ebuild85
3 files changed, 98 insertions, 6 deletions
diff --git a/dev-java/bcpg/ChangeLog b/dev-java/bcpg/ChangeLog
index 9624d642bc94..7d31178ec38a 100644
--- a/dev-java/bcpg/ChangeLog
+++ b/dev-java/bcpg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/bcpg
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcpg/ChangeLog,v 1.1 2013/07/05 10:39:36 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcpg/ChangeLog,v 1.2 2014/02/06 13:59:13 tomwij Exp $
+
+*bcpg-1.50 (06 Feb 2014)
+*bcpg-1.49-r1 (06 Feb 2014)
+
+ 06 Feb 2014; Tom Wijsman <TomWij@gentoo.org> +bcpg-1.49-r1.ebuild,
+ +bcpg-1.50.ebuild, -bcpg-1.49.ebuild:
+ Version bump to 1.50.
*bcpg-1.49 (05 Jul 2013)
diff --git a/dev-java/bcpg/bcpg-1.49.ebuild b/dev-java/bcpg/bcpg-1.49-r1.ebuild
index ee7d6a7cde17..bcfb882030d8 100644
--- a/dev-java/bcpg/bcpg-1.49.ebuild
+++ b/dev-java/bcpg/bcpg-1.49-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcpg/bcpg-1.49.ebuild,v 1.1 2013/07/05 10:39:36 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcpg/bcpg-1.49-r1.ebuild,v 1.1 2014/02/06 13:59:13 tomwij Exp $
EAPI="5"
@@ -23,8 +23,8 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux
RESTRICT="test"
COMMON_DEPEND="
- ~dev-java/bcmail-${PV}:0[test?]
- ~dev-java/bcprov-${PV}:0[test?]"
+ >=dev-java/bcmail-${PV}:0[test?]
+ >=dev-java/bcprov-${PV}:0[test?]"
DEPEND=">=virtual/jdk-1.5
app-arch/unzip
diff --git a/dev-java/bcpg/bcpg-1.50.ebuild b/dev-java/bcpg/bcpg-1.50.ebuild
new file mode 100644
index 000000000000..2e7ed0362811
--- /dev/null
+++ b/dev-java/bcpg/bcpg-1.50.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcpg/bcpg-1.50.ebuild,v 1.1 2014/02/06 13:59:13 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+
+# Tests are currently broken. Appears to need older version of bcprov; but since bcprov is not slotted, this can cause conflicts.
+# Needs further investigation; though, only a small part has tests and there are no tests for bcpg itself.
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-java/bcprov-${PV}:0[test?]"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ test? ( dev-java/junit:0 )
+ ${COMMON_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ default
+ cd "${S}"
+ unpack ./src.zip
+}
+
+java_prepare() {
+ mkdir "${S}"/classes
+
+ if use test ; then
+ java-pkg_jar-from --build-only junit
+ fi
+
+ java-pkg_jar-from bcprov
+}
+
+src_compile() {
+ find org -name "*.java" > "${T}"/src.list
+
+ local cp="bcprov.jar"
+ if use test ; then
+ cp="${cp}:junit.jar"
+ else
+ sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
+ fi
+
+ ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
+
+ cd "${S}"/classes || die
+
+ jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:junit.jar"
+ local pkg="org.bouncycastle"
+
+ java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
+
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/${PN}.jar
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}