summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-08-16 13:38:05 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-08-16 13:38:05 +0000
commit8ff7929e3ba76f242d617df633a8739170e4617e (patch)
tree9872cec1511bf03f034cfd9c1ce9351ee72ffc60 /dev-java/bcprov/bcprov-1.40.ebuild
parentkeyword ~amd64-fbsd, bug #481092 (diff)
downloadgentoo-2-8ff7929e3ba76f242d617df633a8739170e4617e.tar.gz
gentoo-2-8ff7929e3ba76f242d617df633a8739170e4617e.tar.bz2
gentoo-2-8ff7929e3ba76f242d617df633a8739170e4617e.zip
Removed SLOT 1.3 ebuild as dev-java/pdfbox no longer depends on it.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/bcprov/bcprov-1.40.ebuild')
-rw-r--r--dev-java/bcprov/bcprov-1.40.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-java/bcprov/bcprov-1.40.ebuild b/dev-java/bcprov/bcprov-1.40.ebuild
deleted file mode 100644
index 1560c292ffdf..000000000000
--- a/dev-java/bcprov/bcprov-1.40.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcprov/bcprov-1.40.ebuild,v 1.6 2013/07/12 02:38:50 patrick Exp $
-
-EAPI=2
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-ant-2
-
-MY_P="${PN}-jdk15-${PV/./}"
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="1.3"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-
-# The src_unpack find needs a new find
-# https://bugs.gentoo.org/show_bug.cgi?id=182276
-DEPEND=">=virtual/jdk-1.5
- userland_GNU? ( >=sys-apps/findutils-4.3 )
- app-arch/unzip"
-RDEPEND=">=virtual/jre-1.5"
-
-IUSE="userland_GNU"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- default
- cd "${S}"
- unpack ./src.zip
-
- # so that we don't need junit
- echo "Removing testcases' sources:"
- find . -path '*test/*.java' -print -delete \
- || die "Failed to delete testcases."
- find . -name '*Test*.java' -print -delete \
- || die "Failed to delete testcases."
-}
-
-src_compile() {
- mkdir "${S}/classes"
-
- find . -name "*.java" > "${T}/src.list"
- ejavac -encoding ISO-8859-1 -d "${S}/classes" "@${T}/src.list"
-
- cd "${S}/classes"
- jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
-}
-
-src_install() {
- java-pkg_dojar "${S}/${PN}.jar"
-
- use source && java-pkg_dosrc org
- use doc && java-pkg_dojavadoc docs
-}