summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-04 19:26:05 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-04 19:26:05 +0000
commit7f91945e3d1d2ebd967ca7b5f8ab06a0739dc395 (patch)
treed090ee906f831ff44899abeece1cd048fdd4a293 /dev-java/bsh/bsh-2.0_beta4-r1.ebuild
parentStable on sparc wrt #138278 (diff)
downloadgentoo-2-7f91945e3d1d2ebd967ca7b5f8ab06a0739dc395.tar.gz
gentoo-2-7f91945e3d1d2ebd967ca7b5f8ab06a0739dc395.tar.bz2
gentoo-2-7f91945e3d1d2ebd967ca7b5f8ab06a0739dc395.zip
Revision bump to support new Java system.
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'dev-java/bsh/bsh-2.0_beta4-r1.ebuild')
-rw-r--r--dev-java/bsh/bsh-2.0_beta4-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/bsh/bsh-2.0_beta4-r1.ebuild b/dev-java/bsh/bsh-2.0_beta4-r1.ebuild
new file mode 100644
index 000000000000..f20a1ab145d1
--- /dev/null
+++ b/dev-java/bsh/bsh-2.0_beta4-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bsh/bsh-2.0_beta4-r1.ebuild,v 1.1 2006/07/04 19:26:05 nichoj Exp $
+
+inherit java-pkg-2 eutils java-ant-2
+
+MY_PV=${PV/_beta/b}
+MY_DIST=${PN}-${MY_PV}-src.jar
+
+DESCRIPTION="BeanShell: A small embeddable Java source interpreter"
+HOMEPAGE="http://www.beanshell.org"
+SRC_URI="http://www.beanshell.org/${MY_DIST} mirror://gentoo/beanshell-icon.png"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc readline source"
+
+RDEPEND=">=virtual/jdk-1.4
+ =dev-java/bsf-2.3*
+ =dev-java/servletapi-2.4*
+ readline? ( dev-java/libreadline-java )"
+DEPEND="${RDEPEND}
+ source? ( app-arch/zip )
+ >=dev-java/ant-core-1.6"
+
+S=${WORKDIR}/BeanShell-${MY_PV}
+
+ant_src_unpack() {
+ jar xf ${DISTDIR}/${MY_DIST} || die "failed to unpack"
+ cd ${S}
+
+ epatch ${FILESDIR}/bsh${MY_PV}-build.patch
+
+ cp ${FILESDIR}/bsh.Console ${FILESDIR}/bsh.Interpreter ${S}
+
+ use readline && epatch ${FILESDIR}/bsh2-readline.patch
+}
+
+src_compile() {
+ local classpath="bsf-2.3,servletapi-2.4"
+ use readline && classpath="${classpath},libreadline-java"
+
+ eant -lib $(java-pkg_getjars ${classpath}) $(use_doc) jarall
+}
+
+src_install() {
+ java-pkg_newjar ${S}/dist/${P/_beta/b}.jar
+
+ use source && java-pkg_dosrc src/bsh
+
+ java-pkg_dolauncher bsh-console --main bsh.Console
+ java-pkg_dolauncher bsh-interpreter --main bsh.Interpreter
+
+ use doc && java-pkg_dohtml -r ${S}/javadoc/*
+
+ newicon ${DISTDIR}/beanshell-icon.png beanshell.png
+
+ make_desktop_entry bsh-console "BeanShell Prompt" beanshell
+}