summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2006-11-15 04:03:55 +0000
committerWilliam Thomson <wltjr@gentoo.org>2006-11-15 04:03:55 +0000
commit87f1fe4e9559370aa67f4c048b55157379917ea1 (patch)
treec5e48fe109e86a93f340e24f70dbbd1cbcbc671e /dev-java/commons-io
parentadding 0.1.2 to the tree, thanks to pierre for the help in tracking something... (diff)
downloadgentoo-2-87f1fe4e9559370aa67f4c048b55157379917ea1.tar.gz
gentoo-2-87f1fe4e9559370aa67f4c048b55157379917ea1.tar.bz2
gentoo-2-87f1fe4e9559370aa67f4c048b55157379917ea1.zip
Revision bump, moved ebuild from overlay.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/ChangeLog8
-rw-r--r--dev-java/commons-io/commons-io-1.2.ebuild54
-rw-r--r--dev-java/commons-io/files/digest-commons-io-1.23
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-java/commons-io/ChangeLog b/dev-java/commons-io/ChangeLog
index 733de9ec9dfb..ee2e0a687fb4 100644
--- a/dev-java/commons-io/ChangeLog
+++ b/dev-java/commons-io/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-io
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.5 2006/10/09 02:27:30 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.6 2006/11/15 04:03:54 wltjr Exp $
+
+*commons-io-1.2 (15 Nov 2006)
+
+ 15 Nov 2006; William L. Thomson Jr. <wltjr@gentoo.org>
+ +commons-io-1.2.ebuild:
+ Revision bump, moved ebuild from overlay.
09 Oct 2006; Joshua Nichols <nichoj@gentoo.org> commons-io-1.1-r1.ebuild:
Added ~ppc64.
diff --git a/dev-java/commons-io/commons-io-1.2.ebuild b/dev-java/commons-io/commons-io-1.2.ebuild
new file mode 100644
index 000000000000..1f72cd59f603
--- /dev/null
+++ b/dev-java/commons-io/commons-io-1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-1.2.ebuild,v 1.1 2006/11/15 04:03:54 wltjr Exp $
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P="${P}-src"
+DESCRIPTION="Commons-IO contains utility classes , stream implementations, file filters , and endian classes."
+HOMEPAGE="http://jakarta.apache.org/commons/io"
+SRC_URI="mirror://apache/jakarta/commons/io/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc source"
+
+DEPEND="dev-java/ant-core
+ source? ( app-arch/zip )
+ >=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+
+S="${WORKDIR}/${MY_P}"
+
+# junit tests are disabled for now.
+# one of the tests (FileUtilsCleanDirectoryTestCase) always fails when run as
+# root.
+# TODO report upstream
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ mkdir -p build/lib
+ cd build/lib
+# use junit && java-pkg_jar-from junit
+}
+
+src_compile() {
+ local antflags="jar -Dlibdir=build/lib"
+ use doc && antflags="${antflags} javadoc -Djavadocdir=dist/docs/api"
+# use junit && antflags="${antflags} test"
+ eant ${antflags} || die "compile problem"
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+ dohtml PROPOSAL.html STATUS.html usersguide.html
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-io/files/digest-commons-io-1.2 b/dev-java/commons-io/files/digest-commons-io-1.2
new file mode 100644
index 000000000000..4a5c828bb195
--- /dev/null
+++ b/dev-java/commons-io/files/digest-commons-io-1.2
@@ -0,0 +1,3 @@
+MD5 d45b0c7c0fae36c3be99df86354d4323 commons-io-1.2-src.tar.gz 205563
+RMD160 cd1914721f5c2d460f0fe4e7ba2e1e23099bff2a commons-io-1.2-src.tar.gz 205563
+SHA256 9c9983fed8b5c633b156e429eb7885e70d6268eb23b00c16366702158daf8a22 commons-io-1.2-src.tar.gz 205563