summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-05-04 16:59:57 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-05-04 16:59:57 +0000
commitb11d967198262fcbc291254d4ead7f97d4cbf88b (patch)
tree808ed94652a11ecbe047a4b7a9982b51af6bdaca /dev-java/commons-io
parentstable on amd64, ppc and x86 (diff)
downloadgentoo-2-b11d967198262fcbc291254d4ead7f97d4cbf88b.tar.gz
gentoo-2-b11d967198262fcbc291254d4ead7f97d4cbf88b.tar.bz2
gentoo-2-b11d967198262fcbc291254d4ead7f97d4cbf88b.zip
stable on amd64 and x86, added ~ppc to KEYWORDS. introduced support for the source useflag.
(Portage version: 2.0.51.21)
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/ChangeLog6
-rw-r--r--dev-java/commons-io/Manifest14
-rw-r--r--dev-java/commons-io/commons-io-1.0.ebuild25
3 files changed, 22 insertions, 23 deletions
diff --git a/dev-java/commons-io/ChangeLog b/dev-java/commons-io/ChangeLog
index 05417bde86bf..2b8f0cb7361c 100644
--- a/dev-java/commons-io/ChangeLog
+++ b/dev-java/commons-io/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-io
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.1 2005/03/09 23:11:59 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.2 2005/05/04 16:59:57 luckyduck Exp $
+
+ 04 May 2005; Jan Brinkmann <luckyduck@gentoo.org> commons-io-1.0.ebuild:
+ stable on amd64 and x86, added ~ppc to KEYWORDS. introduced support for the
+ source useflag.
*commons-io-1.0 (10 Mar 2005)
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
index b8da12b4e606..8d9584500d5b 100644
--- a/dev-java/commons-io/Manifest
+++ b/dev-java/commons-io/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 e659cda0673d94bdf71b14673c594ce1 commons-io-1.0.ebuild 1332
-MD5 76609778ecbe7c4c068baa0c766be93c ChangeLog 479
+MD5 efa5f86b3a1e80f9e7e28589a46ae693 commons-io-1.0.ebuild 1398
+MD5 ee8b72cb87082190126218ec9657f82c ChangeLog 651
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 5c8037358c1bd4650695b23df55e89fe files/digest-commons-io-1.0 70
MD5 d1ce414440c549e8c25716008f452630 files/commons-io-1.0-gentoo.diff 932
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCL4Lx06ebR+OMO78RAhF5AJ44UzqSWa59A3O/ROTVsUMa+mQzUwCfaAJt
-QUKg4se6mTXoYMo9uisMgJ4=
-=E8tU
------END PGP SIGNATURE-----
diff --git a/dev-java/commons-io/commons-io-1.0.ebuild b/dev-java/commons-io/commons-io-1.0.ebuild
index 6761f3360cb0..3db368331dbb 100644
--- a/dev-java/commons-io/commons-io-1.0.ebuild
+++ b/dev-java/commons-io/commons-io-1.0.ebuild
@@ -1,20 +1,24 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-1.0.ebuild,v 1.1 2005/03/09 23:11:59 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-1.0.ebuild,v 1.2 2005/05/04 16:59:57 luckyduck Exp $
inherit java-pkg eutils
-DESCRIPTION=" Commons-IO contains utility classes , stream implementations, file filters , and endian classes."
+
+DESCRIPTION="Commons-IO contains utility classes , stream implementations, file filters , and endian classes."
HOMEPAGE="http://jakarta.apache.org/commons/io"
SRC_URI="mirror://apache/jakarta/commons/io/source/${PN}-${PV}-src.tar.gz"
-DEPEND="dev-java/ant
- jikes? ( >=dev-java/jikes-1.21 )
- junit? ( >=dev-java/junit-3.8 )
- >=virtual/jdk-1.3"
-RDEPEND=">=virtual/jre-1.3"
+
LICENSE="Apache-1.1"
SLOT="1"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc jikes junit"
+KEYWORDS="x86 amd64 ~ppc"
+IUSE="doc jikes junit source"
+
+DEPEND="jikes? ( >=dev-java/jikes-1.21 )
+ junit? ( >=dev-java/junit-3.8 dev-java/ant )
+ !junit? ( dev-java/ant-core )
+ source? ( app-arch/zip )
+ >=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
src_unpack() {
unpack ${A}
@@ -23,7 +27,7 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-${PV}-gentoo.diff
mkdir -p target/lib
cd target/lib
- java-pkg_jar-from junit junit.jar || die "Could not link to junit"
+ java-pkg_jar-from junit
}
src_compile() {
@@ -41,4 +45,5 @@ src_install() {
dodoc RELEASE-NOTES.txt
dohtml PROPOSAL.html STATUS.html usersguide.html
use doc && java-pkg_dohtml -r dist/docs/*
+ use source && java-pkg_dosrc src/java/*
}