summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2007-05-31 19:12:52 +0000
committerWilliam Thomson <wltjr@gentoo.org>2007-05-31 19:12:52 +0000
commitbd626eed4df5f91f90a424eb7db8c28cfa229aaf (patch)
treeaac91e4168ce07f063ffbfcccfad45e0d0a5af7d /dev-java/edtftpj/edtftpj-1.5.5.ebuild
parentAdded menu entry. Bug #160243 (diff)
downloadgentoo-2-bd626eed4df5f91f90a424eb7db8c28cfa229aaf.tar.gz
gentoo-2-bd626eed4df5f91f90a424eb7db8c28cfa229aaf.tar.bz2
gentoo-2-bd626eed4df5f91f90a424eb7db8c28cfa229aaf.zip
Bumped to latest release
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-java/edtftpj/edtftpj-1.5.5.ebuild')
-rw-r--r--dev-java/edtftpj/edtftpj-1.5.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-java/edtftpj/edtftpj-1.5.5.ebuild b/dev-java/edtftpj/edtftpj-1.5.5.ebuild
new file mode 100644
index 000000000000..1362af21f2fe
--- /dev/null
+++ b/dev-java/edtftpj/edtftpj-1.5.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/edtftpj/edtftpj-1.5.5.ebuild,v 1.1 2007/05/31 19:12:52 wltjr Exp $
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="FTP client library written in Java"
+SRC_URI="http://www.enterprisedt.com/products/edtftpj/download/${P}.zip"
+HOMEPAGE="http://www.enterprisedt.com"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=virtual/jre-1.4
+ dev-java/junit"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack "${A}"
+ find "${S}" -name "*.jar" | xargs rm -fr
+ rm "${S}/doc/LICENSE.TXT" || die "Failed to remove LICENSE.TXT"
+}
+
+src_compile() {
+ cd ${S}/src
+ eant jar -Dftp.classpath=$(java-pkg_getjars junit) $(use_doc javadocs)
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+
+ use doc && java-pkg_dojavadoc build/doc/api
+ use source && java-pkg_dosrc src/com
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/*.{java,txt} || die "Failed to install examples."
+ fi
+
+ dodoc doc/*.TXT doc/*.pdf || die
+}