summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Thomson <wltjr@gentoo.org>2006-09-26 21:58:05 +0000
committerWilliam Thomson <wltjr@gentoo.org>2006-09-26 21:58:05 +0000
commitdc554a1e515235d8699af5588aa949e8b944a8da (patch)
treec25af44a15d9039d26c501d6a225ef98cd754871 /dev-java/edtftpj
parentStable on hppa wrt #145996 (diff)
downloadgentoo-2-dc554a1e515235d8699af5588aa949e8b944a8da.tar.gz
gentoo-2-dc554a1e515235d8699af5588aa949e8b944a8da.tar.bz2
gentoo-2-dc554a1e515235d8699af5588aa949e8b944a8da.zip
Rev bump to 1.5.3, took over package maintenance.
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'dev-java/edtftpj')
-rw-r--r--dev-java/edtftpj/edtftpj-1.5.3.ebuild51
-rw-r--r--dev-java/edtftpj/files/digest-edtftpj-1.5.22
-rw-r--r--dev-java/edtftpj/files/digest-edtftpj-1.5.33
-rw-r--r--dev-java/edtftpj/metadata.xml21
4 files changed, 76 insertions, 1 deletions
diff --git a/dev-java/edtftpj/edtftpj-1.5.3.ebuild b/dev-java/edtftpj/edtftpj-1.5.3.ebuild
new file mode 100644
index 000000000000..482026391ca6
--- /dev/null
+++ b/dev-java/edtftpj/edtftpj-1.5.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/edtftpj/edtftpj-1.5.3.ebuild,v 1.1 2006/09/26 21:58:05 wltjr Exp $
+
+inherit java-pkg
+
+DESCRIPTION="FTP client library written in Java"
+SRC_URI="http://www.enterprisedt.com/products/edtftpj/download/${P}.zip"
+HOMEPAGE="http://www.enterprisedt.com"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc examples jikes source"
+
+RDEPEND=">=virtual/jre-1.4
+ dev-java/junit"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ ${RDEPEND}
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
+
+src_unpack() {
+ unpack "${A}"
+ find "${S}" -name "*.jar" | xargs rm -fr
+ rm "${S}/doc/LICENSE.TXT" || die "Failed to remove LICENSE.TXT"
+}
+
+src_compile() {
+ cd ${S}/src
+ local antflags="jar -Dftp.classpath=$(java-pkg_getjars junit)"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadocs"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ use doc && java-pkg_dohtml -r build/doc/api
+ use source && java-pkg_dosrc src/com
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/*.{java,txt} || die "Failed to install examples."
+ fi
+
+ dodoc doc/*.TXT doc/*.pdf
+
+ java-pkg_dojar lib/*.jar
+}
diff --git a/dev-java/edtftpj/files/digest-edtftpj-1.5.2 b/dev-java/edtftpj/files/digest-edtftpj-1.5.2
index 3ff8cd17d22f..accb4812524d 100644
--- a/dev-java/edtftpj/files/digest-edtftpj-1.5.2
+++ b/dev-java/edtftpj/files/digest-edtftpj-1.5.2
@@ -1 +1,3 @@
MD5 1e6bd7e2ebf054f168a6d00ae37995b5 edtftpj-1.5.2.tar.gz 713160
+RMD160 600e4c7b3f631ae610b468a1be7930422e94297c edtftpj-1.5.2.tar.gz 713160
+SHA256 5731f8531c77587115e8fec406de131e5ce3c384b04d150b7f4d151547906f23 edtftpj-1.5.2.tar.gz 713160
diff --git a/dev-java/edtftpj/files/digest-edtftpj-1.5.3 b/dev-java/edtftpj/files/digest-edtftpj-1.5.3
new file mode 100644
index 000000000000..445fe3481383
--- /dev/null
+++ b/dev-java/edtftpj/files/digest-edtftpj-1.5.3
@@ -0,0 +1,3 @@
+MD5 5baa52cd0aedfb6f94a5a161d2ca61ef edtftpj-1.5.3.zip 974094
+RMD160 15d3e60a2f75f9284c19520a3bf8e38ed1c5a1a2 edtftpj-1.5.3.zip 974094
+SHA256 c7d12fdb001448f5968743acc195672ec6c4833168a974437d3a08922ddef4d5 edtftpj-1.5.3.zip 974094
diff --git a/dev-java/edtftpj/metadata.xml b/dev-java/edtftpj/metadata.xml
index 838c00a4a448..f70e3719d0e9 100644
--- a/dev-java/edtftpj/metadata.xml
+++ b/dev-java/edtftpj/metadata.xml
@@ -1,5 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>java</herd>
+
+ <herd>java</herd>
+
+ <maintainer>
+ <email>wltjr@gentoo.org</email>
+ <name>William L. Thomson Jr.</name>
+ </maintainer>
+
+ <longdescription>
+ edtFTPj is the first choice of Java developers worldwide
+ for incorporating FTP functionality into their applications.
+ edtFTPj is Open Source, licensed under the LGPL, the GNU
+ Lesser General Public License. This means you can freely
+ embed edtFTPj into your commercial Java applications,
+ subject to the normal LGPL restrictions. Unrestricted
+ (non-GPL) source licenses can be also be purchased. edtFTPj
+ has been downloaded over 100,000 times since its first
+ release, and is in use in thousands of companies worldwide.
+ </longdescription>
+
</pkgmetadata>