summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-10-04 13:59:12 +0000
committerVlastimil Babka <caster@gentoo.org>2009-10-04 13:59:12 +0000
commitaa38996606380fbd14fb66db77948303c6445119 (patch)
tree6db05da8136aaadc9311a37976f17bb3b47b2eaf /dev-java/gnu-classpath-inetlib
parentread stable keywords that have been accidentally removed (diff)
downloadgentoo-2-aa38996606380fbd14fb66db77948303c6445119.tar.gz
gentoo-2-aa38996606380fbd14fb66db77948303c6445119.tar.bz2
gentoo-2-aa38996606380fbd14fb66db77948303c6445119.zip
Revbump to remove jessie dependency, since it's not needed with 1.4+ JDKs.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/gnu-classpath-inetlib')
-rw-r--r--dev-java/gnu-classpath-inetlib/ChangeLog12
-rw-r--r--dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.0-r3.ebuild64
-rw-r--r--dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild58
3 files changed, 132 insertions, 2 deletions
diff --git a/dev-java/gnu-classpath-inetlib/ChangeLog b/dev-java/gnu-classpath-inetlib/ChangeLog
index 7c018445ffec..6be1522fe4f0 100644
--- a/dev-java/gnu-classpath-inetlib/ChangeLog
+++ b/dev-java/gnu-classpath-inetlib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/gnu-classpath-inetlib
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath-inetlib/ChangeLog,v 1.23 2007/05/26 22:45:41 betelgeuse Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath-inetlib/ChangeLog,v 1.24 2009/10/04 13:59:12 caster Exp $
+
+*gnu-classpath-inetlib-1.1-r3 (04 Oct 2009)
+*gnu-classpath-inetlib-1.0-r3 (04 Oct 2009)
+
+ 04 Oct 2009; Vlastimil Babka <caster@gentoo.org>
+ +gnu-classpath-inetlib-1.0-r3.ebuild,
+ +gnu-classpath-inetlib-1.1-r3.ebuild:
+ Revbump to remove jessie dependency, since it's not needed with 1.4+ JDKs.
26 May 2007; Petteri Räty <betelgeuse@gentoo.org>
gnu-classpath-inetlib-1.0-r2.ebuild, gnu-classpath-inetlib-1.1-r2.ebuild:
diff --git a/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.0-r3.ebuild b/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.0-r3.ebuild
new file mode 100644
index 000000000000..d42f8f282b86
--- /dev/null
+++ b/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.0-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.0-r3.ebuild,v 1.1 2009/10/04 13:59:12 caster Exp $
+
+inherit java-pkg-2
+
+MY_PN="inetlib"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Network extensions library for GNU classpath and classpathx"
+HOMEPAGE="http://www.gnu.org/software/classpath/"
+SRC_URI="mirror://gnu/classpath/${MY_P}.tar.gz"
+LICENSE="GPL-2-with-linking-exception"
+SLOT="1.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/gnu-crypto-2.0.1"
+DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+# TODO we could give configure the lib dir on the live filesystem
+# instead of populating ${S}/ext with the jars we need -nichoj
+# TODO fix jikes support. Related to bug #89711
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-jdk15.patch"
+
+ mkdir ext && cd ext
+ java-pkg_jar-from gnu-crypto javax-security.jar javax-security-auth-callback.jar
+ java-pkg_jar-from gnu-crypto javax-security.jar javax-security-sasl.jar
+ # fake jar to shut build system up, jsse is part of JDK's classpath already
+ ln -s javax-security-sasl.jar jsse.jar
+}
+
+src_compile() {
+ econf \
+ --enable-smtp \
+ --enable-imap \
+ --enable-pop3 \
+ --enable-nntp \
+ --enable-ftp \
+ --enable-gopher \
+ --with-jsse-jar=${S}/ext \
+ --with-javax-security-auth-callback-jar=${S}/ext \
+ --with-javax-security-sasl-jar=${S}/ext \
+ || die "econf failed"
+ # https://bugs.gentoo.org/show_bug.cgi?id=179897
+ emake JAVACFLAGS="${JAVACFLAGS}" -j1 || die "emake failed"
+ if use doc ; then
+ emake -j1 javadoc || die "emake javadoc failed"
+ fi
+}
+
+src_install() {
+ einstall || die
+ rm -rf ${D}/usr/share/java
+ java-pkg_dojar ${MY_PN}.jar
+ use doc && java-pkg_dojavadoc docs
+ dodoc AUTHORS NEWS README || die
+}
diff --git a/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild b/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild
new file mode 100644
index 000000000000..926d19b614cb
--- /dev/null
+++ b/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath-inetlib/gnu-classpath-inetlib-1.1-r3.ebuild,v 1.1 2009/10/04 13:59:12 caster Exp $
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="inetlib"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Network extensions library for GNU classpath and classpathx"
+HOMEPAGE="http://www.gnu.org/software/classpath/"
+SRC_URI="mirror://gnu/classpath/${MY_P}.tar.gz"
+LICENSE="GPL-2-with-linking-exception"
+SLOT="1.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/gnu-crypto-2.0.1"
+DEPEND=">=virtual/jdk-1.3
+ ${RDEPEND}"
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-jdk15.patch"
+
+ mkdir ext && cd ext
+ java-pkg_jar-from gnu-crypto
+ # fake jar to shut build system up, jsse is part of JDK's classpath already
+ ln -s javax-security.jar jsse.jar
+}
+
+src_compile() {
+ econf \
+ --enable-smtp \
+ --enable-imap \
+ --enable-pop3 \
+ --enable-nntp \
+ --enable-ftp \
+ --enable-gopher \
+ --with-jsse-jar=${S}/ext \
+ --with-javax-security-jar=${S}/ext \
+ || die
+ # https://bugs.gentoo.org/show_bug.cgi?id=179897
+ emake JAVACFLAGS="${JAVACFLAGS}" -j1 || die
+ if use doc ; then
+ emake -j1 javadoc || die
+ fi
+}
+
+src_install() {
+ einstall || die
+ rm -rf ${D}/usr/share/java
+ java-pkg_dojar inetlib.jar
+ use doc && java-pkg_dojavadoc docs
+ dodoc AUTHORS NEWS README || die
+}