summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-06-10 10:37:28 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-06-10 10:37:28 +0000
commit1fb6c882a7d9f7e0cf40d40307a1abbd637f26f7 (patch)
treeddb7733eeb6b1682790b5b8cd0f995272058695a /dev-java/icu4j
parentRemove applied patches. (diff)
downloadgentoo-2-1fb6c882a7d9f7e0cf40d40307a1abbd637f26f7.tar.gz
gentoo-2-1fb6c882a7d9f7e0cf40d40307a1abbd637f26f7.tar.bz2
gentoo-2-1fb6c882a7d9f7e0cf40d40307a1abbd637f26f7.zip
Version bump. #339526
Require at least jdk6. #361593 Build javadocs instead of downloading them. Add use examples to install samples and demos. No longer force javac as compiler. No longer disable any tests. (Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/icu4j')
-rw-r--r--dev-java/icu4j/ChangeLog14
-rw-r--r--dev-java/icu4j/icu4j-49.1.ebuild49
2 files changed, 61 insertions, 2 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index 8ab829474b98..4c31d2b7de30 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-java/icu4j
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.55 2011/12/31 12:32:47 sera Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.56 2012/06/10 10:37:28 sera Exp $
+
+*icu4j-49.1 (10 Jun 2012)
+
+ 10 Jun 2012; Ralph Sennhauser <sera@gentoo.org> +icu4j-49.1.ebuild:
+ Version bump. #339526
+ Require at least jdk6. #361593
+ Build javadocs instead of downloading them.
+ Add use examples to install samples and demos.
+ No longer force javac as compiler.
+ No longer disable any tests.
31 Dec 2011; Ralph Sennhauser <sera@gentoo.org> icu4j-3.8.1-r1.ebuild,
icu4j-4.0.1.1.ebuild, icu4j-4.2.1.1.ebuild, icu4j-4.4.1.1.ebuild,
diff --git a/dev-java/icu4j/icu4j-49.1.ebuild b/dev-java/icu4j/icu4j-49.1.ebuild
new file mode 100644
index 000000000000..b16e80f47a53
--- /dev/null
+++ b/dev-java/icu4j/icu4j-49.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-49.1.ebuild,v 1.1 2012/06/10 10:37:28 sera Exp $
+
+EAPI=4
+
+# testdata.jar, icudata.jar and icutzdata.jar do not contain *.class files
+# but *.res files. These *.res data files are needed to build the final jar.
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A set of Java libraries providing Unicode and Globalization support."
+HOMEPAGE="http://www.icu-project.org/"
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${PV//./_}.tgz"
+
+LICENSE="icu"
+SLOT="49"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+# Beware of jdk version dependant code #361593
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+JAVA_PKG_BSFIX_NAME+=" common-targets.xml"
+
+EANT_DOC_TARGET="docs"
+
+EANT_TEST_TARGET="check"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+ java-pkg_dojar "${PN}-charset.jar"
+ java-pkg_dojar "${PN}-localespi.jar"
+
+ dohtml readme.html
+
+ use doc && java-pkg_dojavadoc doc
+ use examples && java-pkg_doexamples demos samples
+ use source && java-pkg_dosrc main/classes/*/src/com
+}