summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-16 12:06:52 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-16 12:06:52 +0000
commit88e5b00616866e211d5305d047aba78167c7a234 (patch)
tree1b6419a59449580fc635429b6d939d061f4ec192 /dev-java/infobus-bin
parentremove older, keyword x86 (diff)
downloadgentoo-2-88e5b00616866e211d5305d047aba78167c7a234.tar.gz
gentoo-2-88e5b00616866e211d5305d047aba78167c7a234.tar.bz2
gentoo-2-88e5b00616866e211d5305d047aba78167c7a234.zip
cleaner
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/infobus-bin')
-rw-r--r--dev-java/infobus-bin/infobus-bin-1.2.ebuild28
1 files changed, 13 insertions, 15 deletions
diff --git a/dev-java/infobus-bin/infobus-bin-1.2.ebuild b/dev-java/infobus-bin/infobus-bin-1.2.ebuild
index f336180411d3..174d859b63b6 100644
--- a/dev-java/infobus-bin/infobus-bin-1.2.ebuild
+++ b/dev-java/infobus-bin/infobus-bin-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/infobus-bin/infobus-bin-1.2.ebuild,v 1.5 2005/07/09 16:35:35 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/infobus-bin/infobus-bin-1.2.ebuild,v 1.6 2005/07/16 12:06:52 axxo Exp $
inherit java-pkg
@@ -12,30 +12,28 @@ LICENSE="infobus"
SLOT="0"
RESTRICT="fetch"
DEPEND=">=app-arch/unzip-5.50-r1"
-RDEPEND=">=virtual/jdk-1.2"
+RDEPEND=">=virtual/jre-1.2"
IUSE="doc"
S=${WORKDIR}
pkg_nofetch() {
- einfo
- einfo " Due to license restrictions, we cannot fetch the"
- einfo " distributables automagically."
- einfo
- einfo " 1. Visit ${HOMEPAGE}"
- einfo " 2. Download ${At}"
- einfo " 3. Move file to ${DISTDIR}"
- einfo " 4. Run emerge on this package again to complete"
- einfo
- die "User must manually download distfile"
+ einfo
+ einfo " Due to license restrictions, we cannot fetch the"
+ einfo " distributables automagically."
+ einfo
+ einfo " 1. Visit ${HOMEPAGE}"
+ einfo " 2. Download ${At}"
+ einfo " 3. Move file to ${DISTDIR}"
+ einfo " 4. Run emerge on this package again to complete"
+ einfo
+ die "User must manually download distfile"
}
src_unpack() {
- unzip -qq ${DISTDIR}/${A}
+ unzip -qq ${DISTDIR}/${A} || die
}
-src_compile() { :; }
-
src_install() {
use doc && java-pkg_dohtml -r doc/
dohtml *.html