summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2007-10-13 20:29:01 +0000
committerAlistair Bush <ali_bush@gentoo.org>2007-10-13 20:29:01 +0000
commit1d77978ff8de306f91477a9f0dd26a2ba643199c (patch)
treefbb5b4948827d06cddaf037bc1a8fa724578a42b /dev-java/java-config
parent2.1.3.13 bump. This fixes bugs #171272, #183808, #195370, and #195527. (diff)
downloadgentoo-2-1d77978ff8de306f91477a9f0dd26a2ba643199c.tar.gz
gentoo-2-1d77978ff8de306f91477a9f0dd26a2ba643199c.tar.bz2
gentoo-2-1d77978ff8de306f91477a9f0dd26a2ba643199c.zip
Version bump java-config to fix #195382
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-java/java-config')
-rw-r--r--dev-java/java-config/ChangeLog7
-rw-r--r--dev-java/java-config/files/digest-java-config-2.1.23
-rw-r--r--dev-java/java-config/java-config-2.1.2.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-java/java-config/ChangeLog b/dev-java/java-config/ChangeLog
index 3b9eba44e634..5d156ab6a423 100644
--- a/dev-java/java-config/ChangeLog
+++ b/dev-java/java-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/java-config
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.173 2007/10/08 17:27:01 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.174 2007/10/13 20:29:01 ali_bush Exp $
+
+*java-config-2.1.2 (13 Oct 2007)
+
+ 13 Oct 2007; <alistair@gentoo.org> +java-config-2.1.2.ebuild:
+ Version bump java-config for fix #195382 and various other improvements.
*java-config-2.1.1 (08 Oct 2007)
diff --git a/dev-java/java-config/files/digest-java-config-2.1.2 b/dev-java/java-config/files/digest-java-config-2.1.2
new file mode 100644
index 000000000000..bb43880110eb
--- /dev/null
+++ b/dev-java/java-config/files/digest-java-config-2.1.2
@@ -0,0 +1,3 @@
+MD5 e7a1b8fc8173b52d77c2459c6243cd48 java-config-2.1.2.tar.bz2 21333
+RMD160 8e8f16e4ce2da5991853e15ca07f0c8bd4c3ee6d java-config-2.1.2.tar.bz2 21333
+SHA256 c639085040aab839abb9ef46da8713390173d7c021568b4a43c90530ae630b29 java-config-2.1.2.tar.bz2 21333
diff --git a/dev-java/java-config/java-config-2.1.2.ebuild b/dev-java/java-config/java-config-2.1.2.ebuild
new file mode 100644
index 000000000000..79691768dd8a
--- /dev/null
+++ b/dev-java/java-config/java-config-2.1.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.1.2.ebuild,v 1.1 2007/10/13 20:29:01 ali_bush Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ >=dev-java/java-config-wrapper-0.13"
+
+PYTHON_MODNAME="java_config_2"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/java-config-2/config/
+ newins config/jdk-defaults-${ARCH}.conf jdk-defaults.conf || die "arch config not found"
+}
+
+pkg_postrm() {
+ distutils_python_version
+ distutils_pkg_postrm
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "The way Java is handled on Gentoo has been recently updated."
+ elog "If you have not done so already, you should follow the"
+ elog "instructions available at:"
+ elog "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+ elog
+ elog "While we are moving towards the new Java system, we only allow"
+ elog "1.3 or 1.4 JDKs to be used with java-config-1 to ensure"
+ elog "backwards compatibility with the old system."
+ elog "For more details about this, please see:"
+ elog "\thttp://www.gentoo.org/proj/en/java/why-we-need-java-14.xml"
+}