summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-01-09 18:00:40 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-01-09 18:00:40 +0000
commitd2b992cfb2adbaa5e84c635c0fa6893a33a9e184 (patch)
treebcf704bdcd30b23904ab220fc44606d437db1504 /dev-java/javolution/javolution-2.2.0.ebuild
parentStable on sparc wrt security bug #75200. (Manifest recommit) (diff)
downloadgentoo-2-d2b992cfb2adbaa5e84c635c0fa6893a33a9e184.tar.gz
gentoo-2-d2b992cfb2adbaa5e84c635c0fa6893a33a9e184.tar.bz2
gentoo-2-d2b992cfb2adbaa5e84c635c0fa6893a33a9e184.zip
new upstream version available. javolution-2.2.0.
Diffstat (limited to 'dev-java/javolution/javolution-2.2.0.ebuild')
-rw-r--r--dev-java/javolution/javolution-2.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/javolution/javolution-2.2.0.ebuild b/dev-java/javolution/javolution-2.2.0.ebuild
new file mode 100644
index 000000000000..620953cad7b8
--- /dev/null
+++ b/dev-java/javolution/javolution-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javolution/javolution-2.2.0.ebuild,v 1.1 2005/01/09 18:00:40 luckyduck Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="Java Solution for Real-Time and Embedded Systems"
+SRC_URI="http://javolution.org/${P}-src.zip"
+HOMEPAGE=""
+LICENSE="LGPL-2.1"
+SLOT="2.2"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-core-1.4
+ >=app-arch/unzip-5.50-r1
+ jikes?( >=dev-java/jikes-1.21 )"
+RDEPEND=">=virtual/jdk-1.4"
+RESTRICT="nomirror"
+
+S=${WORKDIR}/javolution-${PV%.*}
+
+src_compile() {
+ antflags="init_1.4 compile jar"
+ use doc && antflags="${antflags} doc"
+ # disabled jikes for now till i've the time to write an patch for this
+ #use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant build failed"
+}
+
+src_install() {
+ java-pkg_dojar javolution.jar
+ dodoc doc/coding_standard.txt doc/license.txt
+ use doc && java-pkg_dohtml -r index.html api/*
+}