summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-09-07 15:17:52 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-09-07 15:17:52 +0000
commitbbb120d93dbed00343beab9b419f5e7cd2d7e23a (patch)
treee607573d64c54002899994b35b68bf9ed1855743 /dev-java/jexcelapi
parentBump to EAPI=5 (diff)
downloadgentoo-2-bbb120d93dbed00343beab9b419f5e7cd2d7e23a.tar.gz
gentoo-2-bbb120d93dbed00343beab9b419f5e7cd2d7e23a.tar.bz2
gentoo-2-bbb120d93dbed00343beab9b419f5e7cd2d7e23a.zip
EAPI bump, some qa and dropped patch file for old version
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/jexcelapi')
-rw-r--r--dev-java/jexcelapi/ChangeLog11
-rw-r--r--dev-java/jexcelapi/files/2.5.1-jikes.patch17
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild43
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.6.8.ebuild6
4 files changed, 54 insertions, 23 deletions
diff --git a/dev-java/jexcelapi/ChangeLog b/dev-java/jexcelapi/ChangeLog
index 21af52ab731b..102f2ba83503 100644
--- a/dev-java/jexcelapi/ChangeLog
+++ b/dev-java/jexcelapi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jexcelapi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/ChangeLog,v 1.22 2009/02/04 12:26:27 betelgeuse Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/ChangeLog,v 1.23 2014/09/07 15:17:52 ercpe Exp $
+
+*jexcelapi-2.6.8-r1 (07 Sep 2014)
+
+ 07 Sep 2014; Johann Schmitz <ercpe@gentoo.org> +jexcelapi-2.6.8-r1.ebuild,
+ -files/2.5.1-jikes.patch, jexcelapi-2.6.8.ebuild:
+ EAPI bump, some qa and dropped patch file for old version
04 Feb 2009; Petteri Räty <betelgeuse@gentoo.org>
-jexcelapi-2.6.4.ebuild, -jexcelapi-2.6.6.ebuild:
@@ -85,4 +91,3 @@
+files/2.5.1-jikes.patch, +jexcelapi-2.5.1.ebuild:
Initial import, ebuild based on the contribution of Eddy Mulyono
<eddymulyono@mail.com>. fixes #76209.
-
diff --git a/dev-java/jexcelapi/files/2.5.1-jikes.patch b/dev-java/jexcelapi/files/2.5.1-jikes.patch
deleted file mode 100644
index 413575950289..000000000000
--- a/dev-java/jexcelapi/files/2.5.1-jikes.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -uprN jexcelapi.orig/src/jxl/write/biff/CompoundFile.java jexcelapi/src/jxl/write/biff/CompoundFile.java
---- jexcelapi.orig/src/jxl/write/biff/CompoundFile.java 2005-01-23 15:39:35.389297104 +0100
-+++ jexcelapi/src/jxl/write/biff/CompoundFile.java 2005-01-23 15:40:59.715477576 +0100
-@@ -169,11 +169,11 @@ final class CompoundFile extends BaseCom
- */
- private static final class ReadPropertyStorage
- {
-- PropertyStorage propertyStorage;
-+ jxl.biff.BaseCompoundFile.PropertyStorage propertyStorage;
- byte[] data;
- int number;
-
-- ReadPropertyStorage(PropertyStorage ps, byte[] d, int n)
-+ ReadPropertyStorage(jxl.biff.BaseCompoundFile.PropertyStorage ps, byte[] d, int n)
- {
- propertyStorage = ps;
- data = d;
diff --git a/dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild b/dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild
new file mode 100644
index 000000000000..4a2fa49ce04c
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild,v 1.1 2014/09/07 15:17:52 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2.5"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${PN}
+
+EANT_BUILD_XML="build/build.xml"
+EANT_FILTER_COMPILER="jikes"
+EANT_BUILD_TARGET="jxl"
+EANT_DOC_TARGET="docs"
+
+java_prepare() {
+ find "${S}" -name "*.jar" -o -name "*.class" -delete || die
+}
+
+src_install() {
+ java-pkg_newjar jxl.jar ${PN}.jar
+
+ java-pkg_dohtml index.html tutorial.html
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc "${S}"/src/*
+}
diff --git a/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild b/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild
index ed399a276b73..f2e16205c62e 100644
--- a/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild
+++ b/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild,v 1.3 2008/10/25 17:12:28 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild,v 1.4 2014/09/07 15:17:52 ercpe Exp $
JAVA_PKG_IUSE="doc source"
inherit java-pkg-2 java-ant-2
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="2.5"
-KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE=""
DEPEND=">=virtual/jdk-1.4