summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-06 21:36:06 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-06 21:36:06 +0000
commit733d601cad9bd85761252e5d5f40ea4c4d5dbdba (patch)
tree51f15f2064411058e6713c682715fe23be999f0a /dev-java/jump/jump-0.4.1-r1.ebuild
parentAdded to ~ppc. (Manifest recommit) (diff)
downloadgentoo-2-733d601cad9bd85761252e5d5f40ea4c4d5dbdba.tar.gz
gentoo-2-733d601cad9bd85761252e5d5f40ea4c4d5dbdba.tar.bz2
gentoo-2-733d601cad9bd85761252e5d5f40ea4c4d5dbdba.zip
fixes 63279
Diffstat (limited to 'dev-java/jump/jump-0.4.1-r1.ebuild')
-rw-r--r--dev-java/jump/jump-0.4.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/jump/jump-0.4.1-r1.ebuild b/dev-java/jump/jump-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..d495b77c0c29
--- /dev/null
+++ b/dev-java/jump/jump-0.4.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jump/jump-0.4.1-r1.ebuild,v 1.1 2004/10/06 21:36:06 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="JUMP Ultimate Math Package (JUMP) is a Java-based extensible high-precision math package."
+SRC_URI="mirror://sourceforge/${PN}-math/${PN}-${PV}.tar.gz"
+HOMEPAGE="http://jump-math.sourceforge.net/"
+KEYWORDS="x86 ~ppc ~sparc"
+LICENSE="BSD"
+SLOT="0"
+DEPEND=">=virtual/jre-1.2
+ sys-apps/sed"
+RDEPEND=">=virtual/jre-1.2"
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:${java.home}/src::' -i build.xml
+}
+
+src_compile() {
+ local antflags="jar"
+ use doc && antflags="${antflags} apidocs"
+ ant ${antflags} || die "failed to build"
+}
+
+src_install() {
+ java-pkg_dojar build/${PN}.jar
+ use doc && dohtml -r ${S}/build/apidocs/*
+}