summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-12-25 21:42:29 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-12-25 21:42:29 +0000
commit0576092b9f5fb9db47a025900f2d4f6e9d690b54 (patch)
tree0091f4dacc6c071d9ead342f3e0511dc0cc0b350 /dev-java/junit
parentdev-java/trove: version bump (diff)
downloadgentoo-2-0576092b9f5fb9db47a025900f2d4f6e9d690b54.tar.gz
gentoo-2-0576092b9f5fb9db47a025900f2d4f6e9d690b54.tar.bz2
gentoo-2-0576092b9f5fb9db47a025900f2d4f6e9d690b54.zip
dev-java/junit: version bump
(Portage version: 2.1.10.43/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/junit')
-rw-r--r--dev-java/junit/ChangeLog7
-rw-r--r--dev-java/junit/junit-4.10.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/dev-java/junit/ChangeLog b/dev-java/junit/ChangeLog
index 6032deeaa0ea..0e44a8185461 100644
--- a/dev-java/junit/ChangeLog
+++ b/dev-java/junit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/junit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.62 2011/05/03 18:27:50 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/ChangeLog,v 1.63 2011/12/25 21:42:29 fordfrog Exp $
+
+*junit-4.10 (25 Dec 2011)
+
+ 25 Dec 2011; Miroslav Šulc <fordfrog@gentoo.org> +junit-4.10.ebuild:
+ Version bump
03 May 2011; Fabian Groffen <grobian@gentoo.org> junit-4.8.2-r1.ebuild:
Marked ~x64-freebsd
diff --git a/dev-java/junit/junit-4.10.ebuild b/dev-java/junit/junit-4.10.ebuild
new file mode 100644
index 000000000000..113a95c78bc0
--- /dev/null
+++ b/dev-java/junit/junit-4.10.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/junit/junit-4.10.ebuild,v 1.1 2011/12/25 21:42:29 fordfrog Exp $
+
+# WARNING: JUNIT.JAR IS _NOT_ SYMLINKED TO ANT-CORE LIB FOLDER AS JUNIT3 IS
+
+EAPI="3"
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Simple framework to write repeatable tests"
+SRC_URI="https://github.com/downloads/KentBeck/${PN}/${PN}${PV}.zip"
+HOMEPAGE="http://www.junit.org/"
+LICENSE="CPL-1.0"
+SLOT="4"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+CDEPEND="dev-java/hamcrest-core:0"
+RDEPEND=">=virtual/jre-1.5
+ ${CDEPEND}"
+DEPEND=">=virtual/jdk-1.5
+ userland_GNU? ( >=sys-apps/findutils-4.3 )
+ ${CDEPEND}"
+
+S="${WORKDIR}/${PN}${PV}"
+
+EANT_BUILD_TARGET="jars"
+
+src_unpack() {
+ default
+
+ # Unpack source JAR
+ mkdir -p "${S}/src/main/java" "${S}/src/test/java" \
+ || die "Unable to create source directories"
+ pushd "${S}/src/main/java" >/dev/null
+ jar xf "${S}/${P}-src.jar" || die "Unable to unpack sources."
+ popd >/dev/null
+
+ # copy Gentoo manifest to working directory
+ cp "${FILESDIR}/gentoo-manifest.mf" "${S}"
+}
+
+java_prepare() {
+ # fix javadoc compilation
+ if use doc ; then
+ cp "${S}"/javadoc/stylesheet.css "${S}" \
+ || die "Unable to copy Javdoc stylesheet"
+ fi
+
+ # remove binary and other generated files
+ rm -rf javadoc temp.hamcrest.source *.jar \
+ || die "Unable to clean generated files."
+ find . -name "*.class" -delete \
+ || die "Unable to remove distributed class files"
+
+ # Let Ant know where its hamcrest went
+ EANT_EXTRA_ARGS="-Dhamcrestlib=$(java-pkg_getjars hamcrest-core)"
+
+ # Add Gentoo manifest information to generated JAR files
+ java-ant_xml-rewrite -f build.xml -c \
+ -e jar -a manifest -v "gentoo-manifest.mf"
+}
+
+src_test() {
+ mkdir classes || die "Unable to create build directory for tests"
+
+ local cp=$(java-pkg_getjars hamcrest-core):${S}/${PN}${PV}/${PN}-dep-${PV}.jar
+ ejavac -classpath ${cp} -d classes $(find junit/tests -name "*.java")
+
+ java -classpath ${cp}:classes org.junit.runner.JUnitCore junit.tests.AllTests \
+ || die "Tests failed."
+}
+
+src_install() {
+ java-pkg_newjar ${PN}${PV}/${PN}-dep-${PV}.jar
+ dodoc README.html doc/ReleaseNotes${PV}.txt || die
+
+ use examples && java-pkg_doexamples org/junit/samples
+ use source && java-pkg_dosrc src/main/java/org src/main/java/junit
+
+ if use doc; then
+ dohtml -r doc/*
+ java-pkg_dojavadoc ${PN}${PV}/javadoc
+ fi
+}