summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-08 22:51:00 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-08 22:51:00 +0000
commite4677f5c54e2167dc1c4515189f856ad9af82ceb (patch)
treeb6caec90855277aeba3b3c05c877d521e6aff41c /dev-java/sun-jre-bin
parentfinal to ~arch meta (Manifest recommit) (diff)
downloadgentoo-2-e4677f5c54e2167dc1c4515189f856ad9af82ceb.tar.gz
gentoo-2-e4677f5c54e2167dc1c4515189f856ad9af82ceb.tar.bz2
gentoo-2-e4677f5c54e2167dc1c4515189f856ad9af82ceb.zip
version bumped
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/Manifest12
-rw-r--r--dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.02
-rw-r--r--dev-java/sun-jre-bin/files/sun-jre-bin-1.5.011
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.ebuild187
4 files changed, 202 insertions, 10 deletions
diff --git a/dev-java/sun-jre-bin/Manifest b/dev-java/sun-jre-bin/Manifest
index 7a91063dcf07..7617c9a78d80 100644
--- a/dev-java/sun-jre-bin/Manifest
+++ b/dev-java/sun-jre-bin/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 2fbe937bcd6f100b6c6006430b1373dd sun-jre-bin-1.4.2.05-r1.ebuild 4807
+MD5 cc621d2200a65ccba335c0d1b0d06b9c sun-jre-bin-1.5.0.ebuild 5451
MD5 087ee07309726019e76050502bdc44bd ChangeLog 2099
MD5 ca35f917561afc166491d77810b71095 metadata.xml 242
MD5 ea64994bb63f18d8c29ce57e4f5d80ea files/digest-sun-jre-bin-1.4.2.05-r1 75
+MD5 acb452269bc2a3897ba121b5ebfd7524 files/digest-sun-jre-bin-1.5.0 143
MD5 65240bd8b9977fbe20b35c7f5201c10d files/sun-jre-bin-1.4.2.05 439
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBWyIp/rLF9B432nYRAnZAAJ9Y9QZkk/MlFaIdBG38/eebgLVxSwCfVX0p
-6u/ZKBUR34sKng17p3nL1Wg=
-=aH2H
------END PGP SIGNATURE-----
diff --git a/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0 b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0
new file mode 100644
index 000000000000..d0ed397a0588
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0
@@ -0,0 +1,2 @@
+MD5 cf2aac02eef3d0607c916db7b5de65f5 jre-1_5_0-linux-i586.bin 16511293
+MD5 c00c20e7ac0b1604085d10527d8730a0 jre-1_5_0-linux-amd64.bin 16127113
diff --git a/dev-java/sun-jre-bin/files/sun-jre-bin-1.5.0 b/dev-java/sun-jre-bin/files/sun-jre-bin-1.5.0
new file mode 100644
index 000000000000..85b2583889b0
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/sun-jre-bin-1.5.0
@@ -0,0 +1,11 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/files/sun-jre-bin-1.5.0,v 1.1 2004/10/08 22:51:00 axxo Exp $
+
+VERSION="Sun JRE @PV@"
+JAVA_HOME=/opt/@P@
+JRE_HOME=/opt/@P@
+ADDPATH="${JAVA_HOME}/bin:${JAVA_HOME}/javaws"
+ADDLDPATH="/opt/@P@/lib"
+MANPATH="/opt/@P@/man"
+ENV_VARS="JAVA_HOME JRE_HOME ADDPATH ADDLDPATH MANPATH"
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.ebuild
new file mode 100644
index 000000000000..18a281fe7940
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.ebuild,v 1.1 2004/10/08 22:51:00 axxo Exp $
+
+inherit java eutils
+
+amd64file="jre-${PV//./_}-linux-amd64.bin"
+x86file="jre-${PV//./_}-linux-i586.bin"
+
+if use x86; then
+ At=${x86file}
+elif use amd64; then
+ At=${amd64file}
+fi
+
+S="${WORKDIR}/jre${PV}"
+DESCRIPTION="Sun's J2SE Platform"
+HOMEPAGE="http://java.sun.com/j2se/"
+SRC_URI="x86? ( $x86file ) amd64? ( $amd64file )"
+SLOT="1.5"
+LICENSE="sun-bcla-java-vm"
+KEYWORDS="~x86 ~amd64"
+RESTRICT="fetch"
+IUSE="gnome kde mozilla"
+
+DEPEND=">=dev-java/java-config-1.2
+ sys-apps/sed
+ virtual/lpr"
+
+RDEPEND="x86? ( sys-libs/lib-compat )
+ virtual/lpr"
+
+PROVIDE="virtual/jre-1.5"
+
+PACKED_JARS="lib/rt.jar lib/jsse.jar lib/charsets.jar lib/ext/localedata.jar lib/plugin.jar lib/javaws.jar lib/deploy.jar"
+
+# this is needed for proper operating under a PaX kernel without activated grsecurity acl
+CHPAX_CONSERVATIVE_FLAGS="pemsv"
+
+FETCH_SDK="http://javashoplm.sun.com:80/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jre-1.5.0-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+
+pkg_nofetch() {
+ einfo "Please download ${At} from:"
+ einfo ${FETCH_SDK}
+ einfo "(Select the Linux or Linux AMD64 Self-extracting (.bin), depending on your arch)"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${At} ]; then
+ die "cannot read ${At}. Please check the permission and try again."
+ fi
+
+ #Search for the ELF Header
+ testExp=`echo -e "\105\114\106"`
+ startAt=`grep -aonm 1 ${testExp} ${DISTDIR}/${At} | cut -d: -f1`
+ tail -n +${startAt} ${DISTDIR}/${At} > install.sfx
+ chmod +x install.sfx
+ ./install.sfx || die
+ rm install.sfx
+
+ if [ -f ${S}/bin/unpack200 ]; then
+ UNPACK_CMD=${S}/bin/unpack200
+ chmod +x $UNPACK_CMD
+ for i in $PACKED_JARS; do
+ PACK_FILE=${S}/`dirname $i`/`basename $i .jar`.pack
+ if [ -f ${PACK_FILE} ]; then
+ echo " unpacking: $i"
+ $UNPACK_CMD ${PACK_FILE} ${S}/$i
+ rm -f ${PACK_FILE}
+ fi
+ done
+ rm -f ${UNPACK_CMD}
+ else
+ die "unpack not found"
+ fi
+}
+
+src_install() {
+ local dirs="bin javaws lib man plugin"
+ dodir /opt/${P}
+
+ for i in $dirs ; do
+ cp -a $i ${D}/opt/${P}/ || die "failed to build"
+ done
+
+ dodoc COPYRIGHT LICENSE README
+ dohtml Welcome.html
+
+ if use mozilla; then
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=gcc-3*' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/.systemPrefs
+
+ # install control panel for Gnome/KDE
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}/" \
+ -e "s/\(Name=Java\)/\1 Control Panel/" \
+ ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+ ${T}/sun_java.desktop
+
+ if use x86; then
+ if use gnome ; then
+ #TODO check this on Gnome
+ dodir /usr/share/gnome/apps/Internet
+ insinto /usr/share/gnome/apps/Internet
+ doins ${T}/sun_java.desktop
+ fi
+
+ if use kde ; then
+ dodir /usr/share/applnk/Internet
+ insinto /usr/share/applnk/Internet
+ doins ${T}/sun_java.desktop
+ fi
+ else
+ eerror "Sorry no kde, gnome support for your arch now."
+ fi
+
+ set_java_env ${FILESDIR}/${VMHANDLE}
+}
+
+pkg_postinst() {
+ # Create files used as storage for system preferences.
+ PREFS_LOCATION=/opt/${P}/
+ mkdir -p ${PREFS_LOCATION}/.systemPrefs
+ if [ ! -f ${PREFS_LOCATION}/.systemPrefs/.system.lock ] ; then
+ touch $PREFS_LOCATION/.systemPrefs/.system.lock
+ chmod 644 $PREFS_LOCATION/.systemPrefs/.system.lock
+ fi
+ if [ ! -f $PREFS_LOCATION/.systemPrefs/.systemRootModFile ] ; then
+ touch $PREFS_LOCATION/.systemPrefs/.systemRootModFile
+ chmod 644 $PREFS_LOCATION/.systemPrefs/.systemRootModFile
+ fi
+
+ # Set as default VM if none exists
+ java_pkg_postinst
+
+ #Show info about netscape
+ if has_version '>=netscape-navigator-4.79-r1' || has_version '>=netscape-communicator-4.79-r1' ; then
+ echo
+ einfo "If you want to install the plugin for Netscape 4.x, type"
+ einfo
+ einfo " cd /usr/lib/nsbrowser/plugins/"
+ einfo " ln -sf /opt/${P}/plugin/i386/ns4/libjavaplugin.so"
+ fi
+
+ # if chpax is on the target system, set the appropriate PaX flags
+ # this will not hurt the binary, it modifies only unused ELF bits
+ # but may confuse things like AV scanners and automatic tripwire
+ if has_version "sys-apps/chpax"
+ then
+ echo
+ einfo "setting up conservative PaX flags for jar, javac and java"
+
+ for paxkills in "java"
+ do
+ chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/$paxkills
+ done
+
+ # /opt/$VM/bin/java_vm
+ chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/java_vm
+
+ einfo "you should have seen lots of chpax output above now"
+ ewarn "make sure the grsec ACL contains those entries also"
+ ewarn "because enabling it will override the chpax setting"
+ ewarn "on the physical files - help for PaX and grsecurity"
+ ewarn "can be given by #gentoo-hardened + pappy@gentoo.org"
+ fi
+
+ echo
+ eerror "Some parts of Sun's JRE require XFree86 to be installed."
+ eerror "Be careful which Java libraries you attempt to use."
+
+ ebeep 5
+ epause 8
+}