summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-10-16 17:42:34 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-10-16 17:42:34 +0000
commitdc20da9eefc7e9a4f087f5cbe7c08f675daa1bf2 (patch)
treec67d88f0a454c15a251d2125e0deb334478f9a6a /dev-java/velocity
parentold (Manifest recommit) (diff)
downloadgentoo-2-dc20da9eefc7e9a4f087f5cbe7c08f675daa1bf2.tar.gz
gentoo-2-dc20da9eefc7e9a4f087f5cbe7c08f675daa1bf2.tar.bz2
gentoo-2-dc20da9eefc7e9a4f087f5cbe7c08f675daa1bf2.zip
use java-pkg_dohtml instead of dohtml to also install the package-list in case of api docs: #50740
Diffstat (limited to 'dev-java/velocity')
-rw-r--r--dev-java/velocity/ChangeLog6
-rw-r--r--dev-java/velocity/velocity-1.4.ebuild10
2 files changed, 11 insertions, 5 deletions
diff --git a/dev-java/velocity/ChangeLog b/dev-java/velocity/ChangeLog
index 8dfc48efac82..bc8baf90e2fa 100644
--- a/dev-java/velocity/ChangeLog
+++ b/dev-java/velocity/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/velocity
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/ChangeLog,v 1.13 2004/08/23 21:57:36 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/ChangeLog,v 1.14 2004/10/16 17:39:18 axxo Exp $
+
+ 16 Oct 2004; Thomas Matthijs <axxo@gentoo.org> velocity-1.4.ebuild:
+ use java-pkg_dohtml instead of dohtml to also install the package-list in
+ case of api docs: #50740
23 Aug 2004; Chris Aniszczyk <zx@gentoo.org> -velocity-1.3.ebuild,
velocity-1.4.ebuild:
diff --git a/dev-java/velocity/velocity-1.4.ebuild b/dev-java/velocity/velocity-1.4.ebuild
index 41132e634404..2ff0e5c2fb28 100644
--- a/dev-java/velocity/velocity-1.4.ebuild
+++ b/dev-java/velocity/velocity-1.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.4.ebuild,v 1.5 2004/08/23 21:57:36 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/velocity/velocity-1.4.ebuild,v 1.6 2004/10/16 17:39:18 axxo Exp $
+
+inherit java-pkg
DESCRIPTION="A Java-based template engine that allows easy creation/rendering of documents that format and present data."
HOMEPAGE="http://jakarta.apache.org/velocity/"
@@ -37,10 +39,10 @@ src_compile () {
src_install () {
cd ${S}
if use j2ee ; then
- dojar bin/${PN}-J2EE-${PV}.jar
+ java-pkg_dojar bin/${PN}-J2EE-${PV}.jar
else
- dojar bin/${PN}-${PV}.jar
+ java-pkg_dojar bin/${PN}-${PV}.jar
fi
dodoc LICENSE NOTICE README.txt
- use doc && dohtml -r docs/*
+ use doc && java-pkg_dohtml -r docs/*
}