summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-09 13:04:27 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-09 13:04:27 +0000
commit184aa29f2f114221e6fa15bd92efdcf4cc52c268 (patch)
tree78421cadfe06edff75a3f661b8f3dcf311bfb5fc /dev-java/xjavac/xjavac-20041208-r1.ebuild
parentupdate dep (diff)
downloadgentoo-2-184aa29f2f114221e6fa15bd92efdcf4cc52c268.tar.gz
gentoo-2-184aa29f2f114221e6fa15bd92efdcf4cc52c268.tar.bz2
gentoo-2-184aa29f2f114221e6fa15bd92efdcf4cc52c268.zip
add ant symlink
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/xjavac/xjavac-20041208-r1.ebuild')
-rw-r--r--dev-java/xjavac/xjavac-20041208-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/xjavac/xjavac-20041208-r1.ebuild b/dev-java/xjavac/xjavac-20041208-r1.ebuild
new file mode 100644
index 000000000000..b5579c2bc885
--- /dev/null
+++ b/dev-java/xjavac/xjavac-20041208-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xjavac/xjavac-20041208-r1.ebuild,v 1.1 2005/07/09 13:04:27 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="The implementation of the javac compiler for IBM JDK 1.4 (needed for xerces-2)"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="http://cvs.apache.org/viewcvs.cgi/xml-xerces/java/tools/src/XJavac.java"
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="x86 amd64 ppc64 sparc ~ppc"
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.4
+ jikes? ( >=dev-java/jikes-1.21 )
+ >=dev-java/ant-core-1.4"
+RDEPEND=">=virtual/jdk-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ cp ${FILESDIR}/${P}-build.xml ./build.xml
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "failed to build"
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ dodir /usr/share/ant-core/lib/
+ dosym /usr/share/${PN}-${SLOT}/lib/${PN}.jar /usr/share/ant-core/lib/
+}