summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-05-24 12:33:53 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-05-24 12:33:53 +0000
commit4e17009834d55c5c58223267f49eb08fb1f1f1ba (patch)
treecc6290b5f68d13d1776e20e61b7378000e496d29 /dev-java/xom
parentDepend on libglade. Fixes bug#405669. (diff)
downloadgentoo-2-4e17009834d55c5c58223267f49eb08fb1f1f1ba.tar.gz
gentoo-2-4e17009834d55c5c58223267f49eb08fb1f1f1ba.tar.bz2
gentoo-2-4e17009834d55c5c58223267f49eb08fb1f1f1ba.zip
Remove old. Depend on dev-java/servletapi and old slot of jcu4j.
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/xom')
-rw-r--r--dev-java/xom/ChangeLog6
-rw-r--r--dev-java/xom/xom-1.0-r6.ebuild68
-rw-r--r--dev-java/xom/xom-1.0-r7.ebuild69
-rw-r--r--dev-java/xom/xom-1.2.6.ebuild78
4 files changed, 5 insertions, 216 deletions
diff --git a/dev-java/xom/ChangeLog b/dev-java/xom/ChangeLog
index 658a8470a6d6..23bdfbae326d 100644
--- a/dev-java/xom/ChangeLog
+++ b/dev-java/xom/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/xom
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/ChangeLog,v 1.65 2012/05/21 08:15:50 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/ChangeLog,v 1.66 2012/05/24 12:33:53 sera Exp $
+
+ 24 May 2012; Ralph Sennhauser <sera@gentoo.org> -xom-1.0-r6.ebuild,
+ -xom-1.0-r7.ebuild, -xom-1.2.6.ebuild:
+ Remove old. Depend on dev-java/servletapi and old slot of jcu4j.
21 May 2012; Johannes Huber <johu@gentoo.org> xom-1.2.6-r1.ebuild:
Stable for x86, wrt bug #381981
diff --git a/dev-java/xom/xom-1.0-r6.ebuild b/dev-java/xom/xom-1.0-r6.ebuild
deleted file mode 100644
index 9fdb80b155ec..000000000000
--- a/dev-java/xom/xom-1.0-r6.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/xom-1.0-r6.ebuild,v 1.8 2012/04/13 18:54:06 ulm Exp $
-
-EAPI=1
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-ant-2
-
-XOMVER="xom-${PV/_beta/b}"
-DESCRIPTION="A new XML object model."
-HOMEPAGE="http://cafeconleche.org/XOM/index.html"
-SRC_URI="http://cafeconleche.org/XOM/${XOMVER}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
-IUSE=""
-
-COMMON_DEPEND="dev-java/xerces:2
- dev-java/xalan:0
- dev-java/junit:0
- dev-java/icu4j:0
- examples? ( dev-java/servletapi:2.4 )"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEPEND}"
-DEPEND=">=virtual/jdk-1.4
- ${COMMON_DEPEND}"
-
-S=${WORKDIR}/XOM
-
-# Test require network access to pass
-# They need a redirected http document on public web
-RESTRICT="test"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- java-ant_ignore-system-classes
- rm -v *.jar || die
- cd "${S}/lib"
- rm -v *.jar || die
- java-pkg_jar-from junit
- java-pkg_jar-from xalan
- java-pkg_jar-from xerces-2
- java-pkg_jar-from icu4j icu4j.jar normalizer.jar
- # tagsoup is only needed to run betterdoc but we use the pregenerated ones
-}
-
-src_compile() {
- local ant_flags="-Ddebug=off"
- use examples && ant_flags="${ant_flags} -Dservlet.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)"
-
- eant jar ${ant_flags}\
- $(use examples && echo samples)
-}
-
-EANT_TEST_ANT_TASKS="ant-trax"
-
-src_install() {
- java-pkg_newjar build/${XOMVER}.jar ${PN}.jar
- use examples && java-pkg_dojar build/xom-samples.jar
- dodoc Todo.txt || die
-
- use doc && java-pkg_dojavadoc apidocs/
- use source && java-pkg_dosrc src/*
- use examples && java-pkg_doexamples --subdir nu/xom/samples src/nu/xom/samples
-}
diff --git a/dev-java/xom/xom-1.0-r7.ebuild b/dev-java/xom/xom-1.0-r7.ebuild
deleted file mode 100644
index fbe184b07c74..000000000000
--- a/dev-java/xom/xom-1.0-r7.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/xom-1.0-r7.ebuild,v 1.8 2012/04/13 18:54:06 ulm Exp $
-
-EAPI=1
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-ant-2
-
-XOMVER="xom-${PV/_beta/b}"
-DESCRIPTION="A new XML object model."
-HOMEPAGE="http://cafeconleche.org/XOM/index.html"
-SRC_URI="http://cafeconleche.org/XOM/${XOMVER}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-COMMON_DEPEND="dev-java/xerces:2
- dev-java/icu4j:0
- examples? ( dev-java/servletapi:2.4 )"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEPEND}"
-DEPEND=">=virtual/jdk-1.4
- ${COMMON_DEPEND}"
-#test? ( dev-java/ant-junit:0 )
-
-S=${WORKDIR}/XOM
-
-# Test require network access to pass
-# They need a redirected http document on public web
-RESTRICT="test"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- java-ant_ignore-system-classes
- rm -v *.jar || die
- # nuke test files as we aren't installing them
- rm -vr src/nu/xom/tests || die
- cd "${S}/lib"
- rm -v *.jar || die
- #java-pkg_jar-from --build-only junit
- #java-pkg_jar-from --build-only xalan
- java-pkg_jar-from xerces-2
- java-pkg_jar-from icu4j icu4j.jar normalizer.jar
- # tagsoup is only needed to run betterdoc but we use the pregenerated ones
-}
-
-src_compile() {
- local ant_flags="-Ddebug=off"
- use examples && ant_flags="${ant_flags} -Dservlet.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)"
-
- eant jar ${ant_flags}\
- $(use examples && echo samples)
-}
-
-EANT_TEST_ANT_TASKS="ant-trax"
-
-src_install() {
- java-pkg_newjar build/${XOMVER}.jar ${PN}.jar
- use examples && java-pkg_dojar build/xom-samples.jar
- dodoc Todo.txt || die
-
- use doc && java-pkg_dojavadoc apidocs/
- use source && java-pkg_dosrc src/*
- use examples && java-pkg_doexamples --subdir nu/xom/samples src/nu/xom/samples
-}
diff --git a/dev-java/xom/xom-1.2.6.ebuild b/dev-java/xom/xom-1.2.6.ebuild
deleted file mode 100644
index a73fafab212c..000000000000
--- a/dev-java/xom/xom-1.2.6.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xom/xom-1.2.6.ebuild,v 1.4 2012/01/01 14:51:59 sera Exp $
-
-EAPI="2"
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-ant-2
-
-JAXEN_V="1.1.3"
-JAXEN_P="jaxen-${JAXEN_V}"
-
-DESCRIPTION="A new XML object model."
-HOMEPAGE="http://cafeconleche.org/XOM/index.html"
-SRC_URI="http://cafeconleche.org/XOM/${P}.tar.gz
- http://dist.codehaus.org/jaxen/distributions/${JAXEN_P}-src.tar.gz"
-# Bundled jaxen as its moved under XOM's namespace
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-COMMON_DEPEND="dev-java/xerces:2
- dev-java/xml-commons-external:1.3
- examples? ( dev-java/servletapi:2.4 )"
-RDEPEND=">=virtual/jre-1.4
- ${COMMON_DEPEND}"
-DEPEND=">=virtual/jdk-1.4
- dev-java/jarjar:1
- ${COMMON_DEPEND}"
-
-S="${WORKDIR}/XOM"
-
-# Test require network access to pass
-# They need a redirected http document on public web
-RESTRICT="test"
-
-java_prepare() {
- epatch "${FILESDIR}/${P}.patch"
-
- # Delete test files as they aren't installed
- rm -vr src/nu/xom/tests || die
-
- # Delete bundled jars
- rm -v *.jar lib/*.jar || die
-
- # Delete bundled classes
- find . -name "*.class" -delete -print || die
-
- # Move bundled jaxen to where the build.xml expects it
- mv "${WORKDIR}"/${JAXEN_P}/ lib/ || die
-
- java-pkg_jar-from --into lib/ xml-commons-external-1.3
- java-pkg_jar-from --into lib/ xerces-2
- java-pkg_jar-from --build-only --into lib/ jarjar-1
- # tagsoup is only needed to run betterdoc but we use the pregenerated ones
-}
-
-src_compile() {
- local ant_flags="-Ddebug=off"
- use examples && ant_flags="${ant_flags} -Dservlet.jar=$(java-pkg_getjar servletapi-2.4 servlet-api.jar)"
-
- ejavac src15/nu/xom/JDK15XML1_0Parser.java -d classes15
-
- ANT_TASKS="jarjar-1" eant jar ${ant_flags}\
- $(use examples && echo samples)
-}
-
-src_install() {
- java-pkg_newjar build/${P}.jar ${PN}.jar
- use examples && java-pkg_dojar build/xom-samples.jar
- dodoc Todo.txt || die
-
- use doc && java-pkg_dojavadoc apidocs/
- use source && java-pkg_dosrc src/*
- use examples && java-pkg_doexamples --subdir nu/xom/samples src/nu/xom/samples
-}