summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-07 17:43:41 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-07 17:43:41 +0000
commit2dbe5cd6fd4415ced8a3f5dd0ea407f66c3f9ae6 (patch)
treed135ffd751d2f25a5b57dba9012ede540c2f924c /dev-java
parent*** empty log message *** (diff)
downloadgentoo-2-2dbe5cd6fd4415ced8a3f5dd0ea407f66c3f9ae6.tar.gz
gentoo-2-2dbe5cd6fd4415ced8a3f5dd0ea407f66c3f9ae6.tar.bz2
gentoo-2-2dbe5cd6fd4415ced8a3f5dd0ea407f66c3f9ae6.zip
*** empty log message ***
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/fesi/fesi-r1.ebuild43
-rw-r--r--dev-java/fesi/files/digest1
-rw-r--r--dev-java/jndi/files/digest1
-rw-r--r--dev-java/jndi/jndi-1.2.1-r1.ebuild36
-rw-r--r--dev-java/mysql-jdbc/files/digest1
-rw-r--r--dev-java/mysql-jdbc/mysql-jdbc-1.2c-r1.ebuild41
-rw-r--r--dev-java/xt/files/digest1
-rw-r--r--dev-java/xt/xt-r1.ebuild34
8 files changed, 158 insertions, 0 deletions
diff --git a/dev-java/fesi/fesi-r1.ebuild b/dev-java/fesi/fesi-r1.ebuild
new file mode 100644
index 000000000000..8aa91015568e
--- /dev/null
+++ b/dev-java/fesi/fesi-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fesi/fesi-r1.ebuild,v 1.1 2000/08/07 17:43:40 achim Exp $
+
+P=fesi
+A="fesikit.zip"
+S=${WORKDIR}/${P}
+CATEGORY="dev-java"
+DESCRIPTION="JavaScript Interpreter writte in Java"
+SRC_URI="http://home.worldcom.ch/jmlugrin/fesi/fesikit.zip"
+
+src_unpack() {
+ jar -xf ${DISTDIR}/fesisrc.zip
+ jar -xf ${DISTDIR}/fesikit.zip
+}
+
+src_compile() {
+ cd ${S}
+}
+
+src_install() {
+ cd ${S}
+ insinto /opt/java/lib
+ doins fesi.jar
+ into /usr
+ dodoc COPYRIGHT.TXT Readme.txt
+ docinto html
+ dodoc doc/html/*.html doc/html/*.gif doc/html/*.txt
+ docinto html/api
+ dodoc doc/html/api/*.html doc/html/api/*.css
+ for i in AST awtgui ClassFile Data Exceptions Extensions Interpreter jslib Parser Tests
+ do
+ docinto html/api/FESI/$i
+ dodoc doc/Design/api/FESI/$i/*.html
+ done
+
+
+}
+
+
+
+
diff --git a/dev-java/fesi/files/digest b/dev-java/fesi/files/digest
new file mode 100644
index 000000000000..46a723987c41
--- /dev/null
+++ b/dev-java/fesi/files/digest
@@ -0,0 +1 @@
+MD5 2e52113fb8fb76dfd04611dfa6ccc5b9 fesikit.zip
diff --git a/dev-java/jndi/files/digest b/dev-java/jndi/files/digest
new file mode 100644
index 000000000000..5addb31234b1
--- /dev/null
+++ b/dev-java/jndi/files/digest
@@ -0,0 +1 @@
+MD5 53b63aa68b14cda5722c56d081f56d06 jndi1_2_1.zip
diff --git a/dev-java/jndi/jndi-1.2.1-r1.ebuild b/dev-java/jndi/jndi-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..bd49a955c2da
--- /dev/null
+++ b/dev-java/jndi/jndi-1.2.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jndi/jndi-1.2.1-r1.ebuild,v 1.1 2000/08/07 17:43:40 achim Exp $
+
+P=jndi-1.2.1
+A=jndi1_2_1.zip
+S=${WORKDIR}/${P}
+CATEGORY="dev-java"
+DESCRIPTION="Java Naming and Directory Interface"
+SRC_URI="ftp://"${A}
+HOMEPAGE="http://java.sun.com/products/jndi/"
+
+#Please download the sources from sun
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unzip ${DISTDIR}/${A}
+}
+
+src_compile() {
+ cd ${S}
+}
+
+src_install() {
+ cd ${S}
+ insinto /opt/java/lib
+ doins lib/jndi.jar
+ dodoc COPYRIGHT README.txt
+ docinto html
+ dodoc doc/*.html
+}
+
+
+
diff --git a/dev-java/mysql-jdbc/files/digest b/dev-java/mysql-jdbc/files/digest
new file mode 100644
index 000000000000..4ae4bd74eb35
--- /dev/null
+++ b/dev-java/mysql-jdbc/files/digest
@@ -0,0 +1 @@
+MD5 b04aa7f3048c2ebb169ee88ce19a6a4c mm.mysql.jdbc-1.2c.tar.gz
diff --git a/dev-java/mysql-jdbc/mysql-jdbc-1.2c-r1.ebuild b/dev-java/mysql-jdbc/mysql-jdbc-1.2c-r1.ebuild
new file mode 100644
index 000000000000..e471c2de93ca
--- /dev/null
+++ b/dev-java/mysql-jdbc/mysql-jdbc-1.2c-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-java/mysql-jdbc/mysql-jdbc-1.2c-r1.ebuild,v 1.1 2000/08/07 17:43:41 achim Exp $
+
+P=mysql-jdbc-1.2c
+A=mm.mysql.jdbc-1.2c.tar.gz
+S=${WORKDIR}/mm.mysql.jdbc-1.2c
+CATEGORY="dev-java"
+DESCRIPTION="JDBC Driver for MySQL"
+SRC_URI="http://www.mysql.com/Downloads/Contrib/"${A}
+HOMEPAGE="http://www.mysql.com/"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ jar -cf mysql-jdbc.jar org
+}
+
+src_install() {
+ cd ${S}
+ dodir /opt/java/lib/
+ cp -a mysql-jdbc.jar ${D}/opt/java/lib
+ cd doc
+ docinto html
+ dodoc *.html *.gif
+ docinto html/mm.doc
+ dodoc mm.doc/*.html mm.doc/*.css
+ docinto html/mm.doc/stylesheet-images
+ dodoc mm.doc/stylesheet-images/*.gif
+ docinto html/apidoc
+ dodoc apidoc/*.html apidoc/*.css
+ docinto html/apidoc/org/gjt/mm/mysql
+ dodoc apidoc/org/gjt/mm/mysql/*.html
+}
+
+
+
diff --git a/dev-java/xt/files/digest b/dev-java/xt/files/digest
new file mode 100644
index 000000000000..c4994a86a68e
--- /dev/null
+++ b/dev-java/xt/files/digest
@@ -0,0 +1 @@
+MD5 2ac9973f7f9cb2a480af94066f89568a xt.zip
diff --git a/dev-java/xt/xt-r1.ebuild b/dev-java/xt/xt-r1.ebuild
new file mode 100644
index 000000000000..aa1791773087
--- /dev/null
+++ b/dev-java/xt/xt-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xt/xt-r1.ebuild,v 1.1 2000/08/07 17:43:41 achim Exp $
+
+P=xt
+A=${P}.zip
+S=${WORKDIR}/${P}
+CATEGORY="dev-java"
+DESCRIPTION="Java Implementation of XSL-Transformations"
+SRC_URI="ftp://ftp.jclark.com/pub/xml/"${A}
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unzip ${DISTDIR}/${A}
+}
+
+src_compile() {
+ cd ${S}
+}
+
+src_install() {
+ cd ${S}
+ insinto /opt/java/lib
+ doins xt.jar sax.jar
+ docinto html
+ dodoc xt.htm
+ docinto demo
+ dodoc demo/*
+}
+
+
+