summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-04-27 22:17:36 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-04-27 22:17:36 +0000
commit779db6041aab907887d9efeb45b1b735888850e0 (patch)
treedb7e656df3853eac42fcc939e1d76c50b0da9020 /dev-java
parentapp-emacs/remember moved to PDEPEND, bug #172137. (diff)
downloadgentoo-2-779db6041aab907887d9efeb45b1b735888850e0.tar.gz
gentoo-2-779db6041aab907887d9efeb45b1b735888850e0.tar.bz2
gentoo-2-779db6041aab907887d9efeb45b1b735888850e0.zip
Remove old ebuilds.
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-graph/ChangeLog7
-rw-r--r--dev-java/commons-graph/commons-graph-0.8.1_p20040118-r1.ebuild53
-rw-r--r--dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild65
-rw-r--r--dev-java/commons-graph/files/digest-commons-graph-0.8.1_p200401183
-rw-r--r--dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118-r13
5 files changed, 6 insertions, 125 deletions
diff --git a/dev-java/commons-graph/ChangeLog b/dev-java/commons-graph/ChangeLog
index 21dbc446a758..ca3e1c7b3705 100644
--- a/dev-java/commons-graph/ChangeLog
+++ b/dev-java/commons-graph/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-graph
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/ChangeLog,v 1.6 2007/04/27 22:16:16 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/ChangeLog,v 1.7 2007/04/27 22:17:36 betelgeuse Exp $
+
+ 27 Apr 2007; Petteri Räty <betelgeuse@gentoo.org>
+ -commons-graph-0.8.1_p20040118.ebuild,
+ -commons-graph-0.8.1_p20040118-r1.ebuild:
+ Remove old ebuilds.
*commons-graph-0.8.1_p20040118-r2 (27 Apr 2007)
diff --git a/dev-java/commons-graph/commons-graph-0.8.1_p20040118-r1.ebuild b/dev-java/commons-graph/commons-graph-0.8.1_p20040118-r1.ebuild
deleted file mode 100644
index 2de048c0877e..000000000000
--- a/dev-java/commons-graph/commons-graph-0.8.1_p20040118-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/commons-graph-0.8.1_p20040118-r1.ebuild,v 1.2 2007/04/27 22:16:16 betelgeuse Exp $
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2 eutils
-MY_PN=graph2
-MY_PV=${PV%%_*}.cvs${PV##*_p}
-MY_P=${MY_PN}-${MY_PV}
-API_PV=${PV%%_*}
-DESCRIPTION="A toolkit for managing graphs and graph based data structures"
-# There doesn't seem to be a real home page, so we'll point to a viewcvs
-HOMEPAGE="http://cvs.apache.org/viewcvs/jakarta-commons-sandbox/graph2/"
-# this was extracted from a source rpm at jpackage
-SRC_URI="mirror://gentoo/distfiles/${MY_P}.tar.gz"
-COMMON_DEP="
- dev-java/commons-collections
- dev-java/jdepend"
-DEPEND=">=virtual/jdk-1.3
- test? ( dev-java/ant-junit )
- ${COMMON_DEP}"
-RDEPEND=">=virtual/jre-1.3
- ${COMMON_DEP}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-S=${WORKDIR}/${MY_P}
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-gentoo.diff"
- mkdir -p target/lib
- cd target/lib
- java-pkg_jar-from commons-collections
- java-pkg_jar-from jdepend
-}
-
-src_install(){
- java-pkg_newjar target/${PN}-${API_PV}.jar ${PN}.jar
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc src/*
-}
-
-src_test() {
- cd "${S}/target/lib"
- java-pkg_jar-from junit
- cd "${S}"
- ANT_TASKS="ant-junit" eant test
-}
diff --git a/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild b/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild
deleted file mode 100644
index b38b3a636b43..000000000000
--- a/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-graph/commons-graph-0.8.1_p20040118.ebuild,v 1.4 2005/12/04 23:17:04 nichoj Exp $
-
-inherit java-pkg eutils
-MY_PN=graph2
-MY_PV=${PV%%_*}.cvs${PV##*_p}
-MY_P=${MY_PN}-${MY_PV}
-API_PV=${PV%%_*}
-DESCRIPTION="A toolkit for managing graphs and graph based data structures"
-# There doesn't seem to be a real home page, so we'll point to a viewcvs
-HOMEPAGE="http://cvs.apache.org/viewcvs/jakarta-commons-sandbox/graph2/"
-# this was extracted from a source rpm at jpackage
-SRC_URI="mirror://gentoo/distfiles/${MY_P}.tar.gz"
-COMMON_DEP="dev-java/log4j
- dev-java/commons-collections
- dev-java/xml-commons"
-DEPEND=">=virtual/jdk-1.3
- jikes? ( dev-java/jikes )
- dev-java/ant-core
- test? ( dev-java/ant-tasks )
- ${COMMON_DEP}"
-RDEPEND=">=virtual/jre-1.3
- ${COMMON_DEP}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc jikes test"
-S=${WORKDIR}/${MY_P}
-
-src_unpack(){
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
- mkdir -p target/lib
- cd target/lib
- java-pkg_jar-from log4j
- java-pkg_jar-from commons-collections
- java-pkg_jar-from xml-commons xml-apis.jar
-
-}
-
-src_compile(){
- local antflags="jar -Dnoget=true"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- use doc && antflags="${antflags} javadoc"
- ant ${antflags} || die "compile failed"
-}
-
-src_install(){
- java-pkg_newjar target/${PN}-${API_PV}.jar ${PN}.jar
- use doc && java-pkg_dohtml -r dist/docs/api
-}
-
-src_test() {
- if use test; then
- local antflags="test -Dnoget=true"
- ant ${antflags} || die "test failed"
- else
- ewarn "You must include 'test' in your use flags in order to"
- ewarn "get the dependencies needed to run unit tests"
- ewarn "Skipping unit tests"
- fi
-}
diff --git a/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118 b/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118
deleted file mode 100644
index 071634f706c7..000000000000
--- a/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2f0b4b570e383321675e56d3a2bbfa08 graph2-0.8.1.cvs20040118.tar.gz 42653
-RMD160 cd5cf77dfcc90ca5b0b05279c4e6492a6aed3c38 graph2-0.8.1.cvs20040118.tar.gz 42653
-SHA256 916e3ca83376acd9ca64ee87988c8a19dc86c6468d087ede82d1e05c14a5a142 graph2-0.8.1.cvs20040118.tar.gz 42653
diff --git a/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118-r1 b/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118-r1
deleted file mode 100644
index 071634f706c7..000000000000
--- a/dev-java/commons-graph/files/digest-commons-graph-0.8.1_p20040118-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 2f0b4b570e383321675e56d3a2bbfa08 graph2-0.8.1.cvs20040118.tar.gz 42653
-RMD160 cd5cf77dfcc90ca5b0b05279c4e6492a6aed3c38 graph2-0.8.1.cvs20040118.tar.gz 42653
-SHA256 916e3ca83376acd9ca64ee87988c8a19dc86c6468d087ede82d1e05c14a5a142 graph2-0.8.1.cvs20040118.tar.gz 42653