summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-08-02 20:46:50 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-08-02 20:46:50 +0000
commitb83a3715e7c8d87be704d25ec5a7e0695b417835 (patch)
tree48def01f11766ba806a3384a17a52d671654b16f /dev-java
parentadd ~arm, bug #428248 (diff)
downloadgentoo-2-b83a3715e7c8d87be704d25ec5a7e0695b417835.tar.gz
gentoo-2-b83a3715e7c8d87be704d25ec5a7e0695b417835.tar.bz2
gentoo-2-b83a3715e7c8d87be704d25ec5a7e0695b417835.zip
Respect flags, thanks to Michael Palimaka (kensington) for the patch. #366459
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/byaccj/ChangeLog10
-rw-r--r--dev-java/byaccj/byaccj-1.15-r1.ebuild29
-rw-r--r--dev-java/byaccj/files/Makefile2
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-java/byaccj/ChangeLog b/dev-java/byaccj/ChangeLog
index aec2b36a50cd..09decdeef2fb 100644
--- a/dev-java/byaccj/ChangeLog
+++ b/dev-java/byaccj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/byaccj
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/byaccj/ChangeLog,v 1.6 2011/12/04 16:49:51 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/byaccj/ChangeLog,v 1.7 2012/08/02 20:46:49 sera Exp $
+
+*byaccj-1.15-r1 (02 Aug 2012)
+
+ 02 Aug 2012; Ralph Sennhauser <sera@gentoo.org> +byaccj-1.15-r1.ebuild,
+ files/Makefile:
+ Respect flags, thanks to Michael Palimaka (kensington) for the patch. #366459
04 Dec 2011; Markos Chandras <hwoarang@gentoo.org> byaccj-1.15.ebuild:
add missing die. stable on amd64. bug #370403
diff --git a/dev-java/byaccj/byaccj-1.15-r1.ebuild b/dev-java/byaccj/byaccj-1.15-r1.ebuild
new file mode 100644
index 000000000000..6a76dc701712
--- /dev/null
+++ b/dev-java/byaccj/byaccj-1.15-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/byaccj/byaccj-1.15-r1.ebuild,v 1.1 2012/08/02 20:46:49 sera Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A java extension of BSD YACC-compatible parser generator"
+HOMEPAGE="http://byaccj.sourceforge.net/"
+MY_P="${PN}${PV}_src"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${PN}${PV}"
+
+src_compile() {
+ cp "${FILESDIR}/Makefile" src/Makefile || die
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" -C src linux
+}
+
+src_install() {
+ newbin src/yacc.linux "${PN}"
+ dodoc docs/ACKNOWLEDGEMEN
+}
diff --git a/dev-java/byaccj/files/Makefile b/dev-java/byaccj/files/Makefile
index 003419f6b16d..c46772a1de1b 100644
--- a/dev-java/byaccj/files/Makefile
+++ b/dev-java/byaccj/files/Makefile
@@ -75,7 +75,7 @@ SRCS = closure.c \
$(CC) -c $(CFLAGS) $(INC) $< -o $@
yacc: $(OBJ)
- $(CC) -o yacc $(OBJ)
+ $(CC) $(LDFLAGS) -o yacc $(OBJ)
@echo "done"
clean: