summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-27 20:38:41 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-27 20:38:41 +0000
commitb48d0810e914376e24bb26106447895c66695e9d (patch)
tree21dfb60fdd02f8f4643121a71e626b33ed1ca63b /dev-lang/boo
parentalpha stable wrt #177129 (diff)
downloadgentoo-2-b48d0810e914376e24bb26106447895c66695e9d.tar.gz
gentoo-2-b48d0810e914376e24bb26106447895c66695e9d.tar.bz2
gentoo-2-b48d0810e914376e24bb26106447895c66695e9d.zip
dev-lang/boo: -r1 version bump - added doc and examples use flags, boo.lang is not installed anymore (fixing bug #163926), fixed fdo-mime_* calls
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang/boo')
-rw-r--r--dev-lang/boo/ChangeLog14
-rw-r--r--dev-lang/boo/boo-0.7.5.2013-r1.ebuild (renamed from dev-lang/boo/boo-0.7.5.2013.ebuild)33
-rw-r--r--dev-lang/boo/boo-0.7.6.2237-r1.ebuild48
-rw-r--r--dev-lang/boo/boo-0.7.6.2237.ebuild34
-rw-r--r--dev-lang/boo/files/digest-boo-0.7.5.2013-r1 (renamed from dev-lang/boo/files/digest-boo-0.7.5.2013)0
-rw-r--r--dev-lang/boo/files/digest-boo-0.7.6.2237-r1 (renamed from dev-lang/boo/files/digest-boo-0.7.6.2237)0
6 files changed, 84 insertions, 45 deletions
diff --git a/dev-lang/boo/ChangeLog b/dev-lang/boo/ChangeLog
index 35dc5c160899..297a55c76465 100644
--- a/dev-lang/boo/ChangeLog
+++ b/dev-lang/boo/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-lang/boo
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/ChangeLog,v 1.12 2006/10/29 16:56:27 latexer Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/ChangeLog,v 1.13 2007/06/27 20:38:41 jurek Exp $
+
+*boo-0.7.6.2237-r1 (27 Jun 2007)
+*boo-0.7.5.2013-r1 (27 Jun 2007)
+
+ 27 Jun 2007; Jurek Bartuszek <jurek@gentoo.org> -boo-0.7.5.2013.ebuild,
+ +boo-0.7.5.2013-r1.ebuild, -boo-0.7.6.2237.ebuild,
+ +boo-0.7.6.2237-r1.ebuild:
+ - Added doc and examples use flags
+ - boo.lang is not installed anymore (fixing bug #163926)
+ - Fixed fdo-mime_* calls
*boo-0.7.6.2237 (29 Oct 2006)
diff --git a/dev-lang/boo/boo-0.7.5.2013.ebuild b/dev-lang/boo/boo-0.7.5.2013-r1.ebuild
index e22ca84a61c2..f075da326940 100644
--- a/dev-lang/boo/boo-0.7.5.2013.ebuild
+++ b/dev-lang/boo/boo-0.7.5.2013-r1.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.5.2013.ebuild,v 1.2 2006/01/19 05:40:36 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.5.2013-r1.ebuild,v 1.1 2007/06/27 20:38:41 jurek Exp $
inherit mono fdo-mime eutils
DESCRIPTION="A wrist friendly language for the CLI"
HOMEPAGE="http://boo.codehaus.org/"
-
-SRC_URI="http://dist.codehaus.org/boo/distributions/${P}-src.tar.bz2"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="doc examples"
DEPEND=">=dev-lang/mono-1.1.4
dev-dotnet/nant
@@ -22,7 +21,8 @@ DEPEND=">=dev-lang/mono-1.1.4
src_unpack() {
if has_version "dev-lang/boo"; then
- if ! has_version "=dev-lang/boo-${PV}"; then
+ if ! (has_version ">=dev-lang/boo-${PV}" &&
+ has_version "<=dev-lang/boo-${PVR}"); then
eerror "This version of boo has a problem compiling when any other"
eerror "version of boo is present on the system. Please unmerge boo"
eerror "and then try emerging this version of boo. See bug #108520"
@@ -37,14 +37,29 @@ src_unpack() {
}
src_compile() {
- LC_ALL="C" LANG="C" nant -t:mono-1.0 -D:install.prefix=/usr || die
+ # We no longer need to provide boo.lang (bug #163926)
+ sed -i -e 's#^.*<copy file="extras/boo.lang".*$##' \
+ default.build
+
+ nant -t:mono-1.0 -D:install.prefix=/usr || die
}
src_install() {
- LC_ALL="C" LANG="C" nant install \
+ nant install \
-D:install.destdir=${D} -t:mono-1.0 -D:install.prefix=/usr || die
+
+ use doc && dodoc docs/BooManifesto.sxw
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
}
pkg_postinst() {
- fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
}
diff --git a/dev-lang/boo/boo-0.7.6.2237-r1.ebuild b/dev-lang/boo/boo-0.7.6.2237-r1.ebuild
new file mode 100644
index 000000000000..0866ea8191f5
--- /dev/null
+++ b/dev-lang/boo/boo-0.7.6.2237-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.6.2237-r1.ebuild,v 1.1 2007/06/27 20:38:41 jurek Exp $
+
+inherit mono fdo-mime eutils
+
+DESCRIPTION="A wrist friendly language for the CLI"
+HOMEPAGE="http://boo.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.bz2"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+DEPEND=">=dev-lang/mono-1.1.4
+ dev-dotnet/nant
+ x11-misc/shared-mime-info
+ >=x11-libs/gtksourceview-1.0.1"
+
+src_compile() {
+ # We no longer need to provide boo.lang (bug #163926)
+ sed -i -e 's#^.*<copy file="extras/boo.lang".*$##' \
+ default.build
+
+ nant -t:mono-2.0 -D:install.prefix=/usr || die
+}
+
+src_install() {
+ nant install \
+ -D:install.destdir=${D} -t:mono-2.0 -D:install.prefix=/usr || die
+
+ use doc && dodoc docs/BooManifesto.sxw
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}
diff --git a/dev-lang/boo/boo-0.7.6.2237.ebuild b/dev-lang/boo/boo-0.7.6.2237.ebuild
deleted file mode 100644
index 3ce809e9a4e1..000000000000
--- a/dev-lang/boo/boo-0.7.6.2237.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.7.6.2237.ebuild,v 1.1 2006/10/29 16:56:27 latexer Exp $
-
-inherit mono fdo-mime eutils
-
-DESCRIPTION="A wrist friendly language for the CLI"
-HOMEPAGE="http://boo.codehaus.org/"
-
-SRC_URI="http://dist.codehaus.org/boo/distributions/${P}-src.tar.bz2"
-
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=dev-lang/mono-1.1.4
- dev-dotnet/nant
- x11-misc/shared-mime-info
- >=x11-libs/gtksourceview-1.0.1"
-
-src_compile() {
- LC_ALL="C" LANG="C" nant -t:mono-2.0 -D:install.prefix=/usr || die
-}
-
-src_install() {
- LC_ALL="C" LANG="C" nant install \
- -D:install.destdir=${D} -t:mono-2.0 -D:install.prefix=/usr || die
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-}
diff --git a/dev-lang/boo/files/digest-boo-0.7.5.2013 b/dev-lang/boo/files/digest-boo-0.7.5.2013-r1
index d3364bfdb032..d3364bfdb032 100644
--- a/dev-lang/boo/files/digest-boo-0.7.5.2013
+++ b/dev-lang/boo/files/digest-boo-0.7.5.2013-r1
diff --git a/dev-lang/boo/files/digest-boo-0.7.6.2237 b/dev-lang/boo/files/digest-boo-0.7.6.2237-r1
index 55c2e3ba8190..55c2e3ba8190 100644
--- a/dev-lang/boo/files/digest-boo-0.7.6.2237
+++ b/dev-lang/boo/files/digest-boo-0.7.6.2237-r1