summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-01-23 06:50:57 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-01-23 06:50:57 +0000
commit214f6912129a850cec29974294c90cc6d3fc1274 (patch)
tree488f2d99331f5b5313f4f9c6a374a5973389015e /dev-lang/erlang
parentinitial import (diff)
downloadgentoo-2-214f6912129a850cec29974294c90cc6d3fc1274.tar.gz
gentoo-2-214f6912129a850cec29974294c90cc6d3fc1274.tar.bz2
gentoo-2-214f6912129a850cec29974294c90cc6d3fc1274.zip
clean up
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/ChangeLog7
-rw-r--r--dev-lang/erlang/erlang-11.2.5-r3.ebuild169
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.5-r39
-rw-r--r--dev-lang/erlang/files/erlang-11.2.5-hipe.patch12
-rw-r--r--dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch17
5 files changed, 6 insertions, 208 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index efea1658dadf..08b6e243fa13 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.95 2008/01/22 19:27:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.96 2008/01/23 06:50:56 opfer Exp $
+
+ 23 Jan 2008; Christian Faulhammer <opfer@gentoo.org>
+ -files/erlang-11.2.5-hipe.patch,
+ -files/erlang-11.2.5-odbc-support-amd64.patch, -erlang-11.2.5-r3.ebuild:
+ clean up
22 Jan 2008; Raúl Porcel <armin76@gentoo.org> erlang-12.2.0.ebuild:
alpha/sparc stable wrt #206882
diff --git a/dev-lang/erlang/erlang-11.2.5-r3.ebuild b/dev-lang/erlang/erlang-11.2.5-r3.ebuild
deleted file mode 100644
index b4a76d85c49c..000000000000
--- a/dev-lang/erlang/erlang-11.2.5-r3.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.5-r3.ebuild,v 1.6 2007/12/21 13:18:40 nixnut Exp $
-
-inherit elisp-common eutils flag-o-matic multilib versionator
-
-# NOTE: You need to adjust the version number in the last comment. If you need symlinks for
-# binaries please tell maintainers or open up a bug to let it be created.
-
-# erlang uses a really weird versioning scheme which caused quite a few problems
-# already. Thus we do a slight modification converting all letters to digits to
-# make it more sane (see e.g. #26420)
-
-# the next line selects the right source.
-MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
-
-# ATTN!! Take care when processing the C, etc version!
-MY_P=otp_src_${MY_PV}
-
-DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
-HOMEPAGE="http://www.erlang.org/"
-SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
- doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
- http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
-
-LICENSE="EPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 ppc ~ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
-
-RDEPEND=">=dev-lang/perl-5.6.1
- ssl? ( >=dev-libs/openssl-0.9.7d )
- emacs? ( virtual/emacs )
- java? ( >=virtual/jdk-1.2 )
- odbc? ( dev-db/unixODBC )"
-DEPEND="${RDEPEND}
- tk? ( dev-lang/tk )"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE=50erlang-gentoo.el
-
-src_unpack() {
-
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-build.patch #184419
-
- # needed for amd64
- epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
-
- # needed for FreeBSD
- epatch "${FILESDIR}/${P}-gethostbyname.patch"
-
- # odbc is disabled in the amd64 code, but it works
- if use amd64 && use odbc; then
- epatch "${FILESDIR}/${P}-odbc-support-amd64.patch"
- fi
-
- # needed for building with hipe and recent coreutils
- use hipe && epatch "${FILESDIR}"/${P}-hipe.patch
-
- use odbc || sed -i 's: odbc : :' lib/Makefile
-
- # make sure we only link ssl dynamically
- sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
-
- if use hipe; then
- ewarn
- ewarn "You enabled High performance Erlang. Be aware that this extension"
- ewarn "can break the compilation in many ways, especially on hardened systems."
- ewarn "Don't cry, don't file bugs, just disable it!"
- ewarn
- fi
-}
-
-src_compile() {
- use java || export JAVAC=false
-
- econf \
- --enable-threads \
- $(use_enable hipe) \
- $(use_with ssl) \
- $(use_enable kpoll kernell-poll) \
- $(use_enable smp smp-support) \
- || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use emacs ; then
- pushd lib/tools/emacs
- elisp-compile *.el
- popd
- fi
-}
-
-extract_version() {
- sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
-}
-
-src_install() {
- local ERL_LIBDIR=/usr/$(get_libdir)/erlang
- local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
- local ERL_ERTS_VER=$(extract_version erts VSN)
-
- emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
- dodoc AUTHORS README
-
- dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
- dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
- dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
- dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
- dosym \
- "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
- /usr/bin/erl_call
- dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
-
- ## Remove ${D} from the following files
- dosed "${ERL_LIBDIR}/bin/erl"
- dosed "${ERL_LIBDIR}/bin/start"
- grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
-
- ## Clean up the no longer needed files
- rm "${D}/${ERL_LIBDIR}/Install"
-
- if use doc ; then
- for i in "${WORKDIR}"/man/man* ; do
- dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
- done
- for file in "${WORKDIR}"/man/man*/*.[1-9]; do
- # Man page processing tools expect a capitalized "SEE ALSO" section
- # header, has been reported upstream, should be fixed in R12
- sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${file}
- # doman sucks so we can't use it
- cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
- done
- # extend MANPATH, so the normal man command can find it
- # see bug 189639
- dodir /etc/env.d/
- echo "MANPATH=\"${ERL_LIBDIR}/man\"" > "${D}/etc/env.d/90erlang"
- dohtml -A README,erl,hrl,c,h,kwc,info -r \
- "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
- fi
-
- if use emacs ; then
- pushd "${S}"
- elisp-install erlang lib/tools/emacs/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- popd
- fi
-
- # prepare erl for SMP, fixes bug #188112
- use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
- "${D}/${ERL_LIBDIR}/bin/erl"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
- elog
- elog "If you need a symlink to one of erlang's binaries,"
- elog "please open a bug and tell the maintainers."
- elog
- elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R11B-5"
- elog
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.5-r3 b/dev-lang/erlang/files/digest-erlang-11.2.5-r3
deleted file mode 100644
index 77aa33e4a391..000000000000
--- a/dev-lang/erlang/files/digest-erlang-11.2.5-r3
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 6a40146d855f98d024682cd24e9bb5bc otp_doc_html_R11B-5.tar.gz 4968176
-RMD160 73f8056b66f3bc6ec6b93c3c3dbfdf47074f8974 otp_doc_html_R11B-5.tar.gz 4968176
-SHA256 7dea67980b958ffebf7a94f3d94bd9c874e041f4f5ee574c56aab62c54a71d28 otp_doc_html_R11B-5.tar.gz 4968176
-MD5 5c387162ae6d255f525d72a91481d135 otp_doc_man_R11B-5.tar.gz 725858
-RMD160 62d200be6143183a17f5263b7341ec40afe298c7 otp_doc_man_R11B-5.tar.gz 725858
-SHA256 ab364af6e9db473d2bc5c0646a9b70989b858953ca9c053b78a509960a4f9caa otp_doc_man_R11B-5.tar.gz 725858
-MD5 96acec41da87d6ee0ef18e1aab36ffdd otp_src_R11B-5.tar.gz 38332865
-RMD160 67eac12a891df0e8d46b383ea0997f9de3aa6ac6 otp_src_R11B-5.tar.gz 38332865
-SHA256 d41fdfba40f86a50e04b7226ae5cc4581072fad26d14be5e1ca06603813bb175 otp_src_R11B-5.tar.gz 38332865
diff --git a/dev-lang/erlang/files/erlang-11.2.5-hipe.patch b/dev-lang/erlang/files/erlang-11.2.5-hipe.patch
deleted file mode 100644
index d9399e024d9a..000000000000
--- a/dev-lang/erlang/files/erlang-11.2.5-hipe.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Fix duplicate entry in makefile
-
---- otp_src_R11B-5.orig/lib/hipe/regalloc/Makefile 2007-09-12 12:45:03.000000000 -0600
-+++ otp_src_R11B-5/lib/hipe/regalloc/Makefile 2007-09-12 12:46:01.000000000 -0600
-@@ -43,7 +43,6 @@
- hipe_temp_map \
- hipe_optimistic_regalloc \
- hipe_coalescing_regalloc \
-- hipe_optimistic_regalloc \
- hipe_graph_coloring_regalloc \
- hipe_regalloc_loop \
- hipe_ls_regalloc \ \ No newline at end of file
diff --git a/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch b/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch
deleted file mode 100644
index 1b5405e9c41d..000000000000
--- a/dev-lang/erlang/files/erlang-11.2.5-odbc-support-amd64.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -urN otp_src_R11B-5/lib/odbc/c_src/Makefile.in otp_src_R11B-5.odbc/lib/odbc/c_src/Makefile.in
---- otp_src_R11B-5/lib/odbc/c_src/Makefile.in 2006-05-03 11:18:45.000000000 +0300
-+++ otp_src_R11B-5.odbc/lib/odbc/c_src/Makefile.in 2007-11-07 00:24:36.000000000 +0200
-@@ -57,11 +57,11 @@
- WIN32_TARGET = $(WIN_BIN_DIR)/odbcserver.exe
- EXE_TARGET = $(WIN32_TARGET)
- else
--ifneq ($(BITS64),yes)
-+#ifneq ($(BITS64),yes)
- EI_LIB = -lerl_interface -lei
- UNIX_TARGET = $(BIN_DIR)/odbcserver
- EXE_TARGET = $(UNIX_TARGET)
--endif
-+#endif
- endif
-
- C_FILES = odbcserver.c