summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-24 00:48:14 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-24 00:48:14 +0000
commit58ebda01aa1e8c8b958dc174e3ac782a7f17ecc6 (patch)
tree4524078bc2548d2aae74c626a0343ea3f2ce4fd0 /dev-lang/erlang
parent#100405: sedded #include <errno.h> into main.cc so it actually compiles (diff)
downloadgentoo-2-58ebda01aa1e8c8b958dc174e3ac782a7f17ecc6.tar.gz
gentoo-2-58ebda01aa1e8c8b958dc174e3ac782a7f17ecc6.tar.bz2
gentoo-2-58ebda01aa1e8c8b958dc174e3ac782a7f17ecc6.zip
Add a version which works with wings #97798.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/ChangeLog7
-rw-r--r--dev-lang/erlang/erlang-10.2.5.ebuild108
-rw-r--r--dev-lang/erlang/files/digest-erlang-10.2.53
3 files changed, 117 insertions, 1 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 117d6b044e05..6d2fef650328 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.21 2005/07/18 20:21:03 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.22 2005/08/24 00:48:14 vapier Exp $
+
+*erlang-10.2.5 (24 Aug 2005)
+
+ 24 Aug 2005; Mike Frysinger <vapier@gentoo.org> +erlang-10.2.5.ebuild:
+ Add a version which works with wings #97798.
18 Jul 2005; Matthew Kennedy <mkennedy@gentoo.org>
+files/10.2.6-manpage-emacs-gentoo.patch, files/50erlang-gentoo.el,
diff --git a/dev-lang/erlang/erlang-10.2.5.ebuild b/dev-lang/erlang/erlang-10.2.5.ebuild
new file mode 100644
index 000000000000..62448593d927
--- /dev/null
+++ b/dev-lang/erlang/erlang-10.2.5.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-10.2.5.ebuild,v 1.1 2005/08/24 00:48:14 vapier Exp $
+
+inherit eutils multilib flag-o-matic elisp-common
+
+#erlang uses a really weird versioning scheme which caused quite a few problems already
+#Thus we do a slight modification converting all letters to digits to make it more sane (see e.g. #26420)
+#the next line selects the right source.
+MY_PV=R10B-5
+MY_P=otp_src_${MY_PV}
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+ doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+ http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+
+LICENSE="EPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc emacs java odbc ssl X"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ X? ( virtual/x11 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ emacs? ( virtual/emacs )
+ java? ( >=virtual/jdk-1.2 )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ dev-lang/tk"
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50erlang-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-10.2.6-export-TARGET.patch
+ epatch "${FILESDIR}"/10.2.6-manpage-emacs-gentoo.patch
+ use odbc || sed -i 's: odbc : :' lib/Makefile
+}
+
+src_compile() {
+ use java || export JAVAC=false
+ econf \
+ --enable-threads \
+ $(use_with ssl) \
+ || die
+ make || die
+
+ if use emacs ; then
+ pushd lib/tools/emacs
+ elisp-compile *.el
+ popd
+ fi
+}
+
+src_install() {
+ local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+
+ make INSTALL_PREFIX="${D}" install || die
+ dodoc AUTHORS EPLICENCE README
+
+ dosym ${ERL_LIBDIR}/bin/erl /usr/bin/erl
+ dosym ${ERL_LIBDIR}/bin/erlc /usr/bin/erlc
+ dosym ${ERL_LIBDIR}/bin/ecc /usr/bin/ecc
+ dosym ${ERL_LIBDIR}/bin/elink /usr/bin/elink
+ dosym ${ERL_LIBDIR}/bin/ear /usr/bin/ear
+ dosym ${ERL_LIBDIR}/bin/escript /usr/bin/escript
+
+ ## Remove ${D} from the following files
+ dosed ${ERL_LIBDIR}/bin/erl
+ dosed ${ERL_LIBDIR}/bin/start
+ cd ${ERL_LIBDIR}/erts-*
+ grep -rle "${D}" "${D}"/${ERL_LIBDIR}/erts-* | xargs sed -i -e "s:${D}::g"
+
+ ## Clean up the no longer needed files
+ rm "${D}"/${ERL_LIBDIR}/Install
+
+ if use doc ; then
+ for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+ # Avoid namespace collisions
+ local newfile=${file}erl
+ cp $file $newfile
+ # Man page processing tools expect a capitalized "SEE ALSO" section
+ # header
+ sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' $newfile
+ doman ${newfile}
+ done
+ dohtml -A README,erl,hrl,c,h,kwc,info -r "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+ fi
+
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install erlang lib/tools/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/erlang/files/digest-erlang-10.2.5 b/dev-lang/erlang/files/digest-erlang-10.2.5
new file mode 100644
index 000000000000..7023d030700d
--- /dev/null
+++ b/dev-lang/erlang/files/digest-erlang-10.2.5
@@ -0,0 +1,3 @@
+MD5 fa6c4ba8291e1d11ae412e4d6f0fa392 otp_src_R10B-5.tar.gz 9996505
+MD5 7615ad16c1f26e4cd8891d968d1168fa otp_doc_html_R10B-5.tar.gz 4591317
+MD5 a64d7797ce0f98363f8bd59608a35a58 otp_doc_man_R10B-5.tar.gz 597252