summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2006-03-26 17:52:06 +0000
committerGeorge Shapovalov <george@gentoo.org>2006-03-26 17:52:06 +0000
commit257d1760046cbf35ed78047d494f6934457141e0 (patch)
tree2a57ae8ffec9d000c52b6cde62db974e8b55fcfc /dev-lang/gnat-gcc/gnat-gcc-3.4.5-r2.ebuild
parentMark 3.4.3 stable on ia64 (diff)
downloadgentoo-2-257d1760046cbf35ed78047d494f6934457141e0.tar.gz
gentoo-2-257d1760046cbf35ed78047d494f6934457141e0.tar.bz2
gentoo-2-257d1760046cbf35ed78047d494f6934457141e0.zip
new revision and version. Match the much revorked eclass. Multilib is handled better, use i386 bootstraps on x86, misc fixes..
(Portage version: 2.1_pre6-r5)
Diffstat (limited to 'dev-lang/gnat-gcc/gnat-gcc-3.4.5-r2.ebuild')
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-3.4.5-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lang/gnat-gcc/gnat-gcc-3.4.5-r2.ebuild b/dev-lang/gnat-gcc/gnat-gcc-3.4.5-r2.ebuild
new file mode 100644
index 000000000000..897c584241c9
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-3.4.5-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-3.4.5-r2.ebuild,v 1.1 2006/03/26 17:52:06 george Exp $
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+# BOOT_SLOT is defined in gnatbuild.eclass and depends only on $PV
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ x86? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i386.tar.bz2 )
+ amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64-r2.tar.bz2 )"
+
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd ${S}/gcc/ada
+ sed -i -e "s:CFLAGS = -O2:CFLAGS = ${CFLAGS}:" \
+ Makefile.adalib || die "patching Makefile.adalib failed"
+}