summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2003-09-29 22:47:18 +0000
committerDavid Holm <dholm@gentoo.org>2003-09-29 22:47:18 +0000
commitdad72f5462ea486e50e5911bc32f301c738dbd9b (patch)
tree6148745cd6a4e699610ad1176784aca430a87d97 /dev-lang/gnat/gnat-3.15p-r3.ebuild
parentAdded gcc3 patch .Closes #27519. (diff)
downloadgentoo-2-dad72f5462ea486e50e5911bc32f301c738dbd9b.tar.gz
gentoo-2-dad72f5462ea486e50e5911bc32f301c738dbd9b.tar.bz2
gentoo-2-dad72f5462ea486e50e5911bc32f301c738dbd9b.zip
Changed CFLAGS as suggested by Maxim Reznik <max1@mbank.com.ua>
Diffstat (limited to 'dev-lang/gnat/gnat-3.15p-r3.ebuild')
-rw-r--r--dev-lang/gnat/gnat-3.15p-r3.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-lang/gnat/gnat-3.15p-r3.ebuild b/dev-lang/gnat/gnat-3.15p-r3.ebuild
index ac04da1ac465..6bd615d1ffbe 100644
--- a/dev-lang/gnat/gnat-3.15p-r3.ebuild
+++ b/dev-lang/gnat/gnat-3.15p-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat/gnat-3.15p-r3.ebuild,v 1.2 2003/09/29 17:07:54 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat/gnat-3.15p-r3.ebuild,v 1.3 2003/09/29 22:47:13 dholm Exp $
DESCRIPTION="The GNU Ada Toolkit"
DEPEND="x86? ( >=app-shells/tcsh-6.0 )"
@@ -76,13 +76,13 @@ src_compile() {
# Compile it by first using the bootstrap compiler and then bootstrapping
# our own version. Finally compile the libraries and tools.
- make CC="gcc" CFLAGS="-O0" LANGUAGES="c ada gcov" || \
+ make CC="gcc" CFLAGS="-O2 -gnatpgn" LANGUAGES="c ada gcov" || \
die "Failed while running inital compilation!"
- make CC="gcc" CFLAGS="-O0" LANGUAGES="c ada gcov" bootstrap || \
+ make CC="gcc" CFLAGS="-O2 -gnatpgn" LANGUAGES="c ada gcov" bootstrap || \
die "Died while bootstrapping!"
- make CC="gcc" CFLAGS="-O0" GNATLIBCFLAGS="-O0" gnatlib-shared || \
- die "Failed to build the shared version of gnatlib!"
- make CC="gcc" CFLAGS="-O0" gnattools || \
+ make CC="gcc" CFLAGS="-O2 -gnatpgn" GNATLIBCFLAGS="-O2 -gnatpgn -fPIC" \
+ gnatlib-shared || die "Failed to build the shared version of gnatlib!"
+ make CC="gcc" CFLAGS="-O2 -gnatpgn" gnattools || \
die "Failed to build gnattools!"
}
@@ -100,7 +100,7 @@ src_install() {
touch "${D}/usr/lib/ada/gcc-lib/${CHOST}/2.8.1/include/float.h"
# Build and install the static version of gnatlib
- make CC="gcc" CFLAGS="-O0" GNATLIBCFLAGS="-O0 -fPIC" gnatlib ||
+ make CC="gcc" CFLAGS="-O2 -gnatpgn" GNATLIBCFLAGS="-O2 -gnatpgn" gnatlib ||
die "Failed while compiling static gnatlib!"
make prefix="${D}/usr" libdir="${D}/usr/lib/ada" \
LANGUAGES="c ada gcov" GCC_INSTALL_NAME=gnatgcc install-gnatlib ||