summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-08-15 22:24:10 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-08-15 22:24:10 +0000
commitf0358e2a5e94fa87271655210bb025dcf967c646 (patch)
tree9cc8ac0b0a6dfff93e350ae41b376fe5b58cdbe0 /dev-lang/go
parentversion bump for #480842 (diff)
downloadgentoo-2-f0358e2a5e94fa87271655210bb025dcf967c646.tar.gz
gentoo-2-f0358e2a5e94fa87271655210bb025dcf967c646.tar.bz2
gentoo-2-f0358e2a5e94fa87271655210bb025dcf967c646.zip
remove old version
(Portage version: 2.2.0/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang/go')
-rw-r--r--dev-lang/go/ChangeLog6
-rw-r--r--dev-lang/go/files/go-1.1-no-Werror.patch12
-rw-r--r--dev-lang/go/go-1.1.ebuild139
3 files changed, 5 insertions, 152 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 7f814523d78f..f05eec7af1fe 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.19 2013/08/15 22:21:58 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.20 2013/08/15 22:24:10 williamh Exp $
+
+ 15 Aug 2013; William Hubbs <williamh@gentoo.org>
+ -files/go-1.1-no-Werror.patch, -go-1.1.ebuild:
+ remove old version
*go-1.1.2 (15 Aug 2013)
diff --git a/dev-lang/go/files/go-1.1-no-Werror.patch b/dev-lang/go/files/go-1.1-no-Werror.patch
deleted file mode 100644
index f5c45767ae5c..000000000000
--- a/dev-lang/go/files/go-1.1-no-Werror.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Disable -Werror.
-
---- a/src/cmd/dist/build.c
-+++ b/src/cmd/dist/build.c
-@@ -384,7 +384,6 @@ static char *proto_gccargs[] = {
- "-Wno-unknown-pragmas",
- "-Wno-switch",
- "-Wno-comment",
-- "-Werror",
- "-fno-common",
- "-ggdb",
- "-O2",
diff --git a/dev-lang/go/go-1.1.ebuild b/dev-lang/go/go-1.1.ebuild
deleted file mode 100644
index 91312b9cac6c..000000000000
--- a/dev-lang/go/go-1.1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.1.ebuild,v 1.2 2013/05/20 16:52:33 williamh Exp $
-
-EAPI=5
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-inherit bash-completion-r1 elisp-common eutils
-
-if [[ ${PV} = 9999 ]]; then
- EHG_REPO_URI="https://go.googlecode.com/hg"
- inherit mercurial
-else
- SRC_URI="http://go.googlecode.com/files/go${PV}.src.tar.gz"
- # Upstream only supports go on amd64, arm and x86 architectures.
- KEYWORDS="-* ~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="A concurrent garbage collected and typesafe programming language"
-HOMEPAGE="http://www.golang.org"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="bash-completion emacs vim-syntax zsh-completion"
-
-DEPEND="sys-apps/ed"
-RDEPEND="bash-completion? ( app-shells/bash-completion )
- emacs? ( virtual/emacs )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
- zsh-completion? ( app-shells/zsh-completion )"
-
-# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/linux.*/.*"
-
-# The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped.
-STRIP_MASK="/usr/lib/go/pkg/linux*/*.a"
-
-if [[ ${PV} != 9999 ]]; then
- S="${WORKDIR}"/go
-fi
-
-src_prepare()
-{
- if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}"/${P}-no-Werror.patch
- fi
- epatch_user
-}
-
-src_compile()
-{
- export GOROOT_FINAL=/usr/lib/go
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
- if [[ $CTARGET = armv5* ]]
- then
- export GOARM=5
- fi
-
- cd src
- ./make.bash || die "build failed"
- cd ..
-
- if use emacs; then
- elisp-compile misc/emacs/*.el
- fi
-}
-
-src_test()
-{
- cd src
- PATH="${GOBIN}:${PATH}" \
- ./run.bash --no-rebuild --banner || die "tests failed"
-}
-
-src_install()
-{
- dobin bin/*
- dodoc AUTHORS CONTRIBUTORS PATENTS README
-
- dodir /usr/lib/go
- insinto /usr/lib/go
-
- # There is a known issue which requires the source tree to be installed [1].
- # Once this is fixed, we can consider using the doc use flag to control
- # installing the doc and src directories.
- # [1] http://code.google.com/p/go/issues/detail?id=2775
- doins -r doc include lib pkg src
-
- if use bash-completion; then
- dobashcomp misc/bash/go
- fi
-
- if use emacs; then
- elisp-install ${PN} misc/emacs/*.el misc/emacs/*.elc
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r misc/vim/ftdetect
- doins -r misc/vim/ftplugin
- doins -r misc/vim/syntax
- doins -r misc/vim/plugin
- doins -r misc/vim/indent
- fi
-
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins misc/zsh/go
- fi
-
- fperms -R +x /usr/lib/go/pkg/tool
-}
-
-pkg_postinst()
-{
- if use emacs; then
- elisp-site-regen
- fi
-
- # If the go tool sees a package file timestamped older than a dependancy it
- # will rebuild that file. So, in order to stop go from rebuilding lots of
- # packages for every build we need to fix the timestamps. The compiler and
- # linker are also checked - so we need to fix them too.
- ebegin "fixing timestamps to avoid unnecessary rebuilds"
- tref="usr/lib/go/pkg/*/runtime.a"
- find "${ROOT}"usr/lib/go -type f \
- -exec touch -r "${ROOT}"${tref} {} \;
- eend $?
-}
-
-pkg_postrm()
-{
- if use emacs; then
- elisp-site-regen
- fi
-}