summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-11-03 20:22:56 +0000
committerFabian Groffen <grobian@gentoo.org>2014-11-03 20:22:56 +0000
commitf2e3c5087f11e234be5f1bac92e52cbd97ebeb89 (patch)
tree1fbb319cabf9d10e54893fbf600789738bb30aea /dev-lang/go
parentCleanup old. (diff)
downloadgentoo-2-f2e3c5087f11e234be5f1bac92e52cbd97ebeb89.tar.gz
gentoo-2-f2e3c5087f11e234be5f1bac92e52cbd97ebeb89.tar.bz2
gentoo-2-f2e3c5087f11e234be5f1bac92e52cbd97ebeb89.zip
Darwin: make sure we build with GCC by default instead of Clang, bug #528076
(Portage version: 2.2.14_rc1-prefix/cvs/Darwin i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-lang/go')
-rw-r--r--dev-lang/go/ChangeLog6
-rw-r--r--dev-lang/go/go-1.3.3.ebuild7
-rw-r--r--dev-lang/go/go-9999.ebuild7
3 files changed, 13 insertions, 7 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 41b943c9d682..544c134faf51 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.52 2014/10/24 17:40:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.53 2014/11/03 20:22:56 grobian Exp $
+
+ 03 Nov 2014; Fabian Groffen <grobian@gentoo.org> go-1.3.3.ebuild,
+ go-9999.ebuild:
+ Darwin: make sure we build with GCC by default instead of Clang, bug #528076
24 Oct 2014; Michał Górny <mgorny@gentoo.org> go-1.3.3.ebuild:
Alias additional commands for bash-completion, bug #526240.
diff --git a/dev-lang/go/go-1.3.3.ebuild b/dev-lang/go/go-1.3.3.ebuild
index ac69b044ed40..9750a6908476 100644
--- a/dev-lang/go/go-1.3.3.ebuild
+++ b/dev-lang/go/go-1.3.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.3.3.ebuild,v 1.5 2014/10/24 17:40:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.3.3.ebuild,v 1.6 2014/11/03 20:22:56 grobian Exp $
EAPI=5
export CTARGET=${CTARGET:-${CHOST}}
-inherit bash-completion-r1 elisp-common eutils
+inherit bash-completion-r1 elisp-common toolchain-funcs eutils
if [[ ${PV} = 9999 ]]; then
EHG_REPO_URI="https://go.googlecode.com/hg"
@@ -34,7 +34,7 @@ QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
# The go language uses *.a files which are _NOT_ libraries and should not be
# stripped.
-STRIP_MASK="/usr/lib/go/pkg/linux*/*.a /usr/lib/go/pkg/freebsd*/*.a"
+STRIP_MASK="/usr/lib/go/pkg/linux*/*.a /usr/lib/go/pkg/freebsd*/*.a /usr/lib/go/pkg/darwin*/*.a"
if [[ ${PV} != 9999 ]]; then
S="${WORKDIR}"/go
@@ -57,6 +57,7 @@ src_compile()
then
export GOARM=5
fi
+ tc-export CC
cd src
./make.bash || die "build failed"
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 5ab72ad844dd..75e2b0314bab 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.19 2014/08/15 00:33:15 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.20 2014/11/03 20:22:56 grobian Exp $
EAPI=5
export CTARGET=${CTARGET:-${CHOST}}
-inherit eutils
+inherit eutils toolchain-funcs
if [[ ${PV} = 9999 ]]; then
EHG_REPO_URI="https://go.googlecode.com/hg"
@@ -32,7 +32,7 @@ QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/.*/.*"
# The go language uses *.a files which are _NOT_ libraries and should not be
# stripped.
-STRIP_MASK="/usr/lib/go/pkg/linux*/*.a /usr/lib/go/pkg/freebsd*/*.a"
+STRIP_MASK="/usr/lib/go/pkg/linux*/*.a /usr/lib/go/pkg/freebsd*/*.a /usr/lib/go/pkg/darwin*/*.a"
if [[ ${PV} != 9999 ]]; then
S="${WORKDIR}"/go
@@ -55,6 +55,7 @@ src_compile()
then
export GOARM=5
fi
+ tc-export CC
cd src
./make.bash || die "build failed"