summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-11-03 20:52:49 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-11-03 20:52:49 +0000
commitbecb804b2de51f684df761792c760ed8d2aece57 (patch)
tree74979e35efff89fd85e3678b173774f3c6b03d37 /dev-lang/hugs98/hugs98-2003.11.ebuild
parentMinor fixes (Manifest recommit) (diff)
downloadgentoo-2-becb804b2de51f684df761792c760ed8d2aece57.tar.gz
gentoo-2-becb804b2de51f684df761792c760ed8d2aece57.tar.bz2
gentoo-2-becb804b2de51f684df761792c760ed8d2aece57.zip
patched for gcc-3.4 (#64426)
Diffstat (limited to 'dev-lang/hugs98/hugs98-2003.11.ebuild')
-rw-r--r--dev-lang/hugs98/hugs98-2003.11.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-lang/hugs98/hugs98-2003.11.ebuild b/dev-lang/hugs98/hugs98-2003.11.ebuild
index aa60673b2882..95349a131070 100644
--- a/dev-lang/hugs98/hugs98-2003.11.ebuild
+++ b/dev-lang/hugs98/hugs98-2003.11.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-2003.11.ebuild,v 1.6 2004/10/18 16:54:02 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hugs98/hugs98-2003.11.ebuild,v 1.7 2004/11/03 20:52:49 kosmikus Exp $
+
+inherit base eutils
IUSE="opengl"
@@ -11,13 +13,19 @@ SRC_URI="http://cvs.haskell.org/Hugs/downloads/Nov2003/${MY_P}.tar.gz"
HOMEPAGE="http://www.haskell.org/hugs/"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="x86 ~sparc"
LICENSE="as-is"
DEPEND="virtual/libc
opengl? ( virtual/opengl virtual/glu virtual/glut )
~app-text/docbook-sgml-dtd-4.2"
+src_unpack() {
+ base_src_unpack
+ cd ${S}/src
+ epatch ${FILESDIR}/${P}-gcc34.patch
+}
+
src_compile() {
local myconf
if use opengl; then