summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-01-20 03:45:28 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-01-20 03:45:28 +0000
commit582c6f0448fae7bc9645ca9f01debb40b430b5c1 (patch)
tree5e56a3b3615f8ed4ece590288d5f3447f89bcfba /dev-lang/io/io-2008.01.17.ebuild
parentVersion bump #205990 by Dennis Schridde. (diff)
downloadgentoo-2-582c6f0448fae7bc9645ca9f01debb40b430b5c1.tar.gz
gentoo-2-582c6f0448fae7bc9645ca9f01debb40b430b5c1.tar.bz2
gentoo-2-582c6f0448fae7bc9645ca9f01debb40b430b5c1.zip
Adding new version
(Portage version: 2.1.4)
Diffstat (limited to 'dev-lang/io/io-2008.01.17.ebuild')
-rw-r--r--dev-lang/io/io-2008.01.17.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lang/io/io-2008.01.17.ebuild b/dev-lang/io/io-2008.01.17.ebuild
new file mode 100644
index 000000000000..9e55394e33b7
--- /dev/null
+++ b/dev-lang/io/io-2008.01.17.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/io/io-2008.01.17.ebuild,v 1.1 2008/01/20 03:45:28 araujo Exp $
+
+inherit versionator
+
+MY_PV=$(replace_all_version_separators "-")
+MY_P="Io-${MY_PV}"
+
+DESCRIPTION="Io is a small, prototype-based programming language."
+HOMEPAGE="http://www.iolanguage.com"
+SRC_URI="http://io.urbanape.com/release/${MY_P}.tar.gz
+ http://www.sigusr1.org/~steve/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ make INSTALL_PREFIX="/usr" || die "make failed."
+}
+
+src_install() {
+ make install \
+ INSTALL_PREFIX="${D}/usr" \
+ || die "make install failed"
+ if use doc; then
+ dodoc "${S}/docs/guide.{html,pdf}"
+ fi
+}