summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-09-17 19:16:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-09-17 19:16:49 +0000
commitaa63c8d386819fc54a43918c1c8f8823db8ef1d0 (patch)
tree8b87c363b3ffec32ec7b2a0d57054173aa22cf8b /dev-lang/jimtcl/jimtcl-0.74-r1.ebuild
parentKeyword ~arm (diff)
downloadgentoo-2-aa63c8d386819fc54a43918c1c8f8823db8ef1d0.tar.gz
gentoo-2-aa63c8d386819fc54a43918c1c8f8823db8ef1d0.tar.bz2
gentoo-2-aa63c8d386819fc54a43918c1c8f8823db8ef1d0.zip
Fix shared library symlink. Bug #485064
(Portage version: 2.2.4/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'dev-lang/jimtcl/jimtcl-0.74-r1.ebuild')
-rw-r--r--dev-lang/jimtcl/jimtcl-0.74-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild b/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild
new file mode 100644
index 000000000000..7377dc88fbda
--- /dev/null
+++ b/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-0.74-r1.ebuild,v 1.1 2013/09/17 19:16:49 hwoarang Exp $
+
+EAPI="5"
+
+inherit multilib
+
+DESCRIPTION="Small footprint implementation of Tcl programming language"
+HOMEPAGE="http://jim.tcl.tk"
+SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc static-libs"
+DEPEND="doc? ( app-text/asciidoc )
+ app-arch/unzip"
+
+GIT_HASH="9a3562c"
+S="${WORKDIR}"/msteveb-${PN}-${GIT_HASH}
+
+src_configure() {
+ ! use static-libs && myconf=--with-jim-shared
+ econf ${myconf}
+}
+
+src_compile() {
+ emake all
+ use doc && emake docs
+}
+
+src_install() {
+ dobin jimsh
+ use static-libs && {
+ dolib.a libjim.a
+ } || {
+ dolib.so libjim.so.${PV}
+ dosym /usr/$(get_libdir)/libjim.so.${PV} \
+ /usr/$(get_libdir)/libjim.so
+ }
+ insinto /usr/include
+ doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h
+ doins jim-win32compat.h jim-eventloop.h jim-config.h
+ dodoc AUTHORS README TODO
+ use doc && dohtml Tcl.html
+}