summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2010-07-23 21:48:26 +0000
committerKeri Harris <keri@gentoo.org>2010-07-23 21:48:26 +0000
commitd0a84bfa0306e74cb109a6d405e79beb62229296 (patch)
tree0b012e74d4065b64a7d0fc12f1d2f79ad0c15b5a /dev-lang/mercury-extras
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-d0a84bfa0306e74cb109a6d405e79beb62229296.tar.gz
gentoo-2-d0a84bfa0306e74cb109a6d405e79beb62229296.tar.bz2
gentoo-2-d0a84bfa0306e74cb109a6d405e79beb62229296.zip
Disable erlang-grade in install_libgrades
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mercury-extras')
-rw-r--r--dev-lang/mercury-extras/ChangeLog8
-rw-r--r--dev-lang/mercury-extras/files/mercury-extras-10.04-lex.patch5
-rw-r--r--dev-lang/mercury-extras/files/mercury-extras-10.04-no-java-grade-no-erlang-grade.patch (renamed from dev-lang/mercury-extras/files/mercury-extras-10.04-no-java-grade.patch)46
-rw-r--r--dev-lang/mercury-extras/mercury-extras-10.04.ebuild4
4 files changed, 41 insertions, 22 deletions
diff --git a/dev-lang/mercury-extras/ChangeLog b/dev-lang/mercury-extras/ChangeLog
index cb8c73acc503..1f570422f76c 100644
--- a/dev-lang/mercury-extras/ChangeLog
+++ b/dev-lang/mercury-extras/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/mercury-extras
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/ChangeLog,v 1.72 2010/07/19 19:02:13 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/ChangeLog,v 1.73 2010/07/23 21:48:25 keri Exp $
+
+ 23 Jul 2010; <keri@gentoo.org> mercury-extras-10.04.ebuild,
+ files/mercury-extras-10.04-lex.patch,
+ -files/mercury-extras-10.04-no-java-grade.patch,
+ +files/mercury-extras-10.04-no-java-grade-no-erlang-grade.patch:
+ Disable erlang-grade in install_libgrades
*mercury-extras-10.04 (19 Jul 2010)
diff --git a/dev-lang/mercury-extras/files/mercury-extras-10.04-lex.patch b/dev-lang/mercury-extras/files/mercury-extras-10.04-lex.patch
index e92e4e4a053f..39dcfad46ac3 100644
--- a/dev-lang/mercury-extras/files/mercury-extras-10.04-lex.patch
+++ b/dev-lang/mercury-extras/files/mercury-extras-10.04-lex.patch
@@ -1,7 +1,7 @@
diff -urN lex/Mmakefile lex/Mmakefile
--- lex/Mmakefile 1970-01-01 12:00:00.000000000 +1200
+++ lex/Mmakefile 2010-07-19 21:37:59.000000000 +1200
-@@ -0,0 +1,27 @@
+@@ -0,0 +1,29 @@
+# Copyright (C) 2001 Ralph Becket <rbeck@microsoft.com>
+# Copyright (C) 2002 The University of Melbourne
+
@@ -21,6 +21,7 @@ diff -urN lex/Mmakefile lex/Mmakefile
+MAIN_TARGET = all
+
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
+.PHONEY: all depend install
+
@@ -29,3 +30,5 @@ diff -urN lex/Mmakefile lex/Mmakefile
+depend: lex.depend regex.depend
+
+install:
++ $(MMAKE) liblex.install
++ $(MMAKE) libregex.install
diff --git a/dev-lang/mercury-extras/files/mercury-extras-10.04-no-java-grade.patch b/dev-lang/mercury-extras/files/mercury-extras-10.04-no-java-grade-no-erlang-grade.patch
index ba1af0f90726..6f498616bedd 100644
--- a/dev-lang/mercury-extras/files/mercury-extras-10.04-no-java-grade.patch
+++ b/dev-lang/mercury-extras/files/mercury-extras-10.04-no-java-grade-no-erlang-grade.patch
@@ -1,11 +1,12 @@
diff -ur mercury-extras-10.04.orig/cgi/Mmakefile mercury-extras-10.04/cgi/Mmakefile
--- mercury-extras-10.04.orig/cgi/Mmakefile 2004-07-30 19:01:07.000000000 +1200
+++ mercury-extras-10.04/cgi/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -12,6 +12,8 @@
+@@ -12,6 +12,9 @@
MAIN_TARGET = $(LIBRARY)
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
MCFLAGS-mercury_www = --no-warn-nothing-exported
@@ -13,11 +14,12 @@ diff -ur mercury-extras-10.04.orig/cgi/Mmakefile mercury-extras-10.04/cgi/Mmakef
diff -ur mercury-extras-10.04.orig/complex_numbers/Mmakefile mercury-extras-10.04/complex_numbers/Mmakefile
--- mercury-extras-10.04.orig/complex_numbers/Mmakefile 2003-01-16 23:44:11.000000000 +1300
+++ mercury-extras-10.04/complex_numbers/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -10,6 +10,8 @@
+@@ -10,6 +10,9 @@
MAIN_TARGET = all
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
all: libcomplex_numbers
@@ -25,23 +27,25 @@ diff -ur mercury-extras-10.04.orig/complex_numbers/Mmakefile mercury-extras-10.0
diff -ur mercury-extras-10.04.orig/curs/Mmakefile mercury-extras-10.04/curs/Mmakefile
--- mercury-extras-10.04.orig/curs/Mmakefile 2003-01-16 23:44:14.000000000 +1300
+++ mercury-extras-10.04/curs/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -26,7 +26,7 @@
+@@ -26,7 +26,8 @@
# Omit this line if you want to install the default grades.
# Edit this line if you want to install with different grades.
#
-#LIBGRADES = asm_fast.gc hlc.gc
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
# The following standard libraries must be linked against in any
# application using the curs library (i.e. MLLIBS must include
diff -ur mercury-extras-10.04.orig/curses/Mmakefile mercury-extras-10.04/curses/Mmakefile
--- mercury-extras-10.04.orig/curses/Mmakefile 2003-01-16 23:44:15.000000000 +1300
+++ mercury-extras-10.04/curses/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -13,6 +13,8 @@
+@@ -13,6 +13,9 @@
# this line to include the appropriate curses library for your OS.
MLLIBS = -lncurses
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
-include ../Mmake.params
@@ -49,11 +53,12 @@ diff -ur mercury-extras-10.04.orig/curses/Mmakefile mercury-extras-10.04/curses/
diff -ur mercury-extras-10.04.orig/dynamic_linking/Mmakefile mercury-extras-10.04/dynamic_linking/Mmakefile
--- mercury-extras-10.04.orig/dynamic_linking/Mmakefile 2005-01-25 20:49:05.000000000 +1300
+++ mercury-extras-10.04/dynamic_linking/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -17,6 +17,8 @@
+@@ -17,6 +17,9 @@
CFLAGS = -g
MLFLAGS += --no-strip
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
-include ../Mmake.params
@@ -61,51 +66,51 @@ diff -ur mercury-extras-10.04.orig/dynamic_linking/Mmakefile mercury-extras-10.0
diff -ur mercury-extras-10.04.orig/graphics/mercury_glut/Mmakefile mercury-extras-10.04/graphics/mercury_glut/Mmakefile
--- mercury-extras-10.04.orig/graphics/mercury_glut/Mmakefile 2006-03-30 14:52:44.000000000 +1200
+++ mercury-extras-10.04/graphics/mercury_glut/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -10,6 +10,8 @@
+@@ -10,6 +10,9 @@
MAIN_TARGET = libmercury_glut
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
# The following libraries are for X on Linux (Debian) using Mesa.
# Libaries required by X windows.
-Only in mercury-extras-10.04/graphics/mercury_glut: Mmakefile.orig
diff -ur mercury-extras-10.04.orig/graphics/mercury_opengl/Mmakefile mercury-extras-10.04/graphics/mercury_opengl/Mmakefile
--- mercury-extras-10.04.orig/graphics/mercury_opengl/Mmakefile 2007-10-11 19:21:31.000000000 +1300
+++ mercury-extras-10.04/graphics/mercury_opengl/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -15,6 +15,8 @@
+@@ -15,6 +15,9 @@
MAIN_TARGET = libmercury_opengl
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
# Specify what libraries we need to link against for OpenGL on this system.
# (The following works on Debian with mesa as the OpenGL implementation).
GL_LIBS = -lGL -lGLU -L/usr/X11R6/lib -lX11 -lXt -lICE -lXext -lSM
-Only in mercury-extras-10.04/graphics/mercury_opengl: Mmakefile.orig
diff -ur mercury-extras-10.04.orig/graphics/mercury_tcltk/Mmakefile mercury-extras-10.04/graphics/mercury_tcltk/Mmakefile
--- mercury-extras-10.04.orig/graphics/mercury_tcltk/Mmakefile 2005-08-15 16:11:42.000000000 +1200
+++ mercury-extras-10.04/graphics/mercury_tcltk/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -21,6 +21,8 @@
+@@ -21,6 +21,9 @@
MAIN_TARGET = $(LIBRARY)
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
depend: mercury_tcltk.depend
install: libmercury_tcltk.install
-Only in mercury-extras-10.04/graphics/mercury_tcltk: Mmakefile.orig
-Only in mercury-extras-10.04/graphics/mercury_tcltk: mtcltk.m.orig
diff -ur mercury-extras-10.04.orig/lazy_evaluation/Mmakefile mercury-extras-10.04/lazy_evaluation/Mmakefile
--- mercury-extras-10.04.orig/lazy_evaluation/Mmakefile 2003-01-16 23:44:17.000000000 +1300
+++ mercury-extras-10.04/lazy_evaluation/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -4,6 +4,8 @@
+@@ -4,6 +4,9 @@
# Public License - see the file COPYING.LIB in the Mercury distribution.
#-----------------------------------------------------------------------------#
INSTALL_PREFIX := $(INSTALL_PREFIX)/extras
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
-include ../Mmake.params
default_target: all
@@ -113,33 +118,36 @@ diff -ur mercury-extras-10.04.orig/lazy_evaluation/Mmakefile mercury-extras-10.0
diff -ur mercury-extras-10.04.orig/moose/Mmakefile mercury-extras-10.04/moose/Mmakefile
--- mercury-extras-10.04.orig/moose/Mmakefile 2003-01-16 23:44:20.000000000 +1300
+++ mercury-extras-10.04/moose/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -6,6 +6,7 @@
+@@ -6,6 +6,8 @@
# GRADE = asm_fast.gc.debug
# GRADE = asm_fast.gc.prof
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
# MCFLAGS = -O6
# MCFLAGS = --intermodule-optimization -O6
diff -ur mercury-extras-10.04.orig/odbc/Mmakefile mercury-extras-10.04/odbc/Mmakefile
--- mercury-extras-10.04.orig/odbc/Mmakefile 2006-04-03 18:19:54.000000000 +1200
+++ mercury-extras-10.04/odbc/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -8,6 +8,7 @@
+@@ -8,6 +8,8 @@
#-----------------------------------------------------------------------------#
# Configuration
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
# The driver manager.
# Legal values for MODBC_DRIVER are MODBC_IODBC, MODBC_UNIX, and MODBC_MS.
diff -ur mercury-extras-10.04.orig/posix/Mmakefile mercury-extras-10.04/posix/Mmakefile
--- mercury-extras-10.04.orig/posix/Mmakefile 2008-09-02 21:45:54.000000000 +1200
+++ mercury-extras-10.04/posix/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -8,6 +8,8 @@
+@@ -8,6 +8,9 @@
-include ../Mmake.params
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
# The following is needed (on some systems) to enable declarations of
# Posix functions in standard C header files.
@@ -147,11 +155,12 @@ diff -ur mercury-extras-10.04.orig/posix/Mmakefile mercury-extras-10.04/posix/Mm
diff -ur mercury-extras-10.04.orig/quickcheck/Mmakefile mercury-extras-10.04/quickcheck/Mmakefile
--- mercury-extras-10.04.orig/quickcheck/Mmakefile 2003-01-16 23:44:24.000000000 +1300
+++ mercury-extras-10.04/quickcheck/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -10,6 +10,8 @@
+@@ -10,6 +10,9 @@
MAIN_TARGET = all
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
.PHONY: depend
depend: qcheck.depend test_qcheck.depend
@@ -159,11 +168,12 @@ diff -ur mercury-extras-10.04.orig/quickcheck/Mmakefile mercury-extras-10.04/qui
diff -ur mercury-extras-10.04.orig/xml/Mmakefile mercury-extras-10.04/xml/Mmakefile
--- mercury-extras-10.04.orig/xml/Mmakefile 2002-03-06 23:10:31.000000000 +1300
+++ mercury-extras-10.04/xml/Mmakefile 2010-07-20 06:49:40.000000000 +1200
-@@ -8,6 +8,8 @@
+@@ -8,6 +8,9 @@
INSTALL_PREFIX := $(INSTALL_PREFIX)/extras
+LIBGRADES := $(filter-out java,$(LIBGRADES))
++LIBGRADES := $(filter-out erlang,$(LIBGRADES))
+
.PHONY: default_target
default_target: tryit libxml
diff --git a/dev-lang/mercury-extras/mercury-extras-10.04.ebuild b/dev-lang/mercury-extras/mercury-extras-10.04.ebuild
index a4a83f80c479..0926dfee874f 100644
--- a/dev-lang/mercury-extras/mercury-extras-10.04.ebuild
+++ b/dev-lang/mercury-extras/mercury-extras-10.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-10.04.ebuild,v 1.1 2010/07/19 19:02:13 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-10.04.ebuild,v 1.2 2010/07/23 21:48:25 keri Exp $
inherit eutils
@@ -36,7 +36,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-mercury_tcltk.patch
epatch "${FILESDIR}"/${P}-mercury_opengl.patch
epatch "${FILESDIR}"/${P}-posix.patch
- epatch "${FILESDIR}"/${P}-no-java-grade.patch
+ epatch "${FILESDIR}"/${P}-no-java-grade-no-erlang-grade.patch
if use odbc; then
epatch "${FILESDIR}"/${P}-odbc.patch