summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-06-10 08:31:34 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-06-10 08:31:34 +0000
commit64d346263d3b73917ca50c401d610c7e2410ea8b (patch)
tree2d676af41a61afdf157313d2ea29e1322e42fd9d /dev-lang/mlton-bin/mlton-bin-20040227.ebuild
parentclean old ebuild (Manifest recommit) (diff)
downloadgentoo-2-64d346263d3b73917ca50c401d610c7e2410ea8b.tar.gz
gentoo-2-64d346263d3b73917ca50c401d610c7e2410ea8b.tar.bz2
gentoo-2-64d346263d3b73917ca50c401d610c7e2410ea8b.zip
New ebuild for mlton binary release
Diffstat (limited to 'dev-lang/mlton-bin/mlton-bin-20040227.ebuild')
-rw-r--r--dev-lang/mlton-bin/mlton-bin-20040227.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/mlton-bin/mlton-bin-20040227.ebuild b/dev-lang/mlton-bin/mlton-bin-20040227.ebuild
new file mode 100644
index 000000000000..0a4c2d03ab1b
--- /dev/null
+++ b/dev-lang/mlton-bin/mlton-bin-20040227.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mlton-bin/mlton-bin-20040227.ebuild,v 1.1 2004/06/10 08:31:34 mattam Exp $
+
+inherit eutils
+
+DESCRIPTION="Standard ML optimizing compiler and libraries"
+SRC_URI="http://www.mlton.org/download/mlton-${PV}-1.i386-linux.tgz"
+HOMEPAGE="http://www.mlton.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="doc"
+
+DEPEND="virtual/glibc
+dev-libs/gmp"
+
+src_install() {
+ cd ${WORKDIR}/usr
+ dobin bin/*
+
+ insinto /usr/lib/mlton
+
+ cp -Rp lib/mlton/* ${D}/usr/lib/mlton
+
+ doman man/man1/*.1.gz
+
+ cd share/doc/mlton
+ dodoc changelog README
+ dodoc license/*
+
+ if use doc; then
+ cp -R cmcat examples ${D}/usr/share/doc/${P}/
+ dohtml user-guide/*
+ dodoc *.ps.gz
+ fi
+} \ No newline at end of file