summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-05-13 00:29:15 +0000
committerPeter Johanson <latexer@gentoo.org>2005-05-13 00:29:15 +0000
commit1da62a7b557ee71b468c9d8efe1bd19f2819df8b (patch)
tree46e6d0173e80dbee4be3fb24f2cb6104876e5f79 /dev-lang/mono
parentclean old versions and files; tidy (diff)
downloadgentoo-2-1da62a7b557ee71b468c9d8efe1bd19f2819df8b.tar.gz
gentoo-2-1da62a7b557ee71b468c9d8efe1bd19f2819df8b.tar.bz2
gentoo-2-1da62a7b557ee71b468c9d8efe1bd19f2819df8b.zip
have_NPTL is going the way of the dodo.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog7
-rw-r--r--dev-lang/mono/mono-1.0.5-r5.ebuild11
-rw-r--r--dev-lang/mono/mono-1.0.6.ebuild11
-rw-r--r--dev-lang/mono/mono-1.1.4.ebuild4
-rw-r--r--dev-lang/mono/mono-1.1.5-r1.ebuild4
-rw-r--r--dev-lang/mono/mono-1.1.6-r1.ebuild4
-rw-r--r--dev-lang/mono/mono-1.1.6.ebuild4
-rw-r--r--dev-lang/mono/mono-1.1.7.ebuild4
8 files changed, 20 insertions, 29 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 7624107da1e4..1e1d549003d1 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.44 2005/05/06 14:28:48 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.45 2005/05/13 00:29:15 latexer Exp $
+
+ 13 May 2005; Peter Johanson <latexer@gentoo.org> mono-1.0.5-r5.ebuild,
+ mono-1.0.6.ebuild, mono-1.1.4.ebuild, mono-1.1.5-r1.ebuild,
+ mono-1.1.6.ebuild, mono-1.1.6-r1.ebuild, mono-1.1.7.ebuild:
+ have_NPTL is going the way of the dodo.
06 May 2005; Peter Johanson <latexer@gentoo.org> mono-1.1.7.ebuild:
Force tls=__thread on amd64. See bug #83770.
diff --git a/dev-lang/mono/mono-1.0.5-r5.ebuild b/dev-lang/mono/mono-1.0.5-r5.ebuild
index ea9f36de28f1..53e26af3bae1 100644
--- a/dev-lang/mono/mono-1.0.5-r5.ebuild
+++ b/dev-lang/mono/mono-1.0.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.0.5-r5.ebuild,v 1.3 2005/03/21 19:51:38 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.0.5-r5.ebuild,v 1.4 2005/05/13 00:29:15 latexer Exp $
inherit eutils mono flag-o-matic debug
@@ -68,18 +68,11 @@ src_compile() {
strip-flags
local myconf="--with-sigaltstack=yes"
- if use nptl && have_NPTL
+ if use nptl
then
myconf="${myconf} --with-tls=__thread"
sed -i "s: -fexceptions::" ${S}/libgc/configure.host
else
- if have_NPTL
- then
- ewarn "NPTL glibc detected, but nptl USE flag is not set."
- ewarn "This may cause some problems for mono as it will be"
- ewarn "compiled with normal pthread support."
- fi
-
myconf="${myconf} --with-tls=pthread"
fi
diff --git a/dev-lang/mono/mono-1.0.6.ebuild b/dev-lang/mono/mono-1.0.6.ebuild
index d7e95e8ea1d6..3b46468a1058 100644
--- a/dev-lang/mono/mono-1.0.6.ebuild
+++ b/dev-lang/mono/mono-1.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.0.6.ebuild,v 1.1 2005/03/11 03:14:01 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.0.6.ebuild,v 1.2 2005/05/13 00:29:15 latexer Exp $
inherit eutils mono flag-o-matic debug
@@ -69,18 +69,11 @@ src_compile() {
strip-flags
local myconf="--with-sigaltstack=yes"
- if use nptl && have_NPTL
+ if use nptl
then
myconf="${myconf} --with-tls=__thread"
sed -i "s: -fexceptions::" ${S}/libgc/configure.host
else
- if have_NPTL
- then
- ewarn "NPTL glibc detected, but nptl USE flag is not set."
- ewarn "This may cause some problems for mono as it will be"
- ewarn "compiled with normal pthread support."
- fi
-
myconf="${myconf} --with-tls=pthread"
fi
diff --git a/dev-lang/mono/mono-1.1.4.ebuild b/dev-lang/mono/mono-1.1.4.ebuild
index 3a9c6ff68c0a..0c54ae57d4dc 100644
--- a/dev-lang/mono/mono-1.1.4.ebuild
+++ b/dev-lang/mono/mono-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.4.ebuild,v 1.4 2005/04/29 01:59:05 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.4.ebuild,v 1.5 2005/05/13 00:29:15 latexer Exp $
inherit eutils mono flag-o-matic
@@ -39,7 +39,7 @@ src_compile() {
strip-flags
local myconf="--with-sigaltstack=yes --with-preview=yes"
- if use nptl && have_NPTL
+ if use nptl
then
myconf="${myconf} --with-tls=__thread"
else
diff --git a/dev-lang/mono/mono-1.1.5-r1.ebuild b/dev-lang/mono/mono-1.1.5-r1.ebuild
index 9f3cb7755666..ef3636c82bd3 100644
--- a/dev-lang/mono/mono-1.1.5-r1.ebuild
+++ b/dev-lang/mono/mono-1.1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.5-r1.ebuild,v 1.4 2005/04/29 01:59:05 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.5-r1.ebuild,v 1.5 2005/05/13 00:29:15 latexer Exp $
inherit eutils mono flag-o-matic
@@ -63,7 +63,7 @@ src_compile() {
strip-flags
local myconf="--with-preview=yes"
- if use nptl && have_NPTL
+ if use nptl
then
myconf="${myconf} --with-tls=__thread"
else
diff --git a/dev-lang/mono/mono-1.1.6-r1.ebuild b/dev-lang/mono/mono-1.1.6-r1.ebuild
index 6f3a024e0069..3923e63d4054 100644
--- a/dev-lang/mono/mono-1.1.6-r1.ebuild
+++ b/dev-lang/mono/mono-1.1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.6-r1.ebuild,v 1.2 2005/04/29 01:59:05 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.6-r1.ebuild,v 1.3 2005/05/13 00:29:15 latexer Exp $
inherit eutils mono flag-o-matic
@@ -65,7 +65,7 @@ src_compile() {
strip-flags
local myconf="--with-preview=yes"
- if use nptl && have_NPTL
+ if use nptl
then
myconf="${myconf} --with-tls=__thread"
else
diff --git a/dev-lang/mono/mono-1.1.6.ebuild b/dev-lang/mono/mono-1.1.6.ebuild
index 7604a88b02e1..0e00a1986c0c 100644
--- a/dev-lang/mono/mono-1.1.6.ebuild
+++ b/dev-lang/mono/mono-1.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.6.ebuild,v 1.3 2005/04/29 01:59:05 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.6.ebuild,v 1.4 2005/05/13 00:29:15 latexer Exp $
inherit eutils mono flag-o-matic
@@ -62,7 +62,7 @@ src_compile() {
strip-flags
local myconf="--with-preview=yes"
- if use nptl && have_NPTL
+ if use nptl
then
myconf="${myconf} --with-tls=__thread"
else
diff --git a/dev-lang/mono/mono-1.1.7.ebuild b/dev-lang/mono/mono-1.1.7.ebuild
index dc1a6cd7819f..d061c9a6516c 100644
--- a/dev-lang/mono/mono-1.1.7.ebuild
+++ b/dev-lang/mono/mono-1.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.7.ebuild,v 1.2 2005/05/06 14:28:48 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.7.ebuild,v 1.3 2005/05/13 00:29:15 latexer Exp $
inherit eutils mono flag-o-matic
@@ -59,7 +59,7 @@ src_compile() {
then
myconf="${myconf} --with-tls=__thread"
else
- if use nptl && have_NPTL
+ if use nptl
then
myconf="${myconf} --with-tls=__thread"
else