summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-02-18 14:46:29 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-02-18 14:46:29 +0000
commitfe46accb8f7952c81b33710b13a1947b9cb7f177 (patch)
treecd80728f1a517e6e2b8f4e5531c192b8b929a05a /dev-lang/mosml/mosml-2.01.ebuild
parentRemoving old release candidates. (Manifest recommit) (diff)
downloadgentoo-2-fe46accb8f7952c81b33710b13a1947b9cb7f177.tar.gz
gentoo-2-fe46accb8f7952c81b33710b13a1947b9cb7f177.tar.bz2
gentoo-2-fe46accb8f7952c81b33710b13a1947b9cb7f177.zip
Version bump.
Diffstat (limited to 'dev-lang/mosml/mosml-2.01.ebuild')
-rw-r--r--dev-lang/mosml/mosml-2.01.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lang/mosml/mosml-2.01.ebuild b/dev-lang/mosml/mosml-2.01.ebuild
new file mode 100644
index 000000000000..40a4d63aad51
--- /dev/null
+++ b/dev-lang/mosml/mosml-2.01.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01.ebuild,v 1.1 2004/02/18 14:46:29 plasmaroo Exp $
+
+S="${WORKDIR}/${PN}/src"
+DESCRIPTION="Moscow ML - a lightweight implementation of Standard ML (SML)"
+SRC_URI="http://www.dina.kvl.dk/~sestoft/mosml/mos201src.tar.gz"
+HOMEPAGE="http://www.dina.dk/~sestoft/mosml.html"
+LICENSE="GPL-2"
+DEPEND=""
+KEYWORDS="~x86"
+SLOT="0"
+
+src_compile() {
+
+ emake MOSMLHOME=/opt/mosml world || die
+
+}
+
+src_install () {
+
+ make MOSMLHOME=${D}/opt/mosml install || die
+ rm ${D}/opt/mosml/lib/camlrunm # This is a bad symlink
+ echo "#!/opt/mosml/bin/camlrunm" > ${D}/opt/mosml/lib/header
+
+ dodoc ../README
+ into /usr/bin
+ dosym /opt/mosml/bin/mosml /usr/bin/mosml
+ dosym /opt/mosml/bin/mosmlc /usr/bin/mosmlc
+ dosym /opt/mosml/bin/mosmllex /usr/bin/mosmllex
+ dosym /opt/mosml/bin/mosmlyac /usr/bin/mosmlyac
+ dosym /opt/mosml/bin/camlrunm /usr/bin/camlrunm
+ dosym /opt/mosml/bin/camlrunm /opt/mosml/lib/camlrunm
+
+}