summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-22 03:30:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-22 03:30:17 +0000
commit082448cda7d65113e5260ecea58f3b99bee05951 (patch)
tree3da2eb68c3aea026dc197ae9096c549b70106747 /dev-lang/niecza/niecza-19.ebuild
parentInitial import, ebuilds by me (diff)
downloadgentoo-2-082448cda7d65113e5260ecea58f3b99bee05951.tar.gz
gentoo-2-082448cda7d65113e5260ecea58f3b99bee05951.tar.bz2
gentoo-2-082448cda7d65113e5260ecea58f3b99bee05951.zip
Initial import, ebuilds by me
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/niecza/niecza-19.ebuild')
-rw-r--r--dev-lang/niecza/niecza-19.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-lang/niecza/niecza-19.ebuild b/dev-lang/niecza/niecza-19.ebuild
new file mode 100644
index 000000000000..1d722ecbc29a
--- /dev/null
+++ b/dev-lang/niecza/niecza-19.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/niecza/niecza-19.ebuild,v 1.1 2012/08/22 03:30:17 patrick Exp $
+
+EAPI=4
+
+inherit eutils multilib
+
+GITHUB_CRAP="sorear-niecza-3743eb0"
+
+DESCRIPTION="A Perl 6 compiler targetting the CLR with an experimental focus on optimizations."
+HOMEPAGE="https://github.com/sorear/niecza"
+#SRC_URI="https://github.com/downloads/sorear/${PN}/${P}.zip"
+SRC_URI="https://github.com/sorear/niecza/zipball/v19 -> niecza-19.zip"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}
+ || ( dev-lang/niecza-bin dev-lang/niecza )"
+
+S=${WORKDIR}/${GITHUB_CRAP}
+
+src_prepare() {
+ epatch ${FILESDIR}/fix-bootstrap.patch || die "Failed to fix"
+ cd ${S}
+ # bootstrap only works from git dirs? sigh :)
+ sed -i -e 's:@git describe --tags:echo "v19":' Makefile
+ # silly workaround for stuff trying to write everywhere: copy the installed niecza here (sigh)
+ # since we have different installation paths for the bin version we need to check here
+ mkdir boot -p
+ if has_version dev-lang/niecza; then
+ cp -r /opt/niecza/* boot/
+ else
+ cp -r /opt/niecza-bin/* boot/
+ fi
+}
+
+src_configure() { :; }
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ mkdir -p ${D}/opt/niecza
+ for i in docs lib obj run README.pod; do
+ cp -r ${S}/$i ${D}/opt/niecza/ || die "Failed to install"
+ done
+}