summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2006-11-07 00:25:53 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2006-11-07 00:25:53 +0000
commit770c9ea2254c3b8f50b726b1f13fcb7a17a080b2 (patch)
tree13f6532bf666ff5ec316b62a30d14e82cb80d956 /dev-lang/ocaml/ocaml-3.09.2.ebuild
parentAdd patch to fix downloaded imap mail loss. (diff)
downloadgentoo-2-770c9ea2254c3b8f50b726b1f13fcb7a17a080b2.tar.gz
gentoo-2-770c9ea2254c3b8f50b726b1f13fcb7a17a080b2.tar.bz2
gentoo-2-770c9ea2254c3b8f50b726b1f13fcb7a17a080b2.zip
Disable native code generation on ppc64 (bug #149014).
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.09.2.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.09.2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ocaml-3.09.2.ebuild b/dev-lang/ocaml/ocaml-3.09.2.ebuild
index b4df9f15b7b4..bb0120a02be8 100644
--- a/dev-lang/ocaml/ocaml-3.09.2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.09.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.2.ebuild,v 1.8 2006/11/05 12:20:13 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.2.ebuild,v 1.9 2006/11/07 00:25:53 nattfodd Exp $
inherit flag-o-matic eutils multilib
@@ -45,8 +45,11 @@ src_compile() {
sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
make world || die
- make opt || die
- make opt.opt || die
+ # Native code generation unsupported on some archs
+ if ! use ppc64 ; then
+ make opt || die
+ make opt.opt || die
+ fi
}
src_install() {