summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-01-09 12:46:58 +0000
committerMark Wright <gienah@gentoo.org>2012-01-09 12:46:58 +0000
commitf52060739072d266b538065692a8c24b1e434db8 (patch)
tree0d61a092fa1d3d3d6566c85841e7488cff93c76f /dev-lang/polyml
parentTodays Python Patches (diff)
downloadgentoo-2-f52060739072d266b538065692a8c24b1e434db8.tar.gz
gentoo-2-f52060739072d266b538065692a8c24b1e434db8.tar.bz2
gentoo-2-f52060739072d266b538065692a8c24b1e434db8.zip
Fix upstream bug: --without-portable was equivalent to --with-portable. Add tests.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/polyml')
-rw-r--r--dev-lang/polyml/ChangeLog7
-rw-r--r--dev-lang/polyml/files/polyml-5.4.1-configure.patch11
-rw-r--r--dev-lang/polyml/polyml-5.4.1.ebuild18
3 files changed, 31 insertions, 5 deletions
diff --git a/dev-lang/polyml/ChangeLog b/dev-lang/polyml/ChangeLog
index 426c34292e52..97503b981dfd 100644
--- a/dev-lang/polyml/ChangeLog
+++ b/dev-lang/polyml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/polyml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/ChangeLog,v 1.5 2012/01/08 15:25:53 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/ChangeLog,v 1.6 2012/01/09 12:46:58 gienah Exp $
+
+ 09 Jan 2012; Mark Wright <gienah@gentoo.org> polyml-5.4.1.ebuild,
+ +files/polyml-5.4.1-configure.patch:
+ Fix upstream bug: --without-portable was equivalent to --with-portable. Add
+ tests.
08 Jan 2012; Mark Wright <gienah@gentoo.org> polyml-5.4.1.ebuild:
Thanks to few_ and xarthisius for reviewing, remove econf repetition, - on
diff --git a/dev-lang/polyml/files/polyml-5.4.1-configure.patch b/dev-lang/polyml/files/polyml-5.4.1-configure.patch
new file mode 100644
index 000000000000..aaaed02f8e16
--- /dev/null
+++ b/dev-lang/polyml/files/polyml-5.4.1-configure.patch
@@ -0,0 +1,11 @@
+--- polyml.5.4.1-orig/configure.ac 2010-09-03 21:22:40.000000000 +1000
++++ polyml.5.4.1/configure.ac 2012-01-09 22:44:04.153668402 +1100
+@@ -321,7 +321,7 @@
+ AC_ARG_WITH([portable],
+ [AS_HELP_STRING([--with-portable],
+ [Build the portable interpreter version of Poly/ML instead of native @<:@default=no@:>@])], [
+- ac_cv_with_portable=yes], [
++ ac_cv_with_portable="$withval"], [
+ ac_cv_with_portable=no])
+
+ case "${host_cpu}" in
diff --git a/dev-lang/polyml/polyml-5.4.1.ebuild b/dev-lang/polyml/polyml-5.4.1.ebuild
index 7571494a9201..b44696a5fc1d 100644
--- a/dev-lang/polyml/polyml-5.4.1.ebuild
+++ b/dev-lang/polyml/polyml-5.4.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/polyml-5.4.1.ebuild,v 1.2 2012/01/08 15:25:53 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/polyml-5.4.1.ebuild,v 1.3 2012/01/09 12:46:58 gienah Exp $
EAPI="4"
-inherit base
+inherit base autotools
MY_P=${PN}.${PV}
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="X +gmp portable +threads"
+IUSE="X +gmp portable test +threads"
RDEPEND="X? ( x11-libs/openmotif )
gmp? ( >=dev-libs/gmp-5 )
@@ -24,7 +24,13 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
-PATCHES=("${FILESDIR}/${PN}-5.4.1-asm.patch")
+PATCHES=("${FILESDIR}/${PN}-5.4.1-configure.patch"
+ "${FILESDIR}/${PN}-5.4.1-asm.patch")
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
src_configure() {
econf \
@@ -33,3 +39,7 @@ src_configure() {
$(use_with portable) \
$(use_with threads)
}
+
+src_test() {
+ emake tests || die "tests failed"
+}