summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-29 16:06:26 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-29 16:06:26 +0000
commitc62bd75eec23454a7990910eef891a0cb2c8c67b (patch)
tree4d45299486ec6c806297679e66ef22eed04066c2 /dev-lang/python/python-2.3.6-r5.ebuild
parentpython_mod_{cleanup,optimize} are ROOT aware. Quoting. (diff)
downloadgentoo-2-c62bd75eec23454a7990910eef891a0cb2c8c67b.tar.gz
gentoo-2-c62bd75eec23454a7990910eef891a0cb2c8c67b.tar.bz2
gentoo-2-c62bd75eec23454a7990910eef891a0cb2c8c67b.zip
python_mod_optimize is ROOT aware.
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-lang/python/python-2.3.6-r5.ebuild')
-rw-r--r--dev-lang/python/python-2.3.6-r5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/python/python-2.3.6-r5.ebuild b/dev-lang/python/python-2.3.6-r5.ebuild
index 0ace3b89891e..400ab496aaab 100644
--- a/dev-lang/python/python-2.3.6-r5.ebuild
+++ b/dev-lang/python/python-2.3.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.6-r5.ebuild,v 1.1 2008/04/18 14:26:25 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.6-r5.ebuild,v 1.2 2008/05/29 16:06:26 hawking Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -193,7 +193,7 @@ pkg_postinst() {
python_makesym
python_mod_optimize
- python_mod_optimize -x site-packages -x test ${myroot}/usr/$(get_libdir)/python${PYVER}
+ python_mod_optimize -x site-packages -x test /usr/$(get_libdir)/python${PYVER}
# workaround possible python-upgrade-breaks-portage situation
if [ ! -f ${myroot}/usr/lib/portage/pym/portage.py ]; then
@@ -201,7 +201,7 @@ pkg_postinst() {
einfo "Working around possible python-portage upgrade breakage"
mkdir -p ${myroot}/usr/lib/portage/pym
cp ${myroot}/usr/lib/python2.2/site-packages/{portage,xpak,output,cvstree,getbinpkg,emergehelp,dispatch_conf}.py ${myroot}/usr/lib/portage/pym
- python_mod_optimize ${myroot}/usr/lib/portage/pym
+ python_mod_optimize /usr/lib/portage/pym
fi
fi