summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-06-10 11:15:38 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-06-10 11:15:38 +0000
commit1c70e2ebf3e0158577154dd54c5c557ee4e3a096 (patch)
tree10a5f4acbd3d012bcfabacaffe495a8b19dd8cb0 /dev-lang/smlnj/smlnj-110.0.7.ebuild
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-1c70e2ebf3e0158577154dd54c5c557ee4e3a096.tar.gz
gentoo-2-1c70e2ebf3e0158577154dd54c5c557ee4e3a096.tar.bz2
gentoo-2-1c70e2ebf3e0158577154dd54c5c557ee4e3a096.zip
Fix a great number of bugs, now we have the latest release and working versions... working!
Diffstat (limited to 'dev-lang/smlnj/smlnj-110.0.7.ebuild')
-rw-r--r--dev-lang/smlnj/smlnj-110.0.7.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/dev-lang/smlnj/smlnj-110.0.7.ebuild b/dev-lang/smlnj/smlnj-110.0.7.ebuild
new file mode 100644
index 000000000000..43b405d9f4fe
--- /dev/null
+++ b/dev-lang/smlnj/smlnj-110.0.7.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smlnj/smlnj-110.0.7.ebuild,v 1.1 2004/06/10 11:15:38 mattam Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Standard ML of New Jersey compiler and libraries"
+
+SRC_URI="mirror://${P}-bin.x86-unix.tar.Z
+mirror://${P}-config.tar.Z
+mirror://${P}-runtime.tar.Z
+mirror://${P}-ml-lex.tar.Z
+mirror://${P}-ml-yacc.tar.Z
+mirror://${P}-ml-burg.tar.Z
+mirror://${P}-sml-nj.tar.Z
+mirror://${P}-smlnj-c.tar.Z
+mirror://${P}-smlnj-lib.tar.Z
+mirror://${P}-cml.tar.Z
+mirror://${P}-cm.tar.Z
+mirror://${P}-eXene.tar.Z"
+
+HOMEPAGE="http://www.smlnj.org/"
+
+LICENSE="BSD"
+KEYWORDS="-* x86"
+
+SLOT="0"
+DEPEND="virtual/glibc"
+
+SMLNJ_DEST="/usr/lib/smlnj"
+SMLNJ_TARGETS="./config/targets"
+
+GEN_POSIX_NAMES_PATCH="15i\n#\n.\nj\nw\nq"
+
+ARCH_BOOT="bin.${ARCH}-unix"
+
+src_unpack() {
+ unpack ${A}
+
+ dirs=`ls ${WORKDIR}`
+ mkdir ${WORKDIR}/src
+
+ for i in $dirs; do
+ if test "$i" != "config" -a "$i" != ${ARCH_BOOT}; then
+ mv ${WORKDIR}/${i} ${WORKDIR}/src
+ fi
+ done
+
+ printf ${GEN_POSIX_NAMES_PATCH} | ed -s ${WORKDIR}/src/runtime/config/gen-posix-names.sh
+
+ # This patch removes -ansi flags from the x86-linux Makefiles because they conflict
+ # with both gcc-3.3 and will cause issues is sysmacros.h is included as well.
+ # Closes Bug #30207
+ epatch ${FILESDIR}/${P}-gcc33-quirk-fix.patch
+
+ # smlnj generates a startup script based on the location of the executables
+ # in the filesystem during bootstrapping phase. This solution gets fooled
+ # by portage as compilation location is different than installation location.
+ # This patch solves this problem:
+ epatch ${FILESDIR}/${P}-bindir.patch
+}
+
+src_compile() {
+ SMLNJ_HOME=${WORKDIR}
+ cd ${WORKDIR}
+
+ ./config/install.sh || die
+}
+
+src_install () {
+ dodir ${SMLNJ_DEST}
+ cd ${WORKDIR}
+
+ sed -i -e "s/head -1/head -n 1/" bin/.run-sml
+
+ cp -R bin ${D}/${SMLNJ_DEST}
+ cp -R lib ${D}/${SMLNJ_DEST}
+
+ dodir /etc/env.d
+ echo -e SMLNJ_HOME=${SMLNJ_DEST} > ${D}/etc/env.d/10smlnj
+
+ #need to provide symlinks into /usr/bin
+ dodir /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-burg /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-lex /usr/bin
+ dosym ${SMLNJ_DEST}/bin/ml-yacc /usr/bin
+ dosym ${SMLNJ_DEST}/bin/sml /usr/bin
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You need to run env-update to get a working installation"
+ einfo
+} \ No newline at end of file