summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-12 13:56:04 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-12 13:56:04 +0000
commit435b5c94a5aead573723c057ee93e85db27b6e37 (patch)
tree98b43e294d40c80ea3aee9c86239b8c5688ae314 /dev-lang/stratego
parentChoice library for Stratego (diff)
downloadgentoo-2-435b5c94a5aead573723c057ee93e85db27b6e37.tar.gz
gentoo-2-435b5c94a5aead573723c057ee93e85db27b6e37.tar.bz2
gentoo-2-435b5c94a5aead573723c057ee93e85db27b6e37.zip
Stratego 0.7
Diffstat (limited to 'dev-lang/stratego')
-rw-r--r--dev-lang/stratego/ChangeLog24
-rw-r--r--dev-lang/stratego/files/digest-stratego-0.71
-rw-r--r--dev-lang/stratego/stratego-0.7.ebuild32
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-lang/stratego/ChangeLog b/dev-lang/stratego/ChangeLog
new file mode 100644
index 000000000000..a1fca3d2d78f
--- /dev/null
+++ b/dev-lang/stratego/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for dev-lang/stratego
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/stratego/ChangeLog,v 1.1 2002/04/12 13:56:04 karltk Exp $
+
+*stratego-0.7 (11 Apr 2002)
+
+ 11 Apr 2002; Karl Trygve Kalleberg <karltk@gentoo.org> stratego-0.7.ebuild files/digest-stratego-0.7:
+
+ Stratego is a modular language for the specification of fully automatic
+ program transformation systems based on the paradigm of RewritingStrategies.
+
+ In Stratego, basic transformation rules are expressed by means of labeled
+ conditional rewrite rules. Exhaustively applying all rewrite rules in a
+ collection of valid rules is often not desirable; a system of rules can be
+ non-terminating, or, more frequently, non-confluent. The latter means that
+ different outcomes of the normalization process are possible depending on
+ the position of application and the selection of rules. Therefore, it is
+ necessary to have more control over the application of rules. In standard
+ systems based on rewriting, normalization is controlled by a fixed default
+ RewritingStrategy. In such systems more control is achieved by encoding the
+ desired strategy with additional rewrite rules that spell out a traversal
+ over the abstract syntax tree and apply the transformations in the desired
+ order.
+
diff --git a/dev-lang/stratego/files/digest-stratego-0.7 b/dev-lang/stratego/files/digest-stratego-0.7
new file mode 100644
index 000000000000..203fb4992ec0
--- /dev/null
+++ b/dev-lang/stratego/files/digest-stratego-0.7
@@ -0,0 +1 @@
+MD5 cee67b2512c3cbaf7be7ae140ca82e23 stratego-0.7.tar.gz 1476371
diff --git a/dev-lang/stratego/stratego-0.7.ebuild b/dev-lang/stratego/stratego-0.7.ebuild
new file mode 100644
index 000000000000..1fbad27194f9
--- /dev/null
+++ b/dev-lang/stratego/stratego-0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/stratego/stratego-0.7.ebuild,v 1.1 2002/04/12 13:56:04 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Stratego term-rewriting language"
+SRC_URI="http://www.stratego-language.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.stratego-language.org"
+
+DEPEND=">=dev-libs/aterm-1.6.6
+ >=dev-libs/cpl-stratego-0.4"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+}