summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-04 18:35:33 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-11-04 18:35:33 +0000
commit032c0d4ae2913dc258b4e28976075735fef1611d (patch)
tree385f7228fba1273f1aa67f98cf8ffffcee595f3d /dev-lang/tk
parentBuild with boost-1.50 Bug #425606 (diff)
downloadgentoo-2-032c0d4ae2913dc258b4e28976075735fef1611d.tar.gz
gentoo-2-032c0d4ae2913dc258b4e28976075735fef1611d.tar.bz2
gentoo-2-032c0d4ae2913dc258b4e28976075735fef1611d.zip
Patch 8.5.11 to build on uclibc, bug #441630
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog7
-rw-r--r--dev-lang/tk/files/tk-8.5.11-fix-name-collision-uclibc.patch35
-rw-r--r--dev-lang/tk/tk-8.5.11-r1.ebuild5
-rw-r--r--dev-lang/tk/tk-8.5.11.ebuild5
4 files changed, 49 insertions, 3 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index 84eabe2516d2..c842a57838a3 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.173 2012/08/07 02:34:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.174 2012/11/04 18:35:33 blueness Exp $
+
+ 04 Nov 2012; Anthony G. Basile <blueness@gentoo.org>
+ +files/tk-8.5.11-fix-name-collision-uclibc.patch, tk-8.5.11-r1.ebuild,
+ tk-8.5.11.ebuild:
+ Patch 8.5.11 to build on uclibc, bug #441630
03 Aug 2012; Mike Frysinger <vapier@gentoo.org> tk-8.5.11-r1.ebuild:
Make sure we link against fontconfig since we use it.
diff --git a/dev-lang/tk/files/tk-8.5.11-fix-name-collision-uclibc.patch b/dev-lang/tk/files/tk-8.5.11-fix-name-collision-uclibc.patch
new file mode 100644
index 000000000000..a92717ac9d8b
--- /dev/null
+++ b/dev-lang/tk/files/tk-8.5.11-fix-name-collision-uclibc.patch
@@ -0,0 +1,35 @@
+diff -Naur tk8.5.11.orig/generic/ttk/ttkTreeview.c tk8.5.11/generic/ttk/ttkTreeview.c
+--- tk8.5.11.orig/generic/ttk/ttkTreeview.c 2011-11-01 10:05:27.000000000 -0400
++++ tk8.5.11/generic/ttk/ttkTreeview.c 2012-11-04 13:23:41.000000000 -0500
+@@ -485,11 +485,11 @@
+ }
+ }
+
+-/* + unshare(objPtr) --
++/* + unshareObj(objPtr) --
+ * Ensure that a Tcl_Obj * has refcount 1 -- either return objPtr
+ * itself, or a duplicated copy.
+ */
+-static Tcl_Obj *unshare(Tcl_Obj *objPtr)
++static Tcl_Obj *unshareObj(Tcl_Obj *objPtr)
+ {
+ if (Tcl_IsShared(objPtr)) {
+ Tcl_Obj *newObj = Tcl_DuplicateObj(objPtr);
+@@ -2525,7 +2525,7 @@
+ } else { /* set column */
+ int length;
+
+- item->valuesObj = unshare(item->valuesObj);
++ item->valuesObj = unshareObj(item->valuesObj);
+
+ /* Make sure -values is fully populated:
+ */
+@@ -2826,7 +2826,7 @@
+ */
+ for (parent = item->parent; parent; parent = parent->parent) {
+ if (!(parent->state & TTK_STATE_OPEN)) {
+- parent->openObj = unshare(parent->openObj);
++ parent->openObj = unshareObj(parent->openObj);
+ Tcl_SetBooleanObj(parent->openObj, 1);
+ parent->state |= TTK_STATE_OPEN;
+ TtkRedisplayWidget(&tv->core);
diff --git a/dev-lang/tk/tk-8.5.11-r1.ebuild b/dev-lang/tk/tk-8.5.11-r1.ebuild
index a9800107bc6a..f0bf4114704c 100644
--- a/dev-lang/tk/tk-8.5.11-r1.ebuild
+++ b/dev-lang/tk/tk-8.5.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.11-r1.ebuild,v 1.2 2012/08/03 19:29:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.11-r1.ebuild,v 1.3 2012/11/04 18:35:32 blueness Exp $
EAPI=4
@@ -45,6 +45,9 @@ src_prepare() {
# copy the tcl patch
epatch "${FILESDIR}"/tcl-8.5.9-gentoo-fbsd.patch
+ # Bug 441630
+ epatch "${FILESDIR}"/${PN}-8.5.11-fix-name-collision-uclibc.patch
+
# Make sure we use the right pkg-config, and link against fontconfig
# (since the code base uses Fc* functions).
sed -i \
diff --git a/dev-lang/tk/tk-8.5.11.ebuild b/dev-lang/tk/tk-8.5.11.ebuild
index 5c97f5e7c68e..2ddcfd89ef82 100644
--- a/dev-lang/tk/tk-8.5.11.ebuild
+++ b/dev-lang/tk/tk-8.5.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.11.ebuild,v 1.5 2012/04/26 19:49:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.5.11.ebuild,v 1.6 2012/11/04 18:35:32 blueness Exp $
EAPI=4
@@ -43,6 +43,9 @@ src_prepare() {
# copy the tcl patch
epatch "${FILESDIR}"/tcl-8.5.9-gentoo-fbsd.patch
+ # Bug 441630
+ epatch "${FILESDIR}"/${PN}-8.5.11-fix-name-collision-uclibc.patch
+
sed -i 's/FT_New_Face/XftFontOpen/g' unix/configure.in || die
cd "${S}"/unix