summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-27 20:27:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-27 20:27:31 +0000
commit25aa0a4eeb460dea7657d3ff1824fc19c1e89bb6 (patch)
tree5f4fd541682ad988cf2d0094f1519843c12d5534 /dev-lang/vala
parentDepends on dev-libs/openssl (#342655). EAPI=3 (diff)
downloadgentoo-2-25aa0a4eeb460dea7657d3ff1824fc19c1e89bb6.tar.gz
gentoo-2-25aa0a4eeb460dea7657d3ff1824fc19c1e89bb6.tar.bz2
gentoo-2-25aa0a4eeb460dea7657d3ff1824fc19c1e89bb6.zip
Version bump.
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/vala')
-rw-r--r--dev-lang/vala/ChangeLog7
-rw-r--r--dev-lang/vala/vala-0.10.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-lang/vala/ChangeLog b/dev-lang/vala/ChangeLog
index d77f2713c7d0..b54d4bc0abbc 100644
--- a/dev-lang/vala/ChangeLog
+++ b/dev-lang/vala/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/vala
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.28 2010/10/06 22:02:03 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/ChangeLog,v 1.29 2010/10/27 20:27:31 eva Exp $
+
+*vala-0.10.1 (27 Oct 2010)
+
+ 27 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org> +vala-0.10.1.ebuild:
+ Version bump.
*vala-0.11.0 (06 Oct 2010)
diff --git a/dev-lang/vala/vala-0.10.1.ebuild b/dev-lang/vala/vala-0.10.1.ebuild
new file mode 100644
index 000000000000..efaf0567e4ce
--- /dev/null
+++ b/dev-lang/vala/vala-0.10.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/vala-0.10.1.ebuild,v 1.1 2010/10/27 20:27:31 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Vala - Compiler for the GObject type system"
+HOMEPAGE="http://live.gnome.org/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test +vapigen coverage"
+
+RDEPEND=">=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ || ( sys-devel/bison dev-util/byacc dev-util/yacc )
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ test? ( dev-libs/dbus-glib )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-unversioned
+ $(use_enable vapigen)
+ $(use_enable coverage)"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+ if use coverage && has ccache ${FEATURES}; then
+ ewarn "USE=coverage does not work well with ccache; valac and libvala"
+ ewarn "built with ccache and USE=coverage create temporary files inside"
+ ewarn "CCACHE_DIR and mess with ccache's working, as well as causing"
+ ewarn "sandbox violations when used to compile other packages."
+ ewarn "It is STRONGLY recommended that you disable one of them."
+ fi
+}