summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-10 06:51:30 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-10 06:51:30 +0000
commit42f5c2e2da8a06e3f2ad408b4e71cae539a719d4 (patch)
tree949d607962bfb299ba89c4b75b6312615c2320cb /dev-lang/wml/wml-2.0.9-r1.ebuild
parentrev bump for security reason (diff)
downloadgentoo-2-42f5c2e2da8a06e3f2ad408b4e71cae539a719d4.tar.gz
gentoo-2-42f5c2e2da8a06e3f2ad408b4e71cae539a719d4.tar.bz2
gentoo-2-42f5c2e2da8a06e3f2ad408b4e71cae539a719d4.zip
Use system libpcre instead of bundled one #105138.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lang/wml/wml-2.0.9-r1.ebuild')
-rw-r--r--dev-lang/wml/wml-2.0.9-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/wml/wml-2.0.9-r1.ebuild b/dev-lang/wml/wml-2.0.9-r1.ebuild
new file mode 100644
index 000000000000..939b9ff9ee68
--- /dev/null
+++ b/dev-lang/wml/wml-2.0.9-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/wml/wml-2.0.9-r1.ebuild,v 1.1 2005/09/10 06:51:30 vapier Exp $
+
+inherit fixheadtails eutils
+
+DESCRIPTION="Website META Language"
+HOMEPAGE="http://www.engelschall.com/sw/wml/"
+SRC_URI="http://www.engelschall.com/sw/wml/distrib/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libpcre
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.58"
+
+src_unpack() {
+ unpack ${A}
+ ht_fix_all
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-autotools-update.patch
+ export WANT_AUTOCONF='2.5'
+ for d in $(find "${S}" -mindepth 2 -name configure -printf '%h ') ; do
+ cd "${d}"
+ autoconf || die "autoconf in ${d}"
+ done
+ (cd "${S}"/wml_backend/p2_mp4h && automake) || die "automake failed in wml_backend/p2_mp4h"
+}
+
+src_compile() {
+ econf --libdir=/usr/lib/wml || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+ dodoc ANNOUNCE BUGREPORT C* INSTALL MANIFEST README* SUPPORT VERSION*
+}